+ Responder ao Tópico



  1. #1

    Padrão Ajuda em redirecionameno de Link - Mikrotik

    Boa tarde pessoal, mais uma vez.
    Estou com o seguinte problema.

    Tenho duas RB's aqui.. Na RB_1 que é a RB principal, chegam dois links: LINK_1 e LINK_2.

    Qual regra uso aqui, para fazer a RB_2 trabalhar com o LINK 2?

    - Na RB_1 está setado o ip 192.168.254.1/30;
    - Na RB_2 está setado o ip 192.168.254.2/30;
    - Na RB_2 tenho um dhcp usado para hotspot o qual está 192.168.200.0/22.

    alguém tem esse conhecimento que possa compartilhar?

    obs: no LINK_1 funciona perfeitamente..como padrão, mas no LINK_2 estou tendo esta dificuldade.

    Preciso colocar o link_2 para essa RB_2 para ficar livre o Link_1 para a parte administrativa do meu local de trabalho.


    agradeço desde já, qualquer ajuda.

    Att;

    Pedro Henrique

  2. #2

    Padrão Re: Ajuda em redirecionameno de Link

    Balance pcc ou balance por rotas na RB_1 para poder usar os 2 links ao mesmo tempo

    na parte que você diz "Preciso colocar o link_2 para essa RB_2 para ficar livre o Link_1 para a parte administrativa do meu local de trabalho" É 1 provedor e vc vai deixar link 1 pra vc e link 2 para clientes ou é tudo para uma empresa?



  3. #3

    Padrão Re: Ajuda em redirecionameno de Link

    os dois links são para empresta onde trabalho.. quero definir um deles para a rb onde se encontra o hotspot;.

  4. #4

    Padrão Re: Ajuda em redirecionameno de Link

    Defina as rotas, exemplo:


    /ip route add comment="Rota p/ LINK_1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=LINK_1 scope=30 target-scope=10


    /ip route add comment="Rota p/ LINK_2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=LINK_2 scope=30 target-scope=10






    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_1 passthrough=no src-address=10.1.1.0/22


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_2 passthrough=no src-address=10.2.2.0/24


    Não se esqueça de que é necessário deixar a rota padrão
    Regras do mangle devem preceder outras regras de redirecionamento.



  5. #5

    Padrão

    Citação Postado originalmente por GrandeAmigo Ver Post
    Defina as rotas, exemplo:


    /ip route add comment="Rota p/ LINK_1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=LINK_1 scope=30 target-scope=10


    /ip route add comment="Rota p/ LINK_2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=LINK_2 scope=30 target-scope=10






    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_1 passthrough=no src-address=10.1.1.0/22


    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_2 passthrough=no src-address=10.2.2.0/24


    Não se esqueça de que é necessário deixar a rota padrão
    Regras do mangle devem preceder outras regras de redirecionamento.
    Não funciona.. em partes.. deixa eu explicar..
    até tenho essas regras aqui.. porém não funciona quando tento jogar pra RB_2.

    na RB_1 está o ip 192.168.254.1, e na RB_2 está o ip 192.168.254.2 ( /30);

    quando na regra de filtro mangle eu coloco outra faixa de ip que está na RB_1 consigo navegar pelo LINK_2.


    o que você quis dizer com essa parte:

    Não se esqueça de que é necessário deixar a rota padrão
    Regras do mangle devem preceder outras regras de redirecionamento.
    uso essa regra:

    /ip firewall mangle
    add action=mark-routing chain=prerouting disabled=no new-routing-mark=\
    "LINK_2" passthrough=yes protocol=tcp src-address=172.16.0.180
    add action=mark-routing chain=prerouting disabled=no new-routing-mark=\
    "LINK_2" passthrough=yes protocol=udp src-address=172.16.0.180
    Mas quando coloco o IP da RB_2 no lugar do 172.16.0.180 (Meu próprio PC, regra funcionando.), o qual é 192.168.254.2 (neste caso a RB_2 com este endereço, seria como um cliente, não?)
    até perco acesso a RB_2.

    /ip firewall mangle
    add action=mark-routing chain=prerouting disabled=no new-routing-mark=\
    "LINK_2" passthrough=yes protocol=tcp src-address=192.168.254.2 OU 192.168.254.0/30
    add action=mark-routing chain=prerouting disabled=no new-routing-mark=\
    "LINK_2" passthrough=yes protocol=udp src-address=192.168.254.2 OU 192.168.254.0/30
    ROTAS:

    /ip routeadd check-gateway=ping comment="ROTA DEFAULT LINK_2" disabled=no distance=2 \
    dst-address=0.0.0.0/0 gateway=192.168.25.1 scope=30 target-scope=10
    add comment="PASSAR PELO LINK_2" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.25.1 routing-mark="LINK_2" scope=30 \
    target-scope=10
    add check-gateway=ping comment="ROTA DEFAULT LINK_1" disabled=no distance=1 \
    dst-address=0.0.0.0/0 gateway=187.73.241.25 scope=30 target-scope=10
    add comment="PASSAR PELO LINK_1" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=187.73.241.25 routing-mark="LINK_1" scope=30 \
    target-scope=10
    Complicado.

  6. #6

    Padrão Re: Ajuda em redirecionameno de Link

    Me fala uma coisa

    Os 2 links entram na rb1 vão para a rb2 e lá vc vai separar estes 2 links para grupos distintos
    Grupo1 link1 e Grupo2 link2

    Ou

    Os 2 links entram na rb1, na rb1 vc tira um link1 para o grupo1 e envia o link2 para rb2 para atender o grupo2

    ?



  7. #7

    Padrão Re: Ajuda em redirecionameno de Link

    se a resposta for a opção 2:

    (192.168.2.1 ip do modem 1 / ip na rb1 192.168.2.2 [ether1])
    /ip route add comment="Rota p/ LINK_1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=LINK_1 scope=30 target-scope=10

    (192.168.1.1 ip do modem 2 / ip na rb1 192.168.1.2[ether2])
    /ip route add comment="Rota p/ LINK_2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=LINK_2 scope=30 target-scope=10


    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:

    (10.1.1.1 ip para atender rb principal [ether3])
    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_1 passthrough=no src-address=10.1.1.0/24


    (10.2.2.1 ip para atender rb2 [ether4]) ip na rb2 10.2.2.2
    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_2 passthrough=no src-address=10.2.2.0/24


    Não se esqueça de que é necessário deixar a rota padrão
    0.0.0.0/0 gateway 192.168.2.1 ou gateway 192.168.1.1 a que vc achar melhor

    Regras do mangle devem preceder outras regras de redirecionamento.

  8. #8

    Padrão Re: Ajuda em redirecionameno de Link

    Citação Postado originalmente por GrandeAmigo Ver Post
    Me fala uma coisa

    Os 2 links entram na rb1 vão para a rb2 e lá vc vai separar estes 2 links para grupos distintos
    Grupo1 link1 e Grupo2 link2

    Ou

    Os 2 links entram na rb1, na rb1 vc tira um link1 para o grupo1 e envia o link2 para rb2 para atender o grupo2

    ?

    Exatamente essa segunda situação que quero fazer... os dois links chegam na RB_1; um deles quero deixar para um grupo1 que se encontra na RB_1, o LINK_2, quero que o grupo2 trabalhe, que se encontra na RB_2.

    fiz as regras, mas não funcionam rs.



  9. #9

    Padrão

    Veja as regras:

    Como está setado meu host na regra 172.16.0.180, funciona perfeitamente.. no entanto quando seto o ip da RB_2 (192.168.254.2), mesmo com as outras rotas para eu conseguir acessar a RB_2, perco acesso a ela, e não navega. só desabilitando a regra.

    há outras regras de rotas, e outros filtros mangle também, porque quando vim trabalhar aqui já estava em produção essa configuração.

    o que posso estar fazendo de errado..
    nas regras acima, você define um grupo para LINK_1 e grupo para LINK_2

    *(10.1.1.1 ip para atender rb principal [ether3])*
    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=LINK_1 passthrough=no src-address=10.1.1.0/24
    esse 10.1.1.0/24 seria minha rede interna, correto?
    eu teria que repetir essa regra para todas as redes que quero no grupo1 e no grupo2 ?

    Clique na imagem para uma versão maior

Nome:	         mangle1.jpg
Visualizações:	27
Tamanho: 	63,2 KB
ID:      	58143Clique na imagem para uma versão maior

Nome:	         mangle2.jpg
Visualizações:	26
Tamanho: 	28,5 KB
ID:      	58144Clique na imagem para uma versão maior

Nome:	         rotas.jpg
Visualizações:	27
Tamanho: 	30,8 KB
ID:      	58145