Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Servidor DNS

    Olá bom dia a todos. Sou novo no ramo e gostaria de saber os benefícios e a configuração de uma máquina para montagem de um servidor DNS.

    Desde já agradeço a todos que me ajudarem.

  2. #2

    Padrão Re: Servidor DNS

    Servidor DNS tem por função responder a requisições de nomes.
    Se você não vai usar o servidor DNS para responder por "teus domínios", irá usar para cache de DNS.

    Tendo um servidor cache de DNS na sua rede o primeiro que acessar um determinado domínio vai salvar no cache o retorno do DNS.
    Como o servidor está dentro da sua rede o próximo cliente que buscar a mesma informação vai ter esse retorno na velocidade da sua rede.. imagino eu que até 5ms.

    Olha um exemplo:
    A primeira requisição do servidor DNS:
    Clique na imagem para uma versão maior

Nome:	         primeiro.jpg
Visualizações:	171
Tamanho: 	67,8 KB
ID:      	58471
    Nesse momento ele armazenou em Cache até o tempo limite de vida..

    E agora quem for consultar esse mesmo domínio tem esse tempo de resposta:
    Clique na imagem para uma versão maior

Nome:	         segundo.jpg
Visualizações:	148
Tamanho: 	74,6 KB
ID:      	58472

    Então os benefícios nesse exemplo são:
    Você diminuiu para todos os seus clientes o tempo de pelo menos 170ms original de retorno de DNS para 5ms. (Isso que tem domínios que demoram mais para retornar)
    Isso agiliza a navegação.
    Agora imagine que dentro de 1 site existem diversos domínios..

    Bom, faz um e testa..
    Qualquer máquina responde DNS.. não precisa grandes coisas de hardware.

    Ubuntu Server + Bind.



  3. #3

    Padrão Re: Servidor DNS

    Meu amigo muito obrigado pela explicação.

  4. #4

    Padrão Re: Servidor DNS

    vai colocar só dns nessa máquina???? compra um edgerouter lite que custa 240 reais, economize com a máquina, economize com energia e seja feliz,e é esse o próximo passo para o meu provedor, e contrata o @Arthur Bernardes para configurar para você. abraço



  5. #5

    Padrão Re: Servidor DNS

    Citação Postado originalmente por RODRIGOQUATI Ver Post
    vai colocar só dns nessa máquina???? compra um edgerouter lite que custa 240 reais, economize com a máquina, economize com energia e seja feliz,e é esse o próximo passo para o meu provedor, e contrata o @Arthur Bernardes para configurar para você. abraço
    Interessante. Poderia indicar uma loja para compra?

  6. #6

    Padrão Re: Servidor DNS

    o nosso amigo klabunde ja explicou oque é, pra que server e como ele pode te ajudar, e se voce preferir , procure pelo topico que eu coloquei ensinando um passo a passo para voce criar um servidor DNS, para cache, e respoder por um dominio local. com Centos( sou fã da distro)

    abraço



  7. #7

    Padrão Re: Servidor DNS

    Bom dia amigos

    tenho meu servidor de DNS rodando pelo unbound a um bom tempo e gostaria de saber se e possivel monitorar o desempenho do servidor, saber se ele realmente esta atendendo as minhas necessidades.

    Configurei o meu apartir desse site: http://www.overnix.com/showthread.ph...D-ThunderCache

  8. #8

    Padrão

    @davidmilfont http://produto.mercadolivre.com.br/M...3-erlite-3-_JM vou comprar essa semana pq o dns público tá uma porcaria, os clientes elogiam a velocidade do link mas estão reclamando da demora para resolução de nomes. seja feliz e não gaste energia sem precisar!!!!!



  9. #9

    Padrão Re: Servidor DNS

    Você deve ter um hardware mikrotik com RouterOS ai em algum ligar, uma RB450 ou RB750 pode fazer esse serviço pra você, e é simplíssimo de configurar no RouterOS.

  10. #10

    Padrão Re: Servidor DNS

    Mas se ele usar bind9 por exemplo, é exatamente o mesmo cenário. Se ele tem uma rede que precisa fazer requisição para endereços de internet que estão "fora" da rede dele, é inevitável que ele va ter que recorrer a um serviço de DNS externo, e esse vai ser o caso em 100% das requisições caso ele não mantenha nenhum serviço público dentro da rede dele. Se ele mantem algum serviço publico dentro da rede dele, o servidor DNS será responvável por apenas aquele serviço para a internet. Não tem porque ele ter um DNS público para esse tipo de cenário, a meu ver.

    E neste caso, o MK seria uma resposta suficientemente boa, barata e facil de utilizar.



  11. #11

    Padrão Re: Servidor DNS

    Citação Postado originalmente por RODRIGOQUATI Ver Post
    @davidmilfont http://produto.mercadolivre.com.br/M...3-erlite-3-_JM vou comprar essa semana pq o dns público tá uma porcaria, os clientes elogiam a velocidade do link mas estão reclamando da demora para resolução de nomes. seja feliz e não gaste energia sem precisar!!!!!
    Obrigado @RODRIGOQUATI

  12. #12

    Padrão Re: Servidor DNS

    Citação Postado originalmente por inquiery Ver Post
    Você deve ter um hardware mikrotik com RouterOS ai em algum ligar, uma RB450 ou RB750 pode fazer esse serviço pra você, e é simplíssimo de configurar no RouterOS.
    Poderia dá mais detalhes de como seria a configuração?



  13. #13

    Padrão Re: Servidor DNS

    Não tem mistério david.

    No terminal é só setar os IPs de DNS externos (eu costumo usar o do google e o opendns), assim:

    Código :
    /ip dns set servers=8.8.8.8,8.8.4.4,208.67.220.220,208.67.222.222 allow-remote-requests=yes

    Dessa forma, o MK vai trabalhar como "forwarder", como nosso amigo Arthur falou, porém, ele vai fazer cache de endereços de requisições de toda a sua rede, respondendo muito mais rápido nos pedidos de resolução de nome que ja estão no cache (na velocidade da sua rede).

    Caso você vá usar um MK só para isso, você pode inclusive aumentar o tamanho máximo do cache para um valor bem alto, caso sua rede seja grande, pois não vai usar a memória da routerboard pra outros serviços. Assim:

    Código :
    /ip dns set cache-size=8192KiB

    Assim, o Mk vai usar até 8mb para cache de DNS.

    Se você usar o winbox, é só ir em IP->DNS que tem as opções lá e é bem facil de configurar.


    Eu já usei bind9 durante muito tempo, não percebi diferença de desempenho dele para um MK. Mas note que, não estou dizendo que "não tenha diferença", minha rede aqui é pequena, bem pequena. Pode ser que a solução do Artur seja realmente muito superior em uma rede maior, não sei qual o seu caso. No meu caso é que não há necessidade de ter um hardware muito caro parado para esse serviço.

  14. #14

    Padrão Re: Servidor DNS

    cache dns da RB? sinceramente, isso não é cache , é uma gambi. ja usei e nao gostei. ah( woom 5000 nao funciona com cache da rb)



  15. #15

    Padrão Re: Servidor DNS

    Bom, então se nossos parceiros usam WOM5000, melhor usar um server DNS mesmo, como informado pelo Arhur.
    Eu aqui não uso WOM5000, então não tive problemas com o MK ainda, aqui funciona redondinho.

    Mas no caso de não querer esquentar a cabeça, visto que ja se tem experiência que WOM5000 da problema com o DNS do MK, então melhor montar um servidorzinho mesmo. Como ja foi informado, não precisa de uma grande maquina para DNS. Uma solução meio barata e que pode ser usada para varios fins, seriam montar um Bay-Trail, são baratinhos, pode montar com uma plaquinha com chip J1900 da Asrock ou MSI, e instalar um XenServer nele.

    Dessa forma, você pode virtualizar um OS para usar como servidor DNS, e ainda sobra recursos para virtualizar qualquer outro serviço. Eu aqui, como minha rede é pequena, uso um servidorzinho desse e por enquanto to virtualizando um Debian com Squid, e um servidor Radius. Funciona bem, mas é só uma idéia.

    PS: Agora vem aquele cara dizendo que "tem que ser a maquina tal, pq tem VT-d e um clock tal", mas tem uma coisa muito importante pra lembrar nessas situações: eu sou pobre não posso compra um i7 pra isso.

  16. #16

    Padrão Re: Servidor DNS

    VERDADE inquiery bota um k6 la pra rodar e seje feliz, claro TUDO depende do tamanho da rede, entao quando voce precisar de mais, sua rede vai estar grande, te dando dinheiro, e voce pode comprar um xeon.



  17. #17

    Padrão Re: Servidor DNS

    Servidor caro para DNS?
    Qualquer Pentium II faz DNS...
    Um Linux leve (ubuntu server, centos, ...) ou BSD você instala rapidinho..
    Um P4 com 1Gb de ram e uma boa placa de rede segura MUITA requisição DNS.

  18. #18

    Padrão Re: Servidor DNS

    Obrigado @inquiery,já uso assim,pensei que seria algo diferente.
    Usei por 4 meses o FreeBsd com Unbound e desativei pra ver se havia diferença,mas não notei nenhuma.
    Deve ser porque minha rede é pequena como você citou.



  19. #19

    Padrão Re: Servidor DNS

    Eu não sei sobre o ponto de vista do Marco Civil e da legalidade.. mas você pode gravar os logs das requisições.. e toda informação retirada disso é válida.
    Com um sisteminha simples em PHP é possível pegar esses relatórios e gerar percentuais sobre buscas e afins.
    Pode traçar um perfil do seu cliente.. e ver onde você precisa focar esforços para atender bem.

    Att.

  20. #20

    Padrão Re: Servidor DNS

    falando em quantidade de Requisições, alguem sabe como monitorar? ja quebrei a cabeça e nao descobri como