Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Deve estar sim!Meu script não funciona mais. Já tentei todos os possíveis!

  2. Como funciona? Pode me ajudar?



  3. Então qual seria a solução para contornar esse problema de script? Tenho 2 servidores com versões mais antigas do MK e por enquanto não quero arriscar uma atualização e ficar com a rede parada por algum problema durante o processo.

    Abraço.

  4. Amigão, vai de boa nesse aqui, testado e aprovado tanto nas versões 5.26 e 6.29.1:

    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "USER-CHANGEIP"
    :global ddnspass "SENHA-CHANGEIP"
    :global ddnshost "HOST-CHANGEIP"
    :global ddnsinterface "INTERFACE"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip


    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "ChangeIP: Nenhuma interface $ddnsinterface, por favor cheque a configuração." }


    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }


    :if ([ :typeof $ddnsip ] = "nothing" ) do={


    :log info ("ChangeIP: Sem IP na Interface " . $ddnsinterface . ", por favor verifique.")


    } else={


    :if ($ddnsip != $ddnslastip) do={


    :log info "ChangeIP: Enviando atualização do IP da INTERNET!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip


    } else={


    :log info "ChangeIP: IP da INTERNET não mudou."


    }


    }


    # END OF SCRIPT



  5. @droptux, sim, funciona sim, estou usando ele nesse momento.






Tópicos Similares

  1. Respostas: 0
    Último Post: 03-02-2015, 18:41
  2. Como salvar uma regra ou script pra não perder na hora de reiniciar?
    Por claudinhohw no fórum Sistemas Operacionais
    Respostas: 6
    Último Post: 12-02-2014, 15:52
  3. Quantos clientes posso cadastrar na rb 750
    Por Conectnet no fórum Redes
    Respostas: 6
    Último Post: 26-02-2012, 12:28
  4. Como tratar link dedicado na rb 750
    Por claudiolegal2000 no fórum Redes
    Respostas: 9
    Último Post: 02-09-2010, 21:46
  5. Tem como colocar level 4 na rb 411 ?
    Por starsat no fórum Redes
    Respostas: 12
    Último Post: 13-08-2009, 22:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L