+ Responder ao Tópico



  1. Não, dai já é bem mais complexo. Só com scripts.

    Bloquear um cliente e redirecionar ele para uma pagina, tranquilo. Anúncios já é outro coisa bem diferente, tem que interferir na tráfego dos HTML e injetar código. Com PPPoE acredito que não tenha como fazer no mikrotik.

    A questão de aparecer um aviso antes de ele começar a navegar, depois de logar, até dá, mas vai ter que usar scripts, dai te indico 2 caminhos: estudar e fazer ou contratar um consultor pra fazer pra você.

    Agora, se você quer só uma pagina de bloqueio, cria um profile lá, chama ele de PERFIL_BLOQUEIO por exemplo, e no campo "Address List" do profile, coloca lá assim "CLIENTE_BLOQUEADO".

    coloca essas regras no firewall:

    Código :
    /ip firewall nat chain=dstnat src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-address=IP_DO_APACHE to-port=PORTA_DO_APACHE
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=!tcp action=drop
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=!80 action=drop

    Assim, o cliente que você quiser que aparece a tela de bloqueio, você muda o profile dele para esse "PERFIL_BLOQUEIO". Todo o trafego HTTP dele (porta TCP 80) vai ser direcionado pro Apache, aparecendo a sua mensagem lá. E qualquer outro tipo de trafego vai ser bloqueado.

    Se seu servidor DNS é externo (e não a RB), acredito que requisições DNS vão ser bloqueadas pois vão passar pelo forward e cair num drop daqueles. Dai vai ter que criar uma regra liberando o DNS, antes das regras de drop.

    Código :
    /ip firewall filter add chain=forward in-interface=ETHER_CLIENTES protocol=udp dst-port=53 action=accept

  2. muito obrigado irmao,,, vai ser somente para bloqueio mesmo.



  3. ééé, nao sei aonde estou errando, tentei aqui e nao funcionou.

    instalei o easyphp no meu próprio pc. meu cenario aqui é o seguinte:

    modem bridge
    rb discando pppoe
    uso a mesma interface para autenticar hotspot e pppoe
    pppoe faixa de ip 192.168.77.1/24
    tenho um roteador discando meu usuario pppoe que no caso meu ip loca fica 192.168.1.100
    utilizo o dns do google e um da gvt


    o que fiz: coloquei as regras no firewal e no filter rules citadas acima, porém nao funcionou. detalhe, meu ip publico vindo da gvt, ja está resolvido para meu ddns computador.no-ip.info

  4. Dando uma liga ali vi que eu errei o primeiro comando, para adicionar uma regra de nat, faltou o "add", você chegou a arrumar?

    Se você adicionou a regra pelo winbox, tranquilo, se tentou pelo terminal, a regra não foi adicionada. A primeira linha ficaria assim:

    Código :
    /ip firewall nat add chain=dstnat src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-address=IP_DO_APACHE to-port=PORTA_DO_APACHE


    Outra coisa é que se você ja tem regras de filtro e/ou nat adicionadas que podem interferir nesse redirecionamento, vc tem que ajeitar, reconfigurar direitinho.
    Última edição por ab5x2; 23-06-2015 às 08:43.



  5. Não tenho regras nenhuma adicionadas por mim... A única coisa que fiz foi abrir duas portas no firewall.. Vou abrir agora a 81 para meu IP... Para funcionar esse bloqueio popoe






Tópicos Similares

  1. Linux não conecta em Maquina virtual com T.S
    Por luciusflavius no fórum Servidores de Rede
    Respostas: 4
    Último Post: 04-04-2008, 16:52
  2. Respostas: 6
    Último Post: 16-01-2008, 17:00
  3. Mikrotik em maquina virtual
    Por saip no fórum Redes
    Respostas: 14
    Último Post: 08-05-2007, 18:41
  4. Instalar o LINUX em máquina com CORE 2 DUO, MB com PCI-E e SATA II
    Por aprendiz_ce no fórum Sistemas Operacionais
    Respostas: 7
    Último Post: 11-04-2007, 00:14
  5. Instalação em Máquina Virtual
    Por jh0nn1 no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-09-2005, 00:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L