Página 6 de 13 PrimeiroPrimeiro ... 234567891011 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por roof45 Ver Post
    cara eu estou com esse mesmo problema, já bati cabeça e nada de resolver, estou usando squid3 no ubuntu lts14.04 e mikrotik 6.29.1 e o sarg so me mostra o IP do servidor Ubuntu.
    entao somos 2... pois estou na mesma configuração que voce ubuntu 14.4 squid3
    sarg e microtik 6.29.1

    e eu e o amigo @inquiery ficamos ontem quase 2 horas e nao resolvemos oproblema está serio.... parece que é alguma coisa a ver com o nat....

    agora ele da ess erro no cache.log


    nf getsockopt(so_original_dst) failed on


    estou pesquisando sobre ele , mas parece que o squid nao esta identificando o pacote e nao reconhece o ip que envia o pacote

  2. Caro amigo israeldinho, dei uma busca na internet e encontrei em outro fórum o mesmo problema que o seu, segue o link

    http://www.vivaolinux.com.br/topico/...s/Cache-squid3

    espero que ajude, caso não estamos ai na luta.



  3. Bom, dei uma pesquisada boa ontem e hoje no google, porém, a falta de experiência com o Squid e a falta de tempo pra se aprofundar não me levou a descoberta do problema.

    Instalei o Ubuntu 14.04, o qual nos repositórios do APT tem a versão 3.3.8.
    O teste foi feito com uma instalação limpa do Ubunto, o Squid (apt-get install squid3) e alterações do basico necessário na configuração do Squid.

    No Squid adicionei uma acl chamada localnet
    Código :
    acl localnet src 10.50.50.0/24

    Adicionei uma linha para dar acesso a essa acl (essa linha ficou logo acima da "http_access deny all")
    Código :
    http_access allow localnet

    E alterei o Squid para trabalhar NATiado, que é quando as requisições são passadas para ele por DNAT (ou dst-nat), mudando o destino do pacote, sem mascarar a origem
    Código :
    http_port 3129 intercept


    Após isso só configurei um IP na eth0, 10.0.0.2/30 e uma rota padrão para o 10.0.0.1

    Testei usando uma RB450

    ether0 192.168.11.220/24 (rede com acesso a internet)
    ether1 10.0.0.1/30 (ligado ao servidor Squid)
    ether3 10.50.50.1/24 (entrada de clientes).

    Gateway: 192.168.11.1

    No NAT adicionei uma regra para redirecionar todo o trafego da porta 80 para o Squid, quando a requisição não vinha do próprio Squid.

    Código :
    /ip firewall nat add chain=dstnat src-address=!10.0.0.2 protocol=tcp port=80 action=dst-nat to-address=10.0.0.2 to-ports=3129

    CONCLUSÃO: Não funciona.

    Logo após, instalei o Debian Wheezy (7.8). Depois de uma instalação limpa, configurei o seguinte repositório no APT (/etc/apt/sources.list)

    Código :
    deb http://ftp.br.debian.org/debian/ stable main contrib

    A RB450 ficou exatamente com a mesma configuração, e no Debian coloquei os mesmos IPs e rotas.

    CONCLUSÃO: Não funciona.


    Porém, fui verificar a versão do Squid, e no Debian estava com a versão 3.4.x (não lembro exatamente qual era o x). Sendo que eu tenho um servidor Squid rodando e funcionando, eu sabia que tinha que funcionar. Porém, meu servidor Squid está na versão 3.1.2.

    Então, eu mudei o /etc/apt/sources.list para

    Código :
    deb http://ftp.br.debian.org/debian/ wheezy main contrib

    Logo após, desinstalei o Squid3 que era o 3.4 com os comandos:

    Código :
    apt-get --purge remove squid3 squid3-commom

    Atualizei a lista de pacotes, devido a mudança do repositório:

    Código :
    apt-get update

    E instalei novamente o Squid:

    Código :
    apt-get install squid3

    Agora a minha versão do Squid passou para a 3.1.20 nesse Debian novo, e Voilá, a porra funciona.

    CONCLUSÃO: Alguma alteração foi feita no funcionamento do Squid quando esta trabalhando em modo "intercept" (recebendo requisições sem mascaramento), e eu sou muito nabo para descobrir o porque.



    FICA A DICA FINAL: Quem quiser fazer funcionar em modo transparent com o Squid guardando log dos IPs cliente final, e não só do IP mikrotik, basta usar um Debian 7.8 com Squid 3.1.2 que vai tranquilo.

  4. Citação Postado originalmente por inquiery Ver Post
    Bom, dei uma pesquisada boa ontem e hoje no google, porém, a falta de experiência com o Squid e a falta de tempo pra se aprofundar não me levou a descoberta do problema.

    Instalei o Ubuntu 14.04, o qual nos repositórios do APT tem a versão 3.3.8.
    O teste foi feito com uma instalação limpa do Ubunto, o Squid (apt-get install squid3) e alterações do basico necessário na configuração do Squid.

    No Squid adicionei uma acl chamada localnet
    Código :
    acl localnet src 10.50.50.0/24

    Adicionei uma linha para dar acesso a essa acl (essa linha ficou logo acima da "http_access deny all")
    Código :
    http_access allow localnet

    E alterei o Squid para trabalhar NATiado, que é quando as requisições são passadas para ele por DNAT (ou dst-nat), mudando o destino do pacote, sem mascarar a origem
    Código :
    http_port 3129 intercept


    Após isso só configurei um IP na eth0, 10.0.0.2/30 e uma rota padrão para o 10.0.0.1

    Testei usando uma RB450

    ether0 192.168.11.220/24 (rede com acesso a internet)
    ether1 10.0.0.1/30 (ligado ao servidor Squid)
    ether3 10.50.50.1/24 (entrada de clientes).

    Gateway: 192.168.11.1

    No NAT adicionei uma regra para redirecionar todo o trafego da porta 80 para o Squid, quando a requisição não vinha do próprio Squid.

    Código :
    /ip firewall nat add chain=dstnat src-address=!10.0.0.2 protocol=tcp port=80 action=dst-nat to-address=10.0.0.2 to-ports=3129

    CONCLUSÃO: Não funciona.

    Logo após, instalei o Debian Wheezy (7.8). Depois de uma instalação limpa, configurei o seguinte repositório no APT (/etc/apt/sources.list)

    Código :
    deb http://ftp.br.debian.org/debian/ stable main contrib

    A RB450 ficou exatamente com a mesma configuração, e no Debian coloquei os mesmos IPs e rotas.

    CONCLUSÃO: Não funciona.


    Porém, fui verificar a versão do Squid, e no Debian estava com a versão 3.4.x (não lembro exatamente qual era o x). Sendo que eu tenho um servidor Squid rodando e funcionando, eu sabia que tinha que funcionar. Porém, meu servidor Squid está na versão 3.1.2.

    Então, eu mudei o /etc/apt/sources.list para

    Código :
    deb http://ftp.br.debian.org/debian/ wheezy main contrib

    Logo após, desinstalei o Squid3 que era o 3.4 com os comandos:

    Código :
    apt-get --purge remove squid3 squid3-commom

    Atualizei a lista de pacotes, devido a mudança do repositório:

    Código :
    apt-get update

    E instalei novamente o Squid:

    Código :
    apt-get install squid3

    Agora a minha versão do Squid passou para a 3.1.20 nesse Debian novo, e Voilá, a porra funciona.

    CONCLUSÃO: Alguma alteração foi feita no funcionamento do Squid quando esta trabalhando em modo "intercept" (recebendo requisições sem mascaramento), e eu sou muito nabo para descobrir o porque.



    FICA A DICA FINAL: Quem quiser fazer funcionar em modo transparent com o Squid guardando log dos IPs cliente final, e não só do IP mikrotik, basta usar um Debian 7.8 com Squid 3.1.2 que vai tranquilo.
    entao resolvido fiz oque ele falou e funcionou, instalei debian 7.8 e o squid3 o unico problema é que agora ele esta bloqueando as https port mas acho que é configuração do meu squid isso eu resolvo obrigado mesmo forum voces sao de mais @inquiery



  5. consegui resolver, só fui na regra dst-nat em dst-port adicionei 80, 443 e funcionou normal






Tópicos Similares

  1. Sarg não mostra ip dos clientes
    Por jaelcio no fórum Redes
    Respostas: 22
    Último Post: 14-08-2014, 14:28
  2. Respostas: 3
    Último Post: 24-01-2011, 17:38
  3. Como fazer para Squid não mudar IP do cliente
    Por e-eduardo no fórum Servidores de Rede
    Respostas: 8
    Último Post: 18-02-2009, 08:07
  4. Clientes DHCP não recebem Ip do AP-PC MK
    Por Josue Guedes no fórum Redes
    Respostas: 1
    Último Post: 26-02-2008, 22:07
  5. WET11 - IP do cliente nao funciona dinamico
    Por santocyber no fórum Redes
    Respostas: 11
    Último Post: 30-08-2004, 07:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L