+ Responder ao Tópico



  1. #1

    Padrão Problema com ping alto em jogos

    Pessoal alguém já passou por problema de cliente reclamar de Ping alto em jogos? quando chego na casa do cliente fasso o teste o Ping tá bom em 10ms, 20ms e no jogo fica em 150 segundo o cliente. tem alguma coisa pra melhorar isso? e de preferencia nesse maldito Jogo CrossFire.

  2. #2

    Padrão Re: Problema com ping alto em jogos

    Faço o teste por esse site www.pingtest.net. E do MK pro cliente. se eu estiver errado me diga qual melhor forma de testar, fico grato.



  3. #3

    Padrão Re: Problema com ping alto em jogos

    Então parceiro, pra voce mensurar direito essa latência, voce tem que pegar o ip do servidor de jogo que o brother la se conecta no jogo dele ( no Crossfire no caso ), e pingar esse server direto da sua borda, no caso do seu MK. Depois do seu MK voce pinga o seu cliente.

    Ex:
    A latencia entre seu cliente e o server do game dele é 150ms
    A latencia entre o seu MK e o seu cliente é 20 ms.
    Quando voce pingar do seu MK pro ip do server do game dele, deve dar mais ou menos 130 ms, sacou?

    Infelizmente não tem muito o que voce fazer, é o roteamento do seu fornecedor de link que nao tem uma rota legal pro server do game.

  4. #4

    Padrão Re: Problema com ping alto em jogos

    Não estou encontrando os ip´s dos servidores aqui no brasil.



  5. #5

    Padrão Re: Problema com ping alto em jogos

    @hostjunior, dificilmente com latencia de 150ms esses servidores estarão no Brasil parceiro.

  6. #6

    Padrão Re: Problema com ping alto em jogos

    Se você só tem um link de internet, tenta isso:

    Código :
    /ip firewall address-list add address=23.0.0.0/12 name=GameIPs
    /ip firewall address-list add address=184.50.0.0/15 name=GameIPs
     
    /ip firewall mangle add chain=prerouting connection-mark=no-mark dst-address-list=GameIPs action=mark-connection new-connection-mark=GameConn place-before=0
    /ip firewall mangle add chain=prerouting connection-mark=GameConn action=mark-packet new-packet-mark=GamePacket place-before=0
     
    /queue tree add name=Game parent=global packet-mark=GamePacket priority=1

    Não tenho nem ideia se vai ajudar no seu caso...



  7. #7

    Padrão Re: Problema com ping alto em jogos

    Citação Postado originalmente por shacaw Ver Post
    @hostjunior, dificilmente com latencia de 150ms esses servidores estarão no Brasil parceiro.
    Acho que deve ter pois vi uma noticias aqui pesquisando que tem até aqui no nordeste.

  8. #8

    Padrão Re: Problema com ping alto em jogos

    Amigo, estou me referindo ao servidor que o brother la tava conectado. CrossFire ẽ um game onde existem diversos servidores piratas, então até meu vizinho aqui do lado pode ter um servidor de crossfire. Mas o servidor onde o seu cliente estava conectado naquele momento com latencia de 150ms dificilmente estará no brasil.

    Ainda assim, é possível tambem sim que seja um servidor no brasil, apenas a rota do seu fornecedor até o servidor destino não é legal.



  9. #9

    Padrão Re: Problema com ping alto em jogos

    Citação Postado originalmente por shacaw Ver Post
    Amigo, estou me referindo ao servidor que o brother la tava conectado. CrossFire ẽ um game onde existem diversos servidores piratas, então até meu vizinho aqui do lado pode ter um servidor de crossfire. Mas o servidor onde o seu cliente estava conectado naquele momento com latencia de 150ms dificilmente estará no brasil.

    Ainda assim, é possível tambem sim que seja um servidor no brasil, apenas a rota do seu fornecedor até o servidor destino não é legal.
    Mas pela manhã fica em 65 e 70

  10. #10

    Padrão Re: Problema com ping alto em jogos

    A latência entre o seu MK e o seu cliente varia entre manhã e tarde?

    Se não, mais uma vez... é problema do seu fornecedor.



  11. #11

    Padrão Re: Problema com ping alto em jogos

    O mais provável é que realmente seja a rota até o server do game.

    Pode ser também que a sua banda esteja sendo usada no limite, não só o downstream, mas também o upstream, pode(m) estar(em) esgotado(s). Se esse for o caso, priorizando o trafego dos endereços do game, pode ajudar a melhorar a latência devido tanto aos pacotes não precisarem esperar para serem enviados e nem entrar em fila atrás de outros tipos de comunicação antes de serem recebidos.

    Dando uma "fuçada" eu descobri aqueles endereços lá para os servidor da z8games para o Crossfire da America Latina. Eu os uso aqui pois tenho só 1 link que tem latencia baixa boa para jogos em qualquer horário, e esse link infelizmente é de somente 2Mbps, portanto, eu jogo nele SOMENTE o trafego de jogos que o pessoal me reclama. Até agora, Starcraft II, Crossfire, League of Legends e Diablo III.

    Qualquer coisa, cria também um queue type com mais espaço:

    Código :
    /queue type add kind=pfifo pfifo-limit=5000 name=GameQueue

    E no item da Queue Tree que foi adicionado, muda o tipo de queue para esse criado.

    5000 pacotes no queue é pacote pra kralho, vai dropar menos, e por isso pode evitar alguns travamentos do jogo devido a perda.

  12. #12

    Padrão Re: Problema com ping alto em jogos

    Citação Postado originalmente por inquiery Ver Post
    O mais provável é que realmente seja a rota até o server do game.

    Pode ser também que a sua banda esteja sendo usada no limite, não só o downstream, mas também o upstream, pode(m) estar(em) esgotado(s). Se esse for o caso, priorizando o trafego dos endereços do game, pode ajudar a melhorar a latência devido tanto aos pacotes não precisarem esperar para serem enviados e nem entrar em fila atrás de outros tipos de comunicação antes de serem recebidos.

    Dando uma "fuçada" eu descobri aqueles endereços lá para os servidor da z8games para o Crossfire da America Latina. Eu os uso aqui pois tenho só 1 link que tem latencia baixa boa para jogos em qualquer horário, e esse link infelizmente é de somente 2Mbps, portanto, eu jogo nele SOMENTE o trafego de jogos que o pessoal me reclama. Até agora, Starcraft II, Crossfire, League of Legends e Diablo III.

    Qualquer coisa, cria também um queue type com mais espaço:

    Código :
    /queue type add kind=pfifo pfifo-limit=5000 name=GameQueue

    E no item da Queue Tree que foi adicionado, muda o tipo de queue para esse criado.

    5000 pacotes no queue é pacote pra kralho, vai dropar menos, e por isso pode evitar alguns travamentos do jogo devido a perda.
    Usa essas regras tambem ?

    /ip firewall address-list add address=23.0.0.0/12 name=GameIPs/ip firewall address-list add address=184.50.0.0/15 name=GameIPs /ip firewall mangle add chain=prerouting connection-mark=no-mark dst-address-list=GameIPs action=mark-connection new-connection-mark=GameConn place-before=0/ip firewall mangle add chain=prerouting connection-mark=GameConn action=mark-packet new-packet-mark=GamePacket place-before=0 /queue tree add name=Game parent=global packet-mark=GamePacket priority=1



  13. #13

    Padrão Re: Problema com ping alto em jogos

    Sim. Leia tudo o que eu escrevi para entender pelo menos um pouco o que você está fazendo.

    E se você for adicionar as regras pelo terminal, cuida bem se não vai dar nenhum erro, se der, corrija, não é difícl. Eu digito de cabeça, e constantemente erro alguma coisa. As vezes eu mesmo vejo e edito o post e altero, mas não é sempre.

  14. #14

    Padrão Re: Problema com ping alto em jogos

    Amigo tenho um cliente que joga esse bendito game, e o ping dele fica entre 68ms-130ms, e o IP dos servidores do CF/z8games não estão no Brasil.

    (Link que uso, Dedicado da Oi, com balance com 2 ADSL da Oi também, redireciono o CF pro Dedicado.)

    Jogo Quake 3 Arena com alguns amigos que moram nos EUA e o ping meu fica melhor (50-68ms) do que do CF que dizem ser hospedados no Brasil mais e mentira, só que meu problema e nas rotas zoadas da Oi, tenta contratar um outro Dedicado de outra empresa que com certeza resolvera seu problema, mais essa do jogo estar no Brasil e pura falsidade hehe pode instalar em um PC e monitorar o jogo que você vera.

    OBS:
    Meu concorrente tem link da Copel e o ping dele e bem melhor (36-50ms), ate o fim do ano irei fazer um ptp de um link da Copel apenas pra essa finalidade pois anda entrando uns clientes que gostam desse jogo e só tenho problema com ele.