+ Responder ao Tópico



  1. Bom, se se não são clientes fixos, e sim um ponto de acesso onde dispositivos desconhecidos vão conectar, você pode usar o próprio campo "Lease Script" do DHCP Server para fazer seu script. O script digitado ali, quando é executado, tem acesso a algumas variáveis locais interessantes que vão te ajudar na tarefa, conforme está no wiki da mikrotik.

    • leaseBound - set to "1" if bound, otherwise set to "0"
    • leaseServerName - dhcp server name
    • leaseActMAC - active mac address
    • leaseActIP - active IP address
    Tipo assim:

    Código :
    if ($leaseBound=1) do={
      /queue simple add max-limit=UP/DOWN target=$leaseActIP comment=$leaseActMAC
    } else={
      /queue simple remove [find comment=$leaseActMAC]
    }

    Assim, quando o script for chamado ENTREGANDO UM IP a um cliente, a variavel $leaseBound vai ser 1, e então uma regra de queue será adicionada, e quando o script for chamado LIBERANDO UM IP (liberando significa removendo da tabela por não estar mais em uso), a variável $leaseBound vai ser 0, e a regra de queue será removida. Utilizei o comment das regras de queue para adicionar o MAC para o qual o IP foi oferecido, e assim deletando os itens pelo MAC tb. Poderia ser pelo IP, daria na mesma.

  2. Citação Postado originalmente por jordao Ver Post
    Isaque, boa tarde.
    Já tive um cenário parecido onde eu trabalho, onde precisei abrir uma celula 2.4 sem Hotspot nem PPOE, ou seja, distribuindo IP somente pelo DHCP server.
    A maneira no qual eu consegui limitar a manda dos clientes, a mesma para todos, foi rodando o Script abaixo:

    /queue simple
    for i from=1 to=250 do={ add name=("192.168.1." . $i . "/32") target=("192.168.1." . $i . "/32") dst=0.0.0.0/0 parent=none priority="8" queue=default-small/default-small limit-at=0/0 max-lim
    it=100K/100K total-queue=default-small }

    Sendo que o de negrito seria o range do seu bloco, o de vermelho a sua rede e o de verde a sua banda.
    Este script consiste em gerar todas as queues para os ip's do seu range, ou seja, quando o cliente se conectar já haverá um limitador de trafêgo aplicado ao IP dele.

    Fora esta maneira desconheço uma forma de " gerar " um limitador de trafego automático ao cliente via DHCP.
    vou fazer o teste aqui e posto os resultados obrigado



  3. Citação Postado originalmente por inquiery Ver Post
    Na realidade não precisa nem ter IP estático.
    Basta criar leases estáticos colocando SOMENTE O MAC do cliente, e configurando o rate limite daquele cliente.

    O IP ele vai pegar do DHCP mesmo, e vai aplicar o rate da regra do lease numa queue dinamica para o IP que o cliente pegar.

    O Rate limite segue o seguinte formato:

    rx-rate[/tx-rate] [rx-burst-rate[/tx-burst-rate] [rx-burst-threshold[/tx-burst-threshold] [rx-burst-time[/tx-burst-time]]]]

    rx-rate é o upload
    tx-rate é o download

    o resto dos parametros pra frente é tudo opcional, se você não usa burst, não precisa nem se preocupar com eles.

    Você pode colocar assim por exemplo: 512k/1M
    Isso quer dizer que o cliente para aquele MAC vai ter 512kbps de upload e 1mbps de download.
    obrigado tambem vou testar sua teoria

  4. Citação Postado originalmente por inquiery Ver Post
    Bom, se se não são clientes fixos, e sim um ponto de acesso onde dispositivos desconhecidos vão conectar, você pode usar o próprio campo "Lease Script" do DHCP Server para fazer seu script. O script digitado ali, quando é executado, tem acesso a algumas variáveis locais interessantes que vão te ajudar na tarefa, conforme está no wiki da mikrotik.


    Tipo assim:

    Código :
    if ($leaseBound=1) do={
      /queue simple add max-limit=UP/DOWN target=$leaseActIP comment=$leaseActMAC
    } else={
      /queue simple remove [find comment=$leaseActMAC]
    }

    Assim, quando o script for chamado ENTREGANDO UM IP a um cliente, a variavel $leaseBound vai ser 1, e então uma regra de queue será adicionada, e quando o script for chamado LIBERANDO UM IP (liberando significa removendo da tabela por não estar mais em uso), a variável $leaseBound vai ser 0, e a regra de queue será removida. Utilizei o comment das regras de queue para adicionar o MAC para o qual o IP foi oferecido, e assim deletando os itens pelo MAC tb. Poderia ser pelo IP, daria na mesma.
    vou colocar em pratica sua teoria e posteriormente posto os resultados obrigado



  5. acompanhando...






Tópicos Similares

  1. Respostas: 6
    Último Post: 15-11-2016, 17:58
  2. ajuda..controle de banda no cliente
    Por jrfla no fórum Redes
    Respostas: 2
    Último Post: 09-07-2008, 08:28
  3. Ajuda com script pra desabilitar controle de banda
    Por cleciorodrigo no fórum Redes
    Respostas: 0
    Último Post: 10-06-2007, 07:30
  4. Migrando para controle de banda no FreeBSD
    Por rowdy no fórum Sistemas Operacionais
    Respostas: 21
    Último Post: 27-10-2006, 01:14
  5. Controle de Banda no RH7.1
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-09-2003, 21:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L