+ Responder ao Tópico



  1. #1

    Padrão Ospf caindo por favor me ajudem por favor!!

    amigos nao sei mais o que fazer, minhas RB estão desmontando o roteamento dinamico e não voltam são varios pops os enlaces são ubnt, mikrotik todos com wds e continuam do mesmo jeito, ate RB ligada diretamente no cabo ao backbone cai, segue um exemplo de como são as conf do pops em interfaces eu coloco a mesma em static e network type nbma e nbma neigbors aponto o visinho manual mesmo, no roteador de borda so distribuo rotas default, isso esta acontecendo depois que antigamente por nao ter muito conhecimento eu nos pops distribuia rotas conectadas e staticas depois que tirei fica caindo direto, não sei mais o que fazer. até voltei a versão do para mk 6.28 e nao resolveu.

    /routing ospf instance
    set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.255.255.4
    /routing ospf area
    set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=\
    backbone type=default
    add area-id=0.0.0.1 disabled=no instance=default name=pppoe type=default
    /routing ospf area range
    add advertise=yes area=pppoe cost=calculated disabled=no range=10.16.10.0/24
    /routing ospf interface
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    vlan1 network-type=nbma passive=no priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    /routing ospf nbma-neighbor
    add address=192.168.66.1 disabled=no instance=default poll-interval=2m \
    priority=0
    /routing ospf network
    add area=backbone disabled=no network=192.168.66.0/30
    add area=backbone disabled=no network=177.125.61.0/24
    add area=backbone disabled=no network=10.255.255.4/32
    add area=backbone disabled=no network=10.16.16.0/24
    add area=pppoe disabled=no network=10.16.10.0/24

  2. #2

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    bom dia, passei por isso um bom tempo..resolvi fazendo varias coisas. primeiro coloquei um estalibilizador, depois fiz um aterramento bom na RB, fonte e painel, problema sumiu.



  3. #3

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    minha fonte e da volt 24v/7A, o problema tava me deixando louco ja. fiz o q falei acima e sumiram os problemas

  4. #4

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    opa acredito não ser pois e um problema generalizado todos todos os pops possuem fonte nobreak e sao aterrados como falei ate um mk que tenho dentro de uma vmware as rotas caem



  5. #5

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Verifica o que ocorre nos logs do RouterOS referente ao ospf, e posta aqui, pra poder te ajudar.

  6. #6

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    ospf neighbor state change from full to down so que como falei ja estou apontando manual o roteador visinho apesar ele encontrar dinamicamente e networks type estou tirando o broadcast e colocando nbma



  7. #7
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Última edição por dpetry; 07-10-2015 às 14:40.

  8. #8

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Aqui utilizo OSPF na rede toda, são PTPs com equipamentos Mikrotik e não tenho esses problemas, tem que verificar se teus enlaces não estão com algum problema de throughput ou perdendo pacotes, pois como vc fez com NBMA a ultima coisa que deveria acontecer é o OSPF oscilar, verifica a latência dos enlaces e se não há perca de pacotes outras coisas também é verificar se o ospf ficou corretamente configurado em todos os equipos



  9. #9

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Amigos depois de muito pesquisar e quebrar a cabeça descobri, como tinha dito não era questão de enlaces, wds, etc.. pois o problema acontecia ate mesmo com pops ligado diretamente na fibra. como tinha dito ja estava trabalhando com NBMA por causa de pacotes multicast e usar enlaces 802.11 onde seguinto no wiki da Mikrotik esses pacotes nem sempre são entregues de forma eficiente gerando a instabilidade do OSPF, o problema era que todos os meus roteadores estavao designando rotas, deixei a prioridade dos que queriam desiginar rota 1 e os que iria receber 0 dae esses se tornaram DR e não cairam mais as rotas e fiz ajustes de pesos tambem graças a Deus até agora tudo fluindo, antes nao dava 30 min cai e n voltava mais.

  10. #10

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Bom dia eduardonwt!
    O ideal seria você postar os logs de cada neighbors OSPF qual você está enfrentando esse problema.
    Mas acredito eu que você tenha algum problema com os temporizadores de adjacência OSPF que devem em algum lugar bem escondido na sua topologia apresentar valores descrepantes e estão fazendo suas adjacência entre vizinhos cair e com isso fazendo com que a máquina de estado finita do OSPF(FSM) e o algritmo DJiKSTRA tenha que ser reclaculado para todos neighbors e derrubando a tabela de roteamento.

    Quando o problema ocorrer dê uma olhada no tempo de hold-time da sessão OSPF de cada vizinho. Se ver que esse temporizador está com valores altos a ponto de expirar é porque está acontecendo isso que lhe expliquei.

    Mas pra ter certeza é preciso analisar os logs e cada roteador e seus vizinhos envolvidos no processo de OSPF.

    Seu OSPF possui quantos Pops ativos no roteamento dinâmico?
    O OSPF está como Single Area ou Multi Area?

    Em caso de dúvidas fico à dispossição

    Att

    Rafael Themístocles
    [Consultor em Redes e Telecomunicações/NGN Network Project Engineer]
    http://www.telmetrics.com.br
    E-mail: [email protected]
    Skype: rafaelthemistocles




    Citação Postado originalmente por eduardonwt Ver Post
    amigos nao sei mais o que fazer, minhas RB estão desmontando o roteamento dinamico e não voltam são varios pops os enlaces são ubnt, mikrotik todos com wds e continuam do mesmo jeito, ate RB ligada diretamente no cabo ao backbone cai, segue um exemplo de como são as conf do pops em interfaces eu coloco a mesma em static e network type nbma e nbma neigbors aponto o visinho manual mesmo, no roteador de borda so distribuo rotas default, isso esta acontecendo depois que antigamente por nao ter muito conhecimento eu nos pops distribuia rotas conectadas e staticas depois que tirei fica caindo direto, não sei mais o que fazer. até voltei a versão do para mk 6.28 e nao resolveu.

    /routing ospf instance
    set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.255.255.4
    /routing ospf area
    set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=default name=\
    backbone type=default
    add area-id=0.0.0.1 disabled=no instance=default name=pppoe type=default
    /routing ospf area range
    add advertise=yes area=pppoe cost=calculated disabled=no range=10.16.10.0/24
    /routing ospf interface
    add authentication=none authentication-key="" authentication-key-id=1 cost=10 \
    dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=\
    vlan1 network-type=nbma passive=no priority=1 retransmit-interval=5s \
    transmit-delay=1s use-bfd=no
    /routing ospf nbma-neighbor
    add address=192.168.66.1 disabled=no instance=default poll-interval=2m \
    priority=0
    /routing ospf network
    add area=backbone disabled=no network=192.168.66.0/30
    add area=backbone disabled=no network=177.125.61.0/24
    add area=backbone disabled=no network=10.255.255.4/32
    add area=backbone disabled=no network=10.16.16.0/24
    add area=pppoe disabled=no network=10.16.10.0/24



  11. #11

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    colega , se precisar de um help, nada de consultoria, um help add skype. balsanelli.anderson

  12. #12

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    vlw irmao obrigado por se dispor



  13. #13

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Tive o mesmo problema era um cabo CAT6 entupido no pop.

  14. #14

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Galera boa tarde,como faço Para reduzir ainda mais o volume de informações de roteamento distribuídas nas áreas, o OSPF possibilita o uso de áreas,no meu caso são mais de 4.500



  15. #15

    Padrão Re: Ospf caindo por favor me ajudem por favor!!

    Citação Postado originalmente por Rinaldo011015 Ver Post
    Galera boa tarde,como faço Para reduzir ainda mais o volume de informações de roteamento distribuídas nas áreas, o OSPF possibilita o uso de áreas,no meu caso são mais de 4.500
    É preciso o desenho de sua rede para poder opinar alguma coisa, mas você pode trabalhar com áreas Stub para injetar rotas sumarizadas e default, assim diminui muito o tamanho da tua tabela, e caso queira diminuir ainda mais, área Totally Stub, onde você somente injeta a rota default.