+ Responder ao Tópico



  1. #1

    Padrão Duvida acesso externo mikrotik

    Boa tarde pessoal,
    Estou com um probleminha aqui.

    Tenho 2 Link sendo 1- Dedicado (IP FIXO) onde funciona uma VPN e outro ADSL (IP Dinâmico).

    Configurei o MK para puxar a conexão do LInk ADSL pois tem mais banda de conexão porém preciso ter acesso a ele remotamente e quero usar o IP Estático do link dedicado, quando eu chego em Router e coloco pra o ADSL para ser nivel 1 eu não consigo pingar o ip externo do (dedicado), quando eu coloco pro Dedicado ser nivel "1" consigo pingar e ter acesso ao MK, porem toda conexão de internet na rede passa a trafegar pelo dedicado e é o que eu não quero.

    Alguém poderia me ajudar na regra onde o MK permita ter acesso ao mikrotik externamente pelo link Dedicado sendo que internamente todos tem que trafegar pelo ADSL?

    Fiz algumas regras no mangle mais não obtive exito. Minha RB é uma 433 V4.2

  2. #2

    Padrão Re: Duvida acesso externo mikrotik

    Marca as conexões que entram pelo link dedicado, e cria outra de regra de output pegando a marcação com ação de Mark routing, então cria uma rota apontando o link dedicado como gatway e usando a marcação.



  3. #3

    Padrão Re: Duvida acesso externo mikrotik

    Citação Postado originalmente por berghetti Ver Post
    Marca as conexões que entram pelo link dedicado, e cria outra de regra de output pegando a marcação com ação de Mark routing, então cria uma rota apontando o link dedicado como gatway e usando a marcação.
    você fala criar essa regra dentro do MANGLE? se for isso eu tentei fazer ela conta porem devo estar me perdendo nessa marcação.

  4. #4

    Padrão Re: Duvida acesso externo mikrotik

    Depois que fez a marcação, criou a rota usando essa marcação?



  5. #5

    Padrão Re: Duvida acesso externo mikrotik

    Citação Postado originalmente por berghetti Ver Post
    Depois que fez a marcação, criou a rota usando essa marcação?
    Rapaz criei uma rotas más não lembro disso vou tentar ver sábado pois é em outra cidade e como não estou conseguindo o acesso não tenho como dar esse feedback

  6. #6

    Padrão Re: Duvida acesso externo mikrotik

    OK, se precisar chama no skype, mayco.berghetti



  7. #7

    Padrão Re: Duvida acesso externo mikrotik

    meu nobre tava criada em router, estou me perdendo em algum campo no mangle, vou exportar a regra criada lá.

  8. #8

    Padrão Re: Duvida acesso externo mikrotik

    segue a regra do mangle

    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no dst-address-type="" in-interface=ether2-DEDICADO \
    new-connection-mark=con_IN passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no in-interface=ether3-ADSL new-connection-mark=con_IN2 \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=con_IN \
    disabled=no new-routing-mark=rota passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=con_IN2 \
    disabled=no new-routing-mark=rota2 passthrough=yes

    Em routes
    /ip route
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=177.135.xxx.xx routing-mark=rota scope=30 target-scope=\
    10


    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.25.1 routing-mark=rota2 scope=30 target-scope=\
    10


    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=177.135.xxx.xx scope=30 target-scope=10


    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=192.168.25.1 scope=30 target-scope=10


    add comment="" disabled=yes distance=2 dst-address=10.0.0.0/24 gateway=\
    192.168.0.254 scope=30 target-scope=10




    Dessa forma que fiz, desculpe colocar no IP Externo os "XXX", como o fórum é aberto pra evitar algum tipo de ataque direto ao MK por pessoas de má índole acabei apagando os finais dele, creio que da pra entender como ta criada as regras.

    No mangle tentei algumas regras na net más sem sucesso...



  9. #9

    Padrão Re: Duvida acesso externo mikrotik

    Boa tarde Midller!

    Conseguiu resolver seu problema?

    Citação Postado originalmente por midller Ver Post
    Boa tarde pessoal,
    Estou com um probleminha aqui.

    Tenho 2 Link sendo 1- Dedicado (IP FIXO) onde funciona uma VPN e outro ADSL (IP Dinâmico).

    Configurei o MK para puxar a conexão do LInk ADSL pois tem mais banda de conexão porém preciso ter acesso a ele remotamente e quero usar o IP Estático do link dedicado, quando eu chego em Router e coloco pra o ADSL para ser nivel 1 eu não consigo pingar o ip externo do (dedicado), quando eu coloco pro Dedicado ser nivel "1" consigo pingar e ter acesso ao MK, porem toda conexão de internet na rede passa a trafegar pelo dedicado e é o que eu não quero.

    Alguém poderia me ajudar na regra onde o MK permita ter acesso ao mikrotik externamente pelo link Dedicado sendo que internamente todos tem que trafegar pelo ADSL?

    Fiz algumas regras no mangle mais não obtive exito. Minha RB é uma 433 V4.2

  10. #10

    Padrão Re: Duvida acesso externo mikrotik

    Boa tarde telmetrics, Ainda não já tentei varias regras que conheço e na internet porem sem sucesso..
    Sei que é alguma coisa boba no mangle que estou me perdendo ou esta na minha frente me mordendo e não tou enxergando aff '-.-
    Citação Postado originalmente por telmetrics Ver Post
    Boa tarde Midller!

    Conseguiu resolver seu problema?
    Última edição por midller; 11-11-2015 às 18:48.



  11. #11

    Padrão Re: Duvida acesso externo mikrotik

    Tenta essas regras(mas tem que estar na ordem correta, para evitar problemas coloque elas logo no início do Mangle do seu balance):

    Obs: Troque Link1 e Link2 pelo nome da interface qual seu link está conectado. Caso seus links não sejam PPPoE ou estejam sendo discados em RB diferente do Balance você terá de colocar o IP de Nexthop de cada link no lugar do nome das interfaces.

    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Link1 new-connection-mark=ISP2_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Link2 new-connection-mark=ISP3_conn

    add action=mark-routing chain=output connection-mark=ISP2_conn \
    new-routing-mark=to_ISP1
    add action=mark-routing chain=output connection-mark=ISP3_conn \
    new-routing-mark=to_ISP2

    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP1" distance=1 \
    gateway=Link1 routing-mark=to_ISP1
    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP1" distance=2 \
    gateway=Link2 routing-mark=to_ISP1
    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP2" distance=1 \
    gateway=Link2 routing-mark=to_ISP2

    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP2" distance=2 \
    gateway=Link1 routing-mark=to_ISP2

    Espero ter ajudado!

    Rafael Themístocles
    [Consultor em Redes e Telecomunicações/NGN Network Project Engineer]
    http://www.telmetrics.com.br
    E-mail: [email protected]
    [email protected]
    Skype: rafaelthemistocles

    Whatsapp: (11)9-5962-2128





    Citação Postado originalmente por midller Ver Post
    Boa tarde telmetrics, Ainda não já tentei varias regras que conheço e na internet porem sem sucesso..
    Sei que é alguma coisa boba no mangle que estou me perdendo ou esta na minha frente me mordendo e não tou enxergando aff '-.-

  12. #12

    Padrão Re: Duvida acesso externo mikrotik

    Meu nobre muito obrigado pelas regras deu pra mim ver e olhar onde estava errando nas minhas, o que estava ocorrendo era eu me perdendo no mangle e na rota eu estava apontando para a marcação errada fazendo com que não me retornasse o ping e consequentemente o acesso externo com o ADSL ativo.

    Suas regras me ajudaram em muito a resolver as minhas muito obrigado mesmo!!

    Citação Postado originalmente por telmetrics Ver Post
    Tenta essas regras(mas tem que estar na ordem correta, para evitar problemas coloque elas logo no início do Mangle do seu balance):

    Obs: Troque Link1 e Link2 pelo nome da interface qual seu link está conectado. Caso seus links não sejam PPPoE ou estejam sendo discados em RB diferente do Balance você terá de colocar o IP de Nexthop de cada link no lugar do nome das interfaces.

    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Link1 new-connection-mark=ISP2_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Link2 new-connection-mark=ISP3_conn

    add action=mark-routing chain=output connection-mark=ISP2_conn \
    new-routing-mark=to_ISP1
    add action=mark-routing chain=output connection-mark=ISP3_conn \
    new-routing-mark=to_ISP2

    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP1" distance=1 \
    gateway=Link1 routing-mark=to_ISP1
    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP1" distance=2 \
    gateway=Link2 routing-mark=to_ISP1
    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP2" distance=1 \
    gateway=Link2 routing-mark=to_ISP2

    add check-gateway=ping comment="@Telmetrics:PBR Failover ISP2" distance=2 \
    gateway=Link1 routing-mark=to_ISP2

    Espero ter ajudado!

    Rafael Themístocles
    [Consultor em Redes e Telecomunicações/NGN Network Project Engineer]
    http://www.telmetrics.com.br
    E-mail: [email protected]
    [email protected]
    Skype: rafaelthemistocles

    Whatsapp: (11)9-5962-2128