+ Responder ao Tópico



  1. #1

    Padrão O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    Pessoal tenho RB 750Gl que trabalha como DHCP Server e libera a Internet para rede local e nesta mesma rede tem um Máquina com Linux Ubuntu 12.04 com Squid3 instalado.

    Queria força todos passar pelo Proxy autenticado, tenho que criar alguma regra especial na RB750GL?

    OBS: Também na Rede tem um Servidor Windows 2012 com AD configurado, já criei uma GPO para forçar que os browser use Proxy na porta 3128.

    No memento quando os usuários logam nas estações já esta setado o proxy no browser e algumas regras de bloqueio tipo paginas já estão fucionando.

    Porém também qualquer máquina que não esteja no dominio Windows acessa a internet sem passar pelo proxy, isso eu queria evitar, nesses casos o usuário que não pertencer o dominio seja obrigado autenticar via um POP UP.

    Alguém sabe o que tem que se feito?

    OBS: Já tentei alguamas regras no squid mas não funciona nos dois caso acima citado.

    Já tenho esta regras no squid para funcionar com usuarios do dominio.

    http_port 192.168.0.4:3128
    http_port 3129 intercept


    auth_param basic program /usr/lib/squid3/squid_ldap_auth -R -b “dc=ccbsumare,dc=local” -D “cn=squid,ou=central,dc=ccbsumare,dc=local” -w “Sony14567″ -f sAMAccountName=%s -h 192.168.0.5

    external_acl_type ldap_group %LOGIN /usr/lib/squid3/squid_ldap_group -R -b “dc=ccbsumare,dc=local” -D cn=squid,ou=central,dc=ccbsumare,dc=local -w “Sony14567″ -f “ (&(objectclass=person)(sAMAccountName=%v)(memberof=cn=%a,ou=central,dc=ccbsumare,dc=local))” -h 192.168.0.5


    Abraço
    Última edição por ccbsumare; 10-12-2015 às 13:44.

  2. #2

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=proxy disabled=yes dst-port=80 in-interface=a_interface_da_sua_rede protocol=tcp to-addresses=o_ip_do_seu_proxy to-ports=3128

    boa sorte!!!



  3. #3

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    VC pode bloquear a porta 80 e443 para não conseguirem navegar sem o proxy. Aí VC vai conseguir identificar quem não ta sem proxy e configura manualmente. Aí vai depender de VC pq não sei a quantidade de máquinas que tem no seu ambiente

  4. #4

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    Quando aplico a regra abaixo não esta navegando fica só aguardando.

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=proxy disabled=no dst-port=80 in-interface=Clientes protocol=tcp to-addresses=192.168.0.4 to-ports=3128

    No browser esta configurado 192.168.0.4 porta 3128







  5. #5

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    o ip do proxy não pode ser o mesmo ip da rede dos clientes.
    procura ai "mikrotik com proxy em paralelo"

  6. #6

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    ok
    levantei uma VM com Pfsense 2.2.5 e deixei em paralelo na porta 2 da RB750GL.
    Criei o endereço na interface 2 com IP para o Pfsense 10.1.1.1/30

    consigo pingar do pfsense IP 10.1.1.2 para RB na porta do Pfsense 10.1.1.1
    porém da RB não consigo pingar o PFsense.

    Pela rede 192.168.0.0/24 consigo acessar o webconfiguration do pfsense via http://10.1.1.2

    Porque não pinga da RB para o pfsense?



  7. #7

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    Citação Postado originalmente por ccbsumare Ver Post
    Porque não pinga da RB para o pfsense?
    Rota?

    Explique melhor o seu cenário.

  8. #8

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    vamo lá.

    Aqui tenho duas RB em pararelo sendo 450G que recebe os links de internet e faz o loadbalance a segunda RB 750GL é o gateway e Server DHCP da rede 192.168.0.0/24

    Na RB750 tenho também em paralelo o PFSENSE (Proxy) com a Rede 10.1.1.0/30

    Apesar das estações 192.168.0.0/24 pingar o PFSENSE (10.1.1.2) o mesmo não acontece com a RB750 que não pinga pfsense, mas o pfsense pinga a RB.

    Nesta rede ainda tem um server windows 2012 (AD) e um Server Printer (Windows Server 2008 R2) nehum dos dois pinga o PFSENSE.


    Estranho não?

    Abraço



  9. #9

    Padrão Re: O que precisa fazer para as solicitações sejam enviada para um Proxy na rede?

    apliquei a regra de redirecionamento para IP 10.1.1.2 (proxy) mas quando configuro o browser em uma estação não consegue navegar.

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=proxy disabled=no dst-port=80 in-interface=Clientes protocol=tcp to-addresses=10.1.1.2 to-ports=3128

    O pfsense já esta configurado e habilitado o Proxy.

    o que pode ser agora?