+ Responder ao Tópico



  1. #1

    Padrão Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Colegas.
    Estou com um problema e não acho o a causa real, não sei se é na minha rede ou a operadora que está com alguma rota errada, sei lá!! Bem vamos ao cenário:
    Temos um link dedicado com um bloco alocado /28, como preciso repassar os ips para alguns servidores que precisam ter ip válido diretamente nele, fiz a seguinte configuração:
    Dividi o bloco /28 em três => /30 wan => /30 e /29 lan

    === ENDEREÇOS ====
    WAN
    REDE: 187.115.123.160/30
    GW: 187.115.123.161/30
    etherWAN: 187.115.123.162
    BROAD: 187.115.123.163/30

    LAN
    REDE: 187.115.123.164/30
    GW: 187.115.123.165/30
    etherLAN: 187.115.123.165/30
    BROAD: 187.115.123.167/30

    REDE: 187.115.123.168/29
    GW: 187.115.123.169/29
    etherLAN: 187.115.123.169/29
    BROAD: 187.115.123.174/29

    ==== ROTAS ====

    0.0.0.0/0 GW 187.115.123.161
    187.115.123.160/30 GW etherWAN (dinâmica)
    187.115.123.164/30 GW etherLAN (dinâmica)
    187.115.123.168/29 GW etherLAN (dinâmica)
    18.115.123.164/30 GW 187.115.123.161
    187.115.123.168/29 GW 187.115.123.161

    Coloquei o ip no servidor e o mesmo navega normalmente porém quando vou acessá-lo de fora da rede, o ip é inalcançável.
    Segue um traceroute:

    === TRACEROUTE EXTERNO ===
    Traçando rota para 187.115.123.166


    traceroute to 187.115.123.166 (187.115.123.166), 30 hops max, 60 byte packets
    1 166.78.53.2 (166.78.53.2) 1.010 ms
    2 aggr160a-3.core9.dfw1.rackspace.net (98.129.84.104) 0.989 ms
    3 core9-corea.corea.dfw3.rackspace.net (74.205.108.44) 2.475 ms
    4 be31.dcpe1.dfw1.rackspace.net (74.205.108.112) 3.049 ms
    5 10.25.1.131 (10.25.1.131) 4.674 ms
    6 *
    7 GBLX-level3-13X10G.Dallas.Level3.net (4.68.70.2) 4.744 ms
    8 ae0-160G.ar4.GRU1.gblx.net (67.16.148.6) 138.661 ms
    9 159.63.54.66 (159.63.54.66) 142.619 ms
    10 201.22.64.102.dynamic.dialup.gvt.net.br (201.22.64.102) 138.705 ms
    11 gvt-te-0-15-0-7.rc05.cta.gvt.net.br (189.59.247.178) 147.520 ms
    12 gvt-be-7.rc03.cta.gvt.net.br (179.184.81.25) 151.705 ms
    13 gvt-te-0-5-0-0.rc01.pae.gvt.net.br (179.185.130.138) 155.773 ms
    14 gvt-te-8-1.rd01.pae.gvt.net.br (189.59.252.254) 155.270 ms
    15 ditech.static.gvt.net.br (177.19.164.147) 155.697 ms
    16 ditech.static.gvt.net.br (177.19.164.147) 3001.624 ms !H


    === TRACEROUTE INTERNO ===

    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
    1 corporativo.static.gvt.net.br (187.115.123.165) 0.255 ms 0.234 ms 0.310 ms
    2 corporativo.static.gvt.net.br (187.115.123.161) 1.066 ms 1.246 ms 1.611 ms
    3 vlan2101.static.gvt.net.br (177.19.164.146) 3.276 ms 3.171 ms 3.158 ms
    4 gvt-te-0-2-0-1.rc02.pae.gvt.net.br (189.59.252.213) 5.496 ms gvt-te-0-7-0-0.rc01.pae.gvt.net.br (189.59.252.253) 3.282 ms gvt-te-0-2-0-1.rc02.pae.gvt.net.br (189.59.252.213) 5.409 ms
    5 gvt-te-0-15-0-12.rc03.cta.gvt.net.br (189.59.253.62) 13.195 ms gvt-te-0-10-0-11.rc03.cta.gvt.net.br (201.86.56.115) 15.350 ms gvt-te-0-15-0-12.rc03.cta.gvt.net.br (189.59.253.62) 13.158 ms
    6 gvt-te-0-0-0-25.rc01.spo.gvt.net.br (201.22.76.126) 19.246 ms 24.423 ms 24.418 ms
    7 201.22.64.97.dynamic.dialup.gvt.net.br (201.22.64.97) 20.715 ms 18.699 ms 18.678 ms
    8 72.14.197.255 (72.14.197.255) 17.887 ms 17.785 ms 17.778 ms
    9 216.239.51.117 (216.239.51.117) 18.201 ms 216.239.43.91 (216.239.43.91) 17.761 ms 18.328 ms
    10 66.249.95.97 (66.249.95.97) 19.760 ms 74.125.37.107 (74.125.37.107) 19.300 ms 216.239.56.51 (216.239.56.51) 18.987 ms
    11 google-public-dns-a.google.com (8.8.8.8) 18.200 ms 17.615 ms 17.945 ms


    Alguém pode me dar uma luz??

    Agradeço desde já!!

  2. #2

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Me confirma se estou correto, pelo que intendi o seu cenário é esse:

    Clique na imagem para uma versão maior

Nome:	         rede.png
Visualizações:	106
Tamanho: 	13,8 KB
ID:      	64158



  3. #3

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    cara eu tava com o mesmo problema, pesquisa sobre nat 1:1 ou me manda um email q te dou um help , [email protected]


    Sent from my iPhone usring UnderLinux

  4. #4

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    O cenário é este mesmo!!!! Não sei se o problema está sendo por causa de ARP?!?!

    Citação Postado originalmente por rguerim Ver Post
    Me confirma se estou correto, pelo que intendi o seu cenário é esse:

    Clique na imagem para uma versão maior

Nome:	         rede.png
Visualizações:	106
Tamanho: 	13,8 KB
ID:      	64158



  5. #5

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Daniel, agradeço muito a tua ajuda!!! O problema é que usando o nat 1:1 utiliza-se netmap correto? Neste caso eu não posso usar pois preciso do ip público chegando na ether do server!!

  6. #6

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    O problema está em como o bloco está sendo entregue pra você.

    Peça um /30 para a operadora e mais um /29 ou /28 de IP válido roteado para esse /30.



  7. #7

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Maurobranquinho, boa noite, precisa mesmo fazer essa divisão em blocos? Não poderia tentar resolver isso usando uma bridge?

  8. #8

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Pois é.. Ontem abri um protocolo na VIVO (antiga GVT) para refazer todas as alocações de bloco. Como me informaram, eles não alocam bloco /30 então ficou protocolado para alocar um /29 para WAN e outro bloco /28 para LAN. Assim acredito que conseguirei fazer o que precisamos. Quanto a bridge não é possível pois tenho a rede interna tbm.



  9. #9

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Nat 1:1 da na mesma amigo!
    So não ira colocar o ip publico direto no server, mais será como se fosse!

  10. #10

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Buenas @Maurobranquinho

    Isso é facilmente atingido mudando um pouco as configs.
    Ajeita a interface que recebe o link para ficar com o mesmo prefixo do seu bloco.

    === ENDEREÇOS ====
    WAN
    REDE: 187.115.123.160/28
    GW: 187.115.123.161
    etherWAN: 187.115.123.162/28


    Após isso, é só você, pelo Winbox, ir em IP->ARP e adicionar os IPs públicos que quer usar dentro da sua rede, com a opção Published. Algo assim:

    Código :
    /ip arp add address=187.115.123.166 interface=etherWAN published=yes
    /ip arp add address=187.115.123.170 interface=etherWAN published=yes

    Agora é só você conectar seus servidores em qualquer porta da RB e configurar esses IPs lá. Como todo o bloco /28 é seu, os IPs que você colocar como Published serão anunciados (responderão ao ARP) como pertencendo a etherWAN para a sua operadora, mas não estarão no IP->Address. E portanto, a operadora vai enviar para a RB os pacotes com destino para aquele endereço, a RB vai ver que não é IP dela e que está Published no ARP e vai repassar para o dispositivo dono desse IP. A RB nesse caso vai funcionar como um proxy, mas para todos os efeitos, tanto da internet quando do dispositivo, é como se ele estivesse conectado diretamente na internet com aquele IP WAN.

    Você só tem que tomar o cuidado de no dispositivo onde configurar esses IPs, colocar o gateway deles o IP da sua RB, ou seja, 187.115.123.161.



  11. #11

    Padrão Re: Ip válido: Servidor sai para a internet mas não é alcançável externamente

    Cara.. Muito obrigado!!!!!!! Funcionou tudo perfeito. Não sabia que era somente este detalhe!!!!