Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão BGP no ASR 1001

    Ola pessoal,

    Tenho 2 links (IP e PTT) rodando no quagga. Comprei um cisco ASR-1001, copiei e colei do quagga pro ASR, sendo que o BGP sobre, meus outros roteadores (mikrotiks) recebem o ip do ASR como default route pelo OSPF (default-information originate always) e ficam sem acesso.
    Ja ate coloquei a configuração como sugere o site IX.br sendo que nao vai !

    configuração do ASR:
    version 15.5
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no platform punt-keepalive disable-kernel-core
    platform hardware throughput level 5000000
    !
    hostname ASR-Borda
    !
    boot-start-marker
    boot system bootflash:/asr1001-universal.03.16.04b.S.155-3.S4b-ext.bin
    boot-end-marker
    !
    aqm-register-fnf
    !
    vrf definition Mgmt-intf
    !
    address-family ipv4
    exit-address-family
    !
    address-family ipv6
    exit-address-family


    ip name-server 8.8.8.8 8.8.4.4
    !
    interface Loopback0
    ip address 131.196.116.3 255.255.255.255
    !
    interface GigabitEthernet0/0/0
    description LINK PTT
    ip address 189.45.5.XX 255.255.255.252
    no negotiation auto
    !
    interface GigabitEthernet0/0/1
    description LINK INTERNET
    ip address 189.45.5.yyy 255.255.255.252
    no negotiation auto
    !
    interface GigabitEthernet0/0/3
    ip address 131.196.116.62 255.255.255.240
    no negotiation auto
    !
    router ospf 1
    router-id 131.196.116.3
    passive-interface GigabitEthernet0/0/0
    passive-interface GigabitEthernet0/0/1
    passive-interface GigabitEthernet0/0/2
    passive-interface TenGigabitEthernet0/1/0
    network 131.196.116.0 0.0.3.255 area 0.0.0.0
    default-information originate always
    !
    router bgp 265924
    bgp always-compare-med
    no bgp enforce-first-as
    bgp log-neighbor-changes
    neighbor IX_br-IPv4 peer-group
    neighbor IX_br-IPv4 remote-as 28338
    neighbor IX_br-IPv4 transport connection-mode active
    neighbor IX_br-IPv4 version 4
    neighbor 189.45.5.xx peer-group IX_br-IPv4
    neighbor 189.45.5.xx description LINK PTT
    neighbor 189.45.5.yyy peer-group IX_br-IPv4
    neighbor 189.45.5.yyy description LINK INTERNET
    !
    address-family ipv4
    network 131.196.116.0 mask 255.255.252.0
    network 131.196.116.0 mask 255.255.254.0
    network 131.196.118.0 mask 255.255.254.0
    neighbor IX_br-IPv4 next-hop-self
    neighbor IX_br-IPv4 soft-reconfiguration inbound
    neighbor IX_br-IPv4 route-map BGPv4_IX.br_OUT out
    neighbor 189.45.5.xx activate
    neighbor 189.45.5.yyy activate
    exit-address-family
    !
    ip forward-protocol nd


    ip prefix-list BGPv4_IX.br_OUT seq 10 permit 131.196.116.0/22
    ip prefix-list BGPv4_IX.br_OUT seq 20 permit 131.196.116.0/23
    ip prefix-list BGPv4_IX.br_OUT seq 30 permit 131.196.118.0/23
    !
    route-map BGPv4_IX.br_OUT permit 10
    match ip address prefix-list BGPv4_IX.br_OUT
    !

    -------------
    Ele recebe todas as rotas e chega a pingar externamente:
    ASR-Borda(config-router)#do sh ip bgp sum
    BGP router identifier 131.196.116.3, local AS number 265924
    BGP table version is 1104848, main routing table version 1104848
    661998 network entries using 164175504 bytes of memory
    681153 path entries using 81738360 bytes of memory
    100870/100808 BGP path/bestpath attribute entries using 25015760 bytes of memory
    89565 BGP AS-PATH entries using 4762734 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 275692358 total bytes of memory
    BGP activity 883264/221264 prefixes, 908897/227744 paths, scan interval 60 secs


    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
    189.45.5.xx 4 28338 4740 4 1104772 0 0 00:00:51 19202
    189.45.5.yyy 4 28338 104545 5 1104772 0 0 00:01:19 661951
    ------------------
    ASR-Borda(config-router)#do ping 8.8.8.8
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/1 ms
    ------------------

    Até ai beleza, sendo que que quando dou um tracert dos meus Mikrotiks pra 8.8.8.8 o MK direciona pro ASR (131.196.116.62) e não passa pelo ASR, dá só perda. Sendo que no quagga funciona perfeito.

    O que pode ser ?

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.938
    Posts de Blog
    1

    Padrão Re: BGP no ASR 1001

    primeiro parabéns pela aquisição isto é maquina
    segundo pode ser N coisas
    ta faltando algumas coisas ai

    alias esta conf ta dificil de entender o transito ta no mesmo grupo do ptt

    mais falta vc incluir seus prefixos na RIB



  3. #3

    Padrão Re: BGP no ASR 1001

    Na interface GigabitEthernet0/0/3 (131.196.116.62/28) esta ligado num switch onde se encontra meu pc (131.196.116.61/28).

    Meu PC pinga o ASR ok
    No ASR eu pingo meu PC e pingo internet (8.8.8.8 ex)
    A rota-default do meu pc esta apontando pro ASR e mesmo assim meu PC nao passa por ele, pinga o ASR mas nao pinga 8.8.8.8, é como se o ASR nao estivesse fazendo "ip forward"

    aki eu anuncio meus prefixos do meu AS:
    ip prefix-list BGPv4_IX.br_OUT seq 10 permit 131.196.116.0/22
    ip prefix-list BGPv4_IX.br_OUT seq 20 permit 131.196.116.0/23
    ip prefix-list BGPv4_IX.br_OUT seq 30 permit 131.196.118.0/23
    !
    route-map BGPv4_IX.br_OUT permit 10
    match ip address prefix-list BGPv4_IX.br_OUT

    aparentemente tudo certo

  4. #4
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.938
    Posts de Blog
    1

    Padrão Re: BGP no ASR 1001

    os prefix-list não tem nada haver com RIB e FIB

    exatamente ele não esta fazendo o ip forward pq falta seus prefixo entrar na FIB



  5. #5

    Padrão Re: BGP no ASR 1001

    @Delvalle,

    Traduzindo, adiciona a rota estática dos seus prefixos para dentro da sua rede

  6. #6

    Padrão Re: BGP no ASR 1001

    eu fiz isso a pedido do amigo BRuno,

    ip route 131.196.116.0 255.255.252.0 Null0
    ip route 131.196.116.0 255.255.254.0 Null0
    ip route 131.196.118.0 255.255.254.0 Null0

    ai funcionou, sendo q quando levanto o PTT cai tudo, ai passei o problema pra minha operadora que ainda esta analisando.