Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Lightbulb 1 link com BGP + 1 link normal sem BGP

    Olá pessoal

    Já possuo AS com 1 link fazendo BGP funcionando perfeito com rota default

    Queria saber se é possível, no mesmo roteador, incluir na mesma rede mais 1 link normal, sem AS com somente 1 ip público da operadora para compartilhamento em ip local.

    Já tentei fazer marcações com mangle, mas o maior problema é a rota default para o link sem AS

    Eu queria que os clientes PPPoE com ip 100.99.1.0/24 trafegassem no link sem AS

  2. #2

    Padrão

    Boa noite,

    É possível sim

    Caso necessite de ajuda: 79 99998-9976



  3. #3

    Padrão Re: 1 link com BGP + 1 link normal sem BGP

    Bom, se vc já marcou as conexões no mangle, está no caminho

    Crie a rota default para o link que não tem sessão BGP com uma routing mark

    Faça a marcação de rota para tudo que deseja passar neste link.

    Não esqueça que neste link, vc precisará fazer o nat.

  4. #4

    Padrão

    Citação Postado originalmente por fhayashi Ver Post
    Bom, se vc já marcou as conexões no mangle, está no caminho

    Crie a rota default para o link que não tem sessão BGP com uma routing mark

    Faça a marcação de rota para tudo que deseja passar neste link.

    Não esqueça que neste link, vc precisará fazer o nat.
    então.. fiz tudo isso, criei uma rota 0.0.0.0/0 para o gateway da ONT que me fornece o link sem AS com a marcação conforme fiz no mangle e não vai.. o engraçado é que peguei uma RB e conectei ao meu sistema com configuração simples e deu certo, mas dentro da minha rede não funcionou, eu vejo tráfego na interface da ONT mas não tenho navegação, fiz nat com masquerad e src-nat também nessa interface...



  5. #5

    Padrão Re: 1 link com BGP + 1 link normal sem BGP

    Antes de executar o script, faça um backup completo da RB, execute o script com o safe mode habilitado e preferencialmente de madrugada para caso ocorra algum erro não pare a conexão de seus clientes.


    # Adiciona o bloco que irá utilizar no link SEM bgp em uma address list
    /ip firewall address-list
    add address=100.99.1.0/24 list="CLIENTES-FORA-BGP"
    /

    /ip firewall mangle
    # Faz o bloco não passar pelas regras caso tenha destino algum IP do mesmo bloco.
    add action=accept chain=prerouting comment="LOCAL-PARA-LOCAL" dst-address-list=CLIENTES-FORA-BGP src-address-list=CLIENTES-FORA-BGP

    # Faz a conexão sair pelo menos link que chegou, mude a porta em in-interface para a porta que está recebendo o link.
    add action=mark-connection chain=prerouting comment="IN-LINK-FORA-BGP" connection-mark=no-mark in-interface=ether2 new-connection-mark=Link-FORA-BGP-Conn passthrough=yes

    # Faz a marcação da rota
    add action=mark-routing chain=output comment="OUT-LINK-FORA-BGP" connection-mark=Link-FORA-BGP-Conn new-routing-mark=Link-FORA-BGP-Rota passthrough=yes

    # Faz a marcação nos pacotes de origem o bloco 100.99.1.0/24
    add action=mark-connection chain=prerouting comment="Marca Conexo" dst-address-type=!local new-connection-mark=Link-FORA-BGP-Conn passthrough=yes src-address=100.99.1.0/24


    # Faz a marcação de rota de origem o bloco 100.99.1.0/24 com a marca de conexão Link-FORA-BGP-Conn
    add action=mark-routing chain=prerouting comment="Marca Rota" connection-mark=Link-FORA-BGP-Conn new-routing-mark=Link-FORA-BGP-Rota passthrough=yes src-address=100.99.1.0/24


    # Faz um nat em cima do bloco 100.99.1.0/24 saindo pela interface do link sem BGP, mude o out-interface para a porta do link sem BGP.
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether2 src-address=100.99.1.0/24
    /

    # Cria a rota Default para a marcação de rota FORA-BGP-Rota, troque o gateway para o IP da operadora que te entraga o Link sem BGP.
    /ip route
    add distance=1 gateway=100.100.100.1 routing-mark=Link-FORA-BGP-Rota
    /

  6. #6

    Padrão Re: 1 link com BGP + 1 link normal sem BGP

    Me tire uma dúvida, a autenticação PPPoE é feita em outra RB, correto? se sim, tu não pode fazer o NAT da rede 100.99.1.0/24 na RB do PPPoE, o nat será feito no próprio BGP, apesar de não ser correto em relação a boas praticas.