Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Desafio do PPPOE

    Bom dia

    Senhores estou com um problema que ja está me deixando de cabelo branco, de uns tempos pra cá comecei a ter problemas de quedas de conexão nos clientes que autenticam em PPPoE, ja busquei na internet e sites gringos e ninguém conseguiu achar uma solução. Queria poder juntar forças com vocês para possamos conseguir resolver esse problema e poder ajudar outros que passam por isso.

    Cenario:

    Server PPPoE
    CCR 1036-12G-4S>>>PTP_FIBRA>>>DATACOM EDD>>>OLT EPON CIANET + REDE VDC

    Rede VDC com cascateamento com Switch Intelbras
    Rede EPON FTTH+Hibrida

    A mensagem que aparecia era essa
    Clique na imagem para uma versão maior

Nome:	         PEER.png
Visualizações:	91
Tamanho: 	3,3 KB
ID:      	68885
    pesquisei por esse logo e não encontrei nada então habilitei o debug do log e descobri que antes da queda do cliente aparece essa mensagem.
    Clique na imagem para uma versão maior

Nome:	         debug.png
Visualizações:	134
Tamanho: 	39,1 KB
ID:      	68884

    Voltei a pesquisar novamente e so encontro post's sem solução.
    Antes eu pensava que o problema acontecia por eu ter uma rede VDC, mas depois que ativei a rede de fibra o problema de autenticação persiste.
    O que já tentei foi tentar atualizar o firmware, mudar o keepalive out, mudar o MTU e nenhum resolveu. Qualquer duvida podem perguntar a vontade.

  2. #2

    Padrão Re: Desafio do PPPOE

    Olá. Quantas sessões PPPoE em cada VLAN?

    Imagino que não esteja usando Bridge né? Caso sim, a conversa termina aqui! Hehe, brincadeira. Conta melhor os detalhes aí pra gente saber.



  3. #3

    Padrão

    Citação Postado originalmente por andrecarlim Ver Post
    Olá. Quantas sessões PPPoE em cada VLAN?


    Imagino que não esteja usando Bridge né? Caso sim, a conversa termina aqui! Hehe, brincadeira. Conta melhor os detalhes aí pra gente saber.
    kkkkk... ja passei dessa fase a muito tempo!!

    Ta separado em 4 vlan's.

    Vlan5 gerencia equipamentos
    Vlan150 - saida vdc01
    vlan151 - saida vdc02
    vlan152 - saida epon

    tem poucas sessões media de 15 em cada.

  4. #4

    Padrão Re: Desafio do PPPOE

    Essa quantia não deveria apresentar problemas. Acredito que o keepalive timeout esteja com 15 segundos ou mais, se sim, tente entender o problema. A mensagem ali de "peer is not responding" quer dizer que algo fez com que o processo de pppoe que esta atendendo aquele cliente, ao enviar o pacote LCP esperando uma resposta positiva, não obtivesse resposta alguma, assim ele acredita que a sessão pppoe não precisa ficar estabelecida, o problema, do meu ponto de vista, não é o mikrotik em si, mas algo que esta "interrompendo" a comunicação na camada 2 (onde se estabelece o LCP) e assim "enganando" o serviço de pppoe.

    Se você já não fez isso, a critério de teste, pode deixar o keepalive timout em 60 segundos, para ver se ainda vai apresentar o problema.

    Outra coisa, você tem outros serviços sendo feitos por essa CCR? Algo que possa estar consumindo muita CPU?



  5. #5

    Padrão

    Citação Postado originalmente por andrecarlim Ver Post
    Essa quantia não deveria apresentar problemas. Acredito que o keepalive timeout esteja com 15 segundos ou mais, se sim, tente entender o problema. A mensagem ali de "peer is not responding" quer dizer que algo fez com que o processo de pppoe que esta atendendo aquele cliente, ao enviar o pacote LCP esperando uma resposta positiva, não obtivesse resposta alguma, assim ele acredita que a sessão pppoe não precisa ficar estabelecida, o problema, do meu ponto de vista, não é o mikrotik em si, mas algo que esta "interrompendo" a comunicação na camada 2 (onde se estabelece o LCP) e assim "enganando" o serviço de pppoe.

    Se você já não fez isso, a critério de teste, pode deixar o keepalive timout em 60 segundos, para ver se ainda vai apresentar o problema.

    Outra coisa, você tem outros serviços sendo feitos por essa CCR? Algo que possa estar consumindo muita CPU?
    O Keepalive timeout esta é 10 segundos, como eu pesquisei bastante conseguir entender como funciona o pppoe e cheguei nessa mesma conclusão sua, rsrsrs deve ser algo entrea CCR e a Rede VDC que seria um switch gerenciavel, antes eu estava com um switch cisco 2960, tirei ele e concentrei tudo em um datacom 2104 EDD e ainda continua caindo. O teste que irei fazer no momento é colocar um roteador direto na CCR e ver se esse pppoe apresenta alguma queda.

    Vou colocar em 60 segundos pra ver se resolve.

  6. #6

    Padrão

    Boa tarde amigo, sei bem o que é passar por isso, a unica versão que me deu estabilidade e parou as quedas pppoe foi a 6.37.5 bugfix, ja tentou usa-la? faça o teste, vai ver que ate o tempo de autenticação dos clientes em caso de que do servidor é absurdamente rapida em relação as outras versões MK.

    Citação Postado originalmente por Ueltth Ver Post
    O Keepalive timeout esta é 10 segundos, como eu pesquisei bastante conseguir entender como funciona o pppoe e cheguei nessa mesma conclusão sua, rsrsrs deve ser algo entrea CCR e a Rede VDC que seria um switch gerenciavel, antes eu estava com um switch cisco 2960, tirei ele e concentrei tudo em um datacom 2104 EDD e ainda continua caindo. O teste que irei fazer no momento é colocar um roteador direto na CCR e ver se esse pppoe apresenta alguma queda.

    Vou colocar em 60 segundos pra ver se resolve.