+ Responder ao Tópico



  1. #1

    Padrão Ajuda

    Boa noite, tenho um pequeno provedor, funcionando com um link de 50M na ather 1 de uma rb750g3 (Hex) as outras portas estão dentro de uma bridge atendendo alguns clientes em pppoe, na semana passada adiquiri mais um link e mais uma rb pra uns novos clientes porem nao estou sabendo fazer p ter acesso e tambem usar o outro link como backup.Clique na imagem para uma versão maior

Nome:	         PicsArt_03-06-10.41.45.jpg
Visualizações:	16
Tamanho: 	276,5 KB
ID:      	69481

  2. #2

    Padrão

    Citação Postado originalmente por Heler Ver Post
    Boa noite, tenho um pequeno provedor, funcionando com um link de 50M na ather 1 de uma rb750g3 (Hex) as outras portas estão dentro de uma bridge atendendo alguns clientes em pppoe, na semana passada adiquiri mais um link e mais uma rb pra uns novos clientes porem nao estou sabendo fazer p ter acesso e tambem usar o outro link como backup.Clique na imagem para uma versão maior

Nome:	         PicsArt_03-06-10.41.45.jpg
Visualizações:	16
Tamanho: 	276,5 KB
ID:      	69481



    CARA ESTOU TE ENVIANDO UM BALANCE + FALL OVER SEGUE O SCRIPT
    A ONDE ESTAR OS IPS COM X É SO VOCE EDTAR COM O SEU..VLW ABRAÇO ESPERO TER AJUDADO

    add fast-forward=no name=Local
    /interface ethernet
    set [ find default-name=ether1 ] comment="link1 net 200mb" speed=100Mbps
    set [ find default-name=ether2 ] comment="link2 net 120mb" speed=100Mbps
    set [ find default-name=ether3 ] name=ether3-cliente speed=100Mbps
    set [ find default-name=ether4 ] name=ether4-cliente speed=100Mbps
    set [ find default-name=ether5 ] name=ether5-cliente speed=100Mbps
    set [ find default-name=ether6 ] speed=100Mbps
    set [ find default-name=ether7 ] speed=100Mbps
    set [ find default-name=ether8 ] speed=100Mbps
    set [ find default-name=ether9 ] speed=100Mbps
    set [ find default-name=ether10 ] speed=100Mbps
    set [ find default-name=ether11 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
    set [ find default-name=ether12 ] advertise=\
    10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
    /ip pool
    add name=PPPoE. ranges=192.168.x.2-192.168.x.254
    /ppp profile
    add change-tcp-mss=yes name=15M only-one=yes rate-limit=5000k/15360k \
    use-compression=no use-encryption=no use-mpls=no use-upnp=no
    add change-tcp-mss=yes name=10M only-one=yes rate-limit=2500k/10724k \
    use-compression=no use-encryption=no use-mpls=no use-upnp=no
    add change-tcp-mss=yes name=5M only-one=yes rate-limit=1500k/5224k \
    use-compression=no use-encryption=no use-mpls=no use-upnp=no
    /queue simple
    add max-limit=100M/100M name=Geral target=192.168.x.0/24,192.168.x.0/24
    add max-limit=100M/100M name=Cliente parent=Geral target=\
    192.168.x.0/24,192.168.x.0/24
    add max-limit=512k/2M name=admin parent=Cliente target=192.168.x.10/32
    /ppp profile
    add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 local-address=192.168.x.1 \
    name=PPPoE parent-queue=Cliente remote-address=PPPoE. use-compression=no \
    use-encryption=no use-mpls=no use-upnp=no
    /queue type
    set 9 pfifo-limit=50
    /interface bridge port
    add bridge=Local interface=ether3-cliente
    add bridge=Local interface=ether4-cliente
    add bridge=Local interface=ether5-cliente
    /interface detect-internet
    set detect-interface-list=all
    /interface pppoe-server server
    add authentication=chap,mschap1,mschap2 default-profile=PPPoE disabled=no \
    interface=Local max-mru=1480 max-mtu=1480 one-session-per-host=yes \
    service-name=SERVICE
    /ip address
    add address=192.168.x.1/24 interface=Local network=192.168.x.0
    add address=192.168.x.2/24 comment="Link1 - VIVO" interface=ether1 network=\
    192.168.x.0
    add address=192.168.x.2/24 comment="Link2 - NET" interface=ether2 network=\
    192.168.x.0
    /ip cloud
    set ddns-enabled=yes
    /ip dns
    set allow-remote-requests=yes cache-size=12000KiB servers=8.8.8.8,8.8.4.4
    /ip firewall address-list
    add address=10.0.0.0/8 list=Rede_Privada
    add address=172.16.0.0/12 list=Rede_Privada
    add address=192.168.0.0/16 list=Rede_Privada
    add address=170.66.0.0/16 list=NOBALANCE
    add address=198.184.161.0/24 list=NOBALANCE
    /ip firewall mangle
    add action=accept chain=prerouting comment=NOBALANCE src-address-list=\
    NOBALANCE
    add action=mark-routing chain=prerouting comment=Link1 new-routing-mark=\
    Link1_Router passthrough=no per-connection-classifier=\
    both-addresses-and-ports:6/0 src-address-list=Rede_Privada
    add action=mark-routing chain=prerouting new-routing-mark=Link1_Router \
    passthrough=no per-connection-classifier=both-addresses-and-ports:6/1 \
    src-address-list=Rede_Privada
    add action=mark-routing chain=prerouting new-routing-mark=Link1_Router \
    passthrough=no per-connection-classifier=both-addresses-and-ports:6/2 \
    src-address-list=Rede_Privada
    add action=mark-routing chain=prerouting new-routing-mark=Link1_Router \
    passthrough=no per-connection-classifier=both-addresses-and-ports:6/3 \
    src-address-list=Rede_Privada
    add action=mark-routing chain=prerouting new-routing-mark=Link2_Router \
    passthrough=no per-connection-classifier=both-addresses-and-ports:6/4 \
    src-address-list=Rede_Privada
    add action=mark-routing chain=prerouting new-routing-mark=Link2_Router \
    passthrough=no per-connection-classifier=both-addresses-and-ports:6/5 \
    src-address-list=Rede_Privada
    /ip firewall nat
    add action=masquerade chain=srcnat
    /ip route
    add check-gateway=ping distance=1 gateway=208.67.222.222 routing-mark=\
    Link1_Router
    add check-gateway=ping distance=1 gateway=208.67.220.220 routing-mark=\
    Link2_Router
    add check-gateway=ping distance=1 gateway=208.67.222.222
    add check-gateway=ping distance=2 gateway=208.67.220.220
    add distance=1 dst-address=208.67.220.220/32 gateway=192.168.x.1 scope=10
    add distance=1 dst-address=208.67.222.222/32 gateway=192.168.x.1 scope=10
    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set ssh disabled=yes
    set api disabled=yes
    set api-ssl disabled=yes
    /ip upnp
    set enabled=yes
    /ip upnp interfaces
    add interface=ether1 type=external
    add interface=ether2 type=external
    add interface=Local type=internal
    /ppp secret

    /system ntp client
    set enabled=yes primary-ntp=200.160.7.186 secondary-ntp=201.49.148.135
    /tool graphing interface
    add interface=ether1
    add interface=ether2



  3. #3

    Padrão Re: Ajuda

    Considerando o script do amigo Bruno, não irá funcionar logo no começo, pois além de começar com um comando "add fast-forward=no name=Local" sem nem informar o menu, suas RBs 750gr3 não possuem da ether 6 a 12, sem contar outras linhas que acredito que possam quebrar algo que você já tenha configurado.

    Failover é relativamente simples, quando você sabe o que está fazendo.
    Não existe receita de bolo para failover, cada cenário é um caso diferente, onde você precisará configurar de acordo com muitas variáveis, onde até mesmo o tamanho dos links interfere em quantas linhas terão que ser adicionadas para fazer o balanceamento.
    Um link de backup, se não for utilizado com failover, é mais fácil de configurar, mas para isso, precisamos ter certeza que a comunicação das 2 RBs já esteja 100%.

    Essa primeira parte é fácil, separa um /30 e configura nas 2 RBs, por exemplo:
    RB1 10.10.100.1/30
    RB2 10.10.100.2/30
    Pronto, já tem comunicação entre os 2 equipamentos.

  4. #4

    Padrão

    Citação Postado originalmente por Heler Ver Post
    Boa noite, tenho um pequeno provedor, funcionando com um link de 50M na ather 1 de uma rb750g3 (Hex) as outras portas estão dentro de uma bridge atendendo alguns clientes em pppoe, na semana passada adiquiri mais um link e mais uma rb pra uns novos clientes porem nao estou sabendo fazer p ter acesso e tambem usar o outro link como backup.Clique na imagem para uma versão maior

Nome:	         PicsArt_03-06-10.41.45.jpg
Visualizações:	16
Tamanho: 	276,5 KB
ID:      	69481
    bom dia a varias mandeira de vc fazer isso primeiro pode usar as duas rbs de modo decentralizado e fazer acesso via vpn ou pode usar e loand balance eu aconselho decentralizado loand balance e um quebra galho quando começa a falhar um link bagunça rede toda resumindo loand balance e dos tempos das cavernas o famoso jeitinho brasileiro



  5. #5

    Padrão Re: Ajuda

    Concordo com o bfwcache...
    Pessoalmente não gosto de balanceamentos com firewall... Por diversos fatores...
    mas cada caso é um caso, e vc tem de analizar as melhores formas pra vc
    Acho que vc poderia receber um link em cada uma das rbs, e autenticar clientes em ambas, dessa forma descentralizando, e ainda fazer que uma consiga usar a internet da outra pra redundancia...

    Estude um pouco as formas de fazer, decida qual seá mais interessante pra vc, e poste suas dividas que com certeza consiguira deixar 100%