+ Responder ao Tópico



  1. #1

    Padrão Roteador em modo PPPOE não conecta

    Pessoa tenho um rede em bridge como um cliente direto na torre via cabo autenticando por pppoe que não firma a conexão apresenta o seguinte erro = logged in. 0 64 56 4 5 . Existe outros roteadores da mesma marca em outras torres ligados da mesma forma que estão normais. Alguém teria alguma dica?

    Clique na imagem para uma versão maior

Nome:	         Sem título1.png
Visualizações:	13
Tamanho: 	18,5 KB
ID:      	69644
    Última edição por silvawes; 14-06-2019 às 15:02.

  2. #2

    Padrão Re: Roteador em modo PPPOE não conecta

    Tem várias coisas pra causas queda, basicamente o timeout da conexão está sendo curto demais.

    Na interface, em PPP profile, zerar (Deixar em banco) o idle-timeout, e o session-timeout, bota "no" no only-one, e também "no" no change-tcp-mss.

    As vezes tem alguma coisa no caminho comendo parte do cabeçalho TCP/IP, basicamente o MTU de 1492 bytes resulta em pacote quebrado quando algo no caminho fica limitado a 1472 bytes, aí é caso de testar limitar MTU nos 2 lados com vários valores pra teste (Teste!), usa os padrões tipo 1472, 1480, 1492, não precisa exagerar com 1522 e cia, o problema não é pacote grande, as vezes cai conexão justo quando tem pacote pequeno, quando ao invés de ter que quebrar pacote e colocar o cabeçalho em todas as partes ele envia pacote de só 60 ou 100 bytes.

    Geralmente não é timeout intencional, e sim algum pacote pequeno não contando como pacote/tráfego e o SO perde as contas e desconecta quando não deu o timeout selecionado, desativando/deixando em branco os campos do profile ppp ele nem contabiliza porque está setado pra nunca dar timeout. Enfim, é bug e não desconexão intencional, por isso não tem receita certeira, tem que sair testando tudo a respeito de timeout no server e profile ppp/pppoe, e tudo relativo aos tamanhos de pacotes quando o problema ocorre só depois de passar ou de não passar por alguma hardware no caminho (Só switch cego não altera nada, mas outros hardwares em bridge alteram o cabeçalho se não tiver wds ou similar ativo, é altera 2 bytes que já gera erro de checksum e a conexão é derrubada!).