Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Smile Ajuda com load balance + failover por rotas recursivas

    Boa noite pessoal, gostaria da ajuda de vocês pra desvendar o por que do loadbalance com failover por rotas recursivas que implementei numa rb750gr3 não ta balanceando os link, somente um dos links é utilizado, o link 1 só passa a ser usado quando o link 2 cai.

    O link 1 é de 10Mb e o link 2 de 40Mb.

    Nos testes que realizei, coloquei no PC uns 5 videos para reproduzir ao mesmo tempo todos em HD, um vídeo reproduzindo no Galaxy e Netflix na TV, tudo ao mesmo tempo, ai fiquei de olho no tráfego que tava passando pelas duas interfaces de entrada dos link (ether0 e ether1) e tudo estava passando somente por um dos links, o trafego não estava sendo dividido, já revisei essas regras zilhões de vezes e não consigo achar o problema. Peço encarecidamente que deem uma olhada na configuração.

    Agradeço a ajuda de todos

    vlw, abraco





    /interface ethernet
    set [ find default-name=ether1 ] comment="============= Link 1"
    set [ find default-name=ether2 ] comment="============= Link 2"
    set [ find default-name=ether3 ] comment="============= Link 3"
    set [ find default-name=ether4 ] comment="============= Gerencia"
    set [ find default-name=ether5 ] comment="============= Clientes PPPoE" \
    loop-protect=on loop-protect-disable-time=1m


    /ip pool
    add name=pool-clientes ranges=10.50.0.2-10.50.255.254
    add name=pool-gerencia ranges=192.168.88.2


    /ip dhcp-server
    add address-pool=pool-gerencia disabled=no interface=ether4 name=\
    dhcp-gerencia


    /ppp profile
    add comment=\
    "============= Profile com configuracoes padrao do servidor PPPoE" \
    local-address=10.50.0.1 name=profile-padrao remote-address=pool-clientes


    add comment="============= [PCC] Profile para monitoramento do Link1 via scrip\
    t com ping para DNS 8.8.4.4" name=profile-monitoramento-link1 on-down="/ip\
    \_route remove [find comment="============= PCC-rota-monitoramento-link1\
    "]" on-up="/ip route add ds=8.8.4.4 gateway=\$"remote-address" scope=10\
    \_comment="============= PCC-rota-monitoramento-link1""


    add comment="============= [PCC] Profile para monitoramento do Link2 via scrip\
    t com ping para DNS 9.9.9.9" name=profile-monitoramento-link2 on-down="/ip\
    \_route remove [find comment="============= PCC-rota-monitoramento-link2\
    "]" on-up="/ip route add ds=9.9.9.9 gateway=\$"remote-address" scope=10\
    \_comment="============= PCC-rota-monitoramento-link2""


    /interface pppoe-client
    add comment="============= [PCC] Discador PPPoE do link 1" disabled=no \
    interface=ether1 max-mtu=1500 name=pppoe-link1 password=gomes profile=\
    profile-monitoramento-link1 user=valmir


    add comment="============= [PCC] Discador PPPoE do link 2" disabled=no \
    interface=ether2 name=pppoe-link2 password=12345678 profile=\
    profile-monitoramento-link2 user=IZAAC


    /interface pppoe-server server
    add authentication=chap,mschap1,mschap2 default-profile=profile-padrao \
    disabled=no interface=ether5 max-mru=1492 max-mtu=1492 \
    one-session-per-host=yes service-name=servidor-pppoe


    /ip dns
    set allow-remote-requests=yes cache-size=20480KiB servers=\
    1.0.0.1,1.1.1.1,8.8.8.8,4.2.2.1,4.2.2.3


    /ip firewall address-list
    add address=10.0.0.0/8 list=rede-interna
    add address=172.16.0.0/12 list=rede-interna
    add address=192.168.0.0/16 list=rede-interna


    /ip firewall mangle
    add action=accept chain=prerouting comment=\
    "============= [PCC] Faz tafego da rede interna nao passar pelo PCC" \
    dst-address-list=rede-interna src-address-list=rede-interna


    add action=mark-connection chain=prerouting comment=\
    "============= [PCC] Marca conexao do link 1" connection-mark=no-mark \
    in-interface=pppoe-link1 new-connection-mark=conexao-link1 passthrough=\
    yes
    add action=mark-connection chain=prerouting comment=\
    "============= [PCC] Marca conexao do link 2" connection-mark=no-mark \
    in-interface=pppoe-link2 new-connection-mark=conexao-link2 passthrough=\
    yes


    add action=mark-routing chain=output comment=\
    "============= [PCC] Marca rota de saida do link 1" connection-mark=\
    conexao-link1 new-routing-mark=link1-rota passthrough=yes
    add action=mark-routing chain=output comment=\
    "============= [PCC] Marca rota de saida do link 2" connection-mark=\
    conexao-link2 new-routing-mark=link2-rota passthrough=yes


    add action=mark-connection chain=prerouting comment="============= [PCC] Marca\
    \_conexao do link 1 de acordo com regras do balanceamento (5/0)" \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    conexao-link1 passthrough=yes per-connection-classifier=\
    both-addresses:5/0
    add action=mark-connection chain=prerouting comment="============= [PCC] Marca\
    \_conexao do link 2 de acordo com regras do balanceamento (5/1)" \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    conexao-link2 passthrough=yes per-connection-classifier=\
    both-addresses:5/1
    add action=mark-connection chain=prerouting comment="============= [PCC] Marca\
    \_conexao do link 2 de acordo com regras do balanceamento (5/2)" \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    conexao-link2 passthrough=yes per-connection-classifier=\
    both-addresses:5/2
    add action=mark-connection chain=prerouting comment="============= [PCC] Marca\
    \_conexao do link 2 de acordo com regras do balanceamento (5/3)" \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    conexao-link2 passthrough=yes per-connection-classifier=\
    both-addresses:5/3
    add action=mark-connection chain=prerouting comment="============= [PCC] Marca\
    \_conexao do link 2 de acordo com regras do balanceamento (5/4)" \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    conexao-link2 passthrough=yes per-connection-classifier=\
    both-addresses:5/4


    add action=mark-routing chain=prerouting comment=\
    "============= [PCC] Marca rota do link 1" connection-mark=conexao-link1 \
    in-interface=ether5 new-routing-mark=link1-rota passthrough=yes
    add action=mark-routing chain=prerouting comment=\
    "============= [PCC] Marca rota do link 2" connection-mark=conexao-link2 \
    in-interface=ether5 new-routing-mark=link2-rota passthrough=yes


    /ip firewall nat
    add action=masquerade chain=srcnat comment="============= NAT no Link 1" \
    out-interface=pppoe-link1
    add action=masquerade chain=srcnat comment="============= NAT no Link 2" \
    out-interface=pppoe-link2


    /ip firewall raw
    add action=passthrough chain=prerouting comment=\
    "============= Regra para monitoramento"
    add action=drop chain=prerouting comment="============= Descarta requisico
    es (TCP) externa ao servidor DNS local" dst-port=53 in-interface=ether1 \
    protocol=tcp src-address-list=!rede-interna
    add action=drop chain=prerouting comment="============= Descarta requisico
    es (UDP) externa ao servidor DNS local" dst-port=53 protocol=udp \
    src-address-list=!rede-interna


    /ip route
    add comment="============= [PCC] Rota padrao PCC link 1" distance=1 gateway=\
    8.8.4.4 routing-mark=link1-rota
    add comment="============= [PCC] Rota padrao PCC link 2" distance=1 gateway=\
    9.9.9.9 routing-mark=link2-rota


    add check-gateway=ping comment="============= [PCC] Rota padrao link 2" \
    distance=1 gateway=9.9.9.9
    add check-gateway=ping comment="============= [PCC] Rota padrao link 1" \
    distance=2 gateway=8.8.4.4


    add comment="============= PCC-rota-monitoramento-link1" distance=1 \
    dst-address=8.8.4.4/32 gateway=171.1.1.1 scope=10
    add comment="============= PCC-rota-monitoramento-link2" distance=1 \
    dst-address=9.9.9.9/32 gateway=172.16.10.1 scope=10


    /ip service
    set telnet disabled=yes
    set ftp disabled=yes
    set ssh address=172.20.1.1/32 port=2215
    set api disabled=yes
    set api-ssl disabled=yes
    /ppp aaa
    set interim-update=5m use-radius=yes
    /radius
    add address=172.20.1.1 secret=123456 service=ppp timeout=900ms
    /radius incoming
    set accept=yes
    /system clock
    set time-zone-name=America/Fortaleza
    /system ntp client
    set enabled=yes primary-ntp=200.160.0.8 secondary-ntp=200.160.7.186

  2. #2

    Padrão Re: Ajuda com load balance + failover por rotas recursivas

    Tenta mudar
    De:
    /ip route
    add comment="============= [PCC] Rota padrao PCC link 1" distance=1 gateway=8.8.4.4 routing-mark=link1-rota
    add comment="============= [PCC] Rota padrao PCC link 2" distance=1 gateway=9.9.9.9 routing-mark=link2-rota

    Para:
    /ip route
    add comment="============= [PCC] Rota padrao PCC link 1" distance=1 gateway=pppoe-link1 routing-mark=link1-rota
    add comment="============= [PCC] Rota padrao PCC link 2" distance=1 gateway=pppoe-link2 routing-mark=link2-rota



  3. #3

    Padrão Re: Ajuda com load balance + failover por rotas recursivas

    Citação Postado originalmente por eberty Ver Post
    Tenta mudar
    De:
    /ip route
    add comment="============= [PCC] Rota padrao PCC link 1" distance=1 gateway=8.8.4.4 routing-mark=link1-rota
    add comment="============= [PCC] Rota padrao PCC link 2" distance=1 gateway=9.9.9.9 routing-mark=link2-rota

    Para:
    /ip route
    add comment="============= [PCC] Rota padrao PCC link 1" distance=1 gateway=pppoe-link1 routing-mark=link1-rota
    add comment="============= [PCC] Rota padrao PCC link 2" distance=1 gateway=pppoe-link2 routing-mark=link2-rota
    Agradeço a sugestão amigo, vou testar hoje a noite.

    Mas qual seria a explicação pra essa mudança? Só pra entender.

  4. #4

    Padrão

    Cara, não sei ao certo, porem aqui funcionou da forma que eu te passei. Outro detalhe uso apenas 2 dns e não tenho essa porta de gerencia. Aqui são 5 links e o balance é quase igual. Gerencio a rede pelo próprio ip da rede.



  5. #5

    Padrão Re: Ajuda com load balance + failover por rotas recursivas

    Outra detalhe é que não utilizo concentrador com ballance, aqui é tudo separado. tenho ballance(750gr3) + gerenciandor da rede(3011) + 4 concentradores(750gr3), na primeira 750 tem cgnat, alguns ips publicos e ibpg, da 3011 pra frente ospf, mpls + ibgp e entre ao ballance e a 3011 tenho 2 servidores dns(unbound) e radius tudo ligados em um switch.

  6. #6

    Padrão Re: Ajuda com load balance + failover por rotas recursivas

    Citação Postado originalmente por eberty Ver Post
    Cara, não sei ao certo, porem aqui funcionou da forma que eu te passei. Outro detalhe uso apenas 2 dns e não tenho essa porta de gerencia. Aqui são 5 links e o balance é quase igual. Gerencio a rede pelo próprio ip da rede.
    A quantidade de DNS nao vai inflienciar em nada, e só mesmo redundância, se os dois primeiros falharem (o que é quase impossível, o terceiro seria usado e assim por diante).

    A porta de gerência e só uma porta que uso pra conectar a rb no PC pra poder acessar via winbox.

    Vlw amigo, vou tentar fazer o que sugeriu e ver se funciona, trago os resultados mais tarde.

    Vlw, abraço.