+ Responder ao Tópico



  1. #1
    dboom
    Visitante

    Padrão permissões de CGI

    Não sei muito bem como me explicar, mas lá vai: Tenho um servidor rodando RH7 e a parte de internet quem configurou foi um amigo meu. Ele deixou duas pastas /var/www/html e /var/www/cgi-bin e me disse que poderia colocar os programas em cgi dentro da pasta cgi (dã), peguei um programinha de cartao virtual em cgi e conversando com o cara que fez o programa ele me disse que se eu tenho dois diretorios diferentes para pagina e cgi, nao vai funcionar o script dele (nem outro, segundo ele), e agora o que faço??? tem como colocar os programas e as paginas tudo em um unico diretorio?? sem ter que mudar muita coisa no servidor?? ou tem outra forma de executar cgi mesmo em pastas diferentes??

  2. #2
    paulogrifo
    Visitante

    Padrão permissões de CGI

    ((
    O problema é tipo de permissão:
    os scripts precisam de permissão de execução e as páginas de leitura

    Porém nos cgis não podem ter permissão de leitura

    Pra tentar quebar isso mude na mão a permissão de cada arquivo de litura html forçando a leitura

    ))



  3. #3
    dboom
    Visitante

    Padrão permissões de CGI

    fiz isso, mas nao adiantou, tipo tinha que dar um chmod 755 em alguns arquivos e um chmod 777 na pasta onde ficaria os arquivos. O problema eh que o cara que fez o script disse que tinha que ficar tudo na mesma pasta, e meu servidor tem uma pasta para as paginas e uma para os scripts.

  4. #4
    Mr_Mind
    Visitante

    Padrão permissões de CGI

    toma cuidado com as permissoes q das!!
    isso das directorias podes mudar no ficheiro d configuraçao do teu webserver! se apache .. /etc/apache/httpd.conf, ou /etc/httpd/conf/httpd.conf
    <IMG SRC="images/forum/icons/icon_biggrin.gif">



  5. #5
    dboom
    Visitante

    Padrão permissões de CGI

    Mr_Mind me falaram que se o meu servidor estiver configurado com dois diretorios diferentes para gci e para html, os scripts que tenho nao vai funcionar.... alguem tem alguma ideia ou sabe de algum sistema de cartao virtual que funcione sem ser cgi??? ou como fazer para tentar "unir" esses dois diretorios???
    testei em outros dominios e funciona e so no meu nao funciona..................
    <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif">
    o que fazer?? queria testar os cartoes agora para o natal, mas no meu server nao da.

  6. #6
    Visitante

    Padrão permissões de CGI

    To com o mesmo problema no RH 8 nenhum script .cgi ou .pl funciona já mudei permissão já fiz o diabo já li hots e helps mas nao resovel nada tem alguem ai que sabe onde mexer nesta bosta e deixar todos os scrips funcionado, segurança nos vê depois nos logs., e não é so eu e o colega com este problema, a redhat tem alguma bronca com script, pode fazer do zero nao roda perl nem a pau em www . o segredo eu não sei mas se alguem suber espero que nao seja gates e diga aqui onde ta a bronca.

    cleber damasio
    [email protected]



  7. #7

    Padrão permissões de CGI

    vc carregou os modulos cgi???

    LoadModule cgi_module modules/mod_cgi.so
    AddModule mod_cgi.c

    <Directory "/cgi-bin/">
    AddHandler cgi-script cgi
    AllowOverride None
    Options +ExecCGI
    Order allow,deny
    Allow from all
    </Directory>

  8. #8
    Visitante

    Padrão permissões de CGI

    ow 1c3-m4n tbm tenho esse problema e uso o RH 7.3, isso eu executo junto com o script???



  9. #9
    paulogrifo
    Visitante

    Padrão permissões de CGI

    ((
    Isso vc habilita no httpd.conf para habilitar o uso de scripts pelo apache
    e ainda tem a diretiva:
    ScriptAlias /cgi-bin/ /home/seu/dir/de/scripts
    Em complemento vc pode especificar direto para um diretório
    <Directory /home/seu/dir/de/scripts>
    Options ExecCGI
    </Directory>
    E verifique tb:

    AddHandler cgi-scripts .cgi .pl

    Para autorizar estas extensões a executar scripts...

    ...
    ))