+ Responder ao Tópico



  1. #1
    Futuremax
    Visitante

    Padrão Script de configuração......

    Montei um script para configurar uma firewall, mas ele só configura se for ip fixo, a linha que dá problema é a seguinte:

    iptables -A POSTROUTING -t nat -s 192.168.2.0/16 -j SNAT --to 200.200.200.200

    Só funciona se for ip, portanto se o ip for randomico não tem como colocar no lugar do ip 200.200.200.200 <=> eth0 por exemplo, existe um meio de fazer isso???? Alias, se alguém quizer dar um olhada no script e me ajudar, me manda um e-mail <A HREF="mailto:[email protected]">[email protected]</A>
    Falow??
    <IMG SRC="images/forum/icons/icon_wink.gif">

  2. #2

    Padrão Script de configuração......

    ao inves de -s 200.xxx.xxx vc pode colocar -i eth0
    -i input interface
    -o output interface <IMG SRC="images/forum/icons/icon_wink.gif">

    a respeito do seu script num to com tempo pra ficar olhando mto bem mas tem uma coisa q pode te ajudar... tipo vc fez em bash certo? se foi ai vai

    IP=200.xxx.xxx.xxx..xxxx

    ai nas suas regras vc coloca $IP ao inves de digitar o ip, com isso vc soh troca o ip uma vez no codigo inteiro e pode utilizar o script facilmente em qq máquina!!!!

    [ Esta mensagem foi editada por: 1c3_m4n em 27-11-2002 16:01 ]



  3. #3
    Futuremax
    Visitante

    Padrão Script de configuração......

    O problema não está no -s e sim no --to <IMG SRC="images/forum/icons/icon_eek.gif">

    [ Esta mensagem foi editada por: Futuremax em 27-11-2002 16:07 ]

  4. #4
    DIVORAK
    Visitante

    Padrão Script de configuração......

    VEJA ESTE SCRIPT VC VAI GOSTAR

    http://www.jg555.com/firewall/firewa...ha-1.32.tar.gz

    ELE FAZ TUDO SÓZINHO




  5. #5
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.925
    Posts de Blog
    1

    Padrão Script de configuração......

    pege este escript abaixo ele é otimo
    http://www.jg555.com/firewall/firewall-Alpha-1.32.rpm

  6. #6

    Padrão Script de configuração......

    depois do -A POSTROUTING coloque -p tcp

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2002-11-27 16:02, Futuremax wrote:
    O problema não está no -s e sim no --to <IMG SRC="images/forum/icons/icon_eek.gif">

    [ Esta mensagem foi editada por: Futuremax em 27-11-2002 16:07 ]
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>