+ Responder ao Tópico



  1. #11
    Ola Perdigao !!

    Explica para nos se voce compilou o apache ou instalou atraves dos
    RPMs?
    Para que o PHP funcione e´ necessario que os modulos estejam presentes.
    Quando vc inicia o apache, aparece alguma mensagem de erro ?

    tenta isso:

    no diretorio htdocs crie o arquivo teste.php

    <?php
    phpinfo()
    ?>

    digite no navegador localhost/teste.php

    O que acontece ??

    hasta....Junior

  2. #12
    Futuremax
    Pelo que entendi no seu conf.d falta ainda umas linhas para que o php rode normalmente:

    php_flag engine on

    AddType application/x-httpd-php .php

    E conta pra gente, ele starta o httpd??? Ou tenta fazer download do arquivo.php??? Detalhe mais o erro, não sabemos de onde começar....



  3. Bom o nome deste arquivo depende das distro isto sei pois eu tenho um slackware 81 e um RH7.3 com apache e php
    no RH nao tem o mod_php.conf estas configuracoes ja estao adicionadas diretamente no http.conf
    ja no slackeware existe um include para este arquivo pois é que ficam as configuracoes do php referente ao apache
    nos dois existem o php.ini
    Este é o grande problemas das distros nao esite um padrao para os mesmos softwares

    Isto foi so para tirar as dúvidas <IMG SRC="images/forum/icons/icon_wink.gif">

  4. #14
    Perdigao
    Meus amigos, acho que estamos em desacordo, no RH 8.0 não usa mais as linhas no httpd.conf

    ele tem uma pasta a mais que é a conf.d em /etc/httpd/conf.d e dentro desta pasta estão os arquivos .conf para inicialização dos modulos, seja PHP, MYSQL dentre outros...

    é diferente, e posso dizer que não esta levantando... o principio deve ser o mesmo, entretanto não esta carregando...

    No arquivo httpd.conf tem uma linha que é a seguinte:

    #
    Include conf.d/*.conf
    #

    assim ele vai carregar todos os modulos que nesta versão estão em .conf como exemplo, o php.conf , o ssl.conf, o auth_mysql.conf e assim por diante...

    entendem???

    Tenho de fazer levantar o php... ou continuar tentando, se alguem já tiver passado por isso, ou se por acaso souberem como resolver este problema, me avisem...

    Se por ventura quizerem entrar na minha maquina (teste) para verificar a diferença é só entrar em contato comigo por SIM-ICQ 15889316

    Abraços,

    Perdigao

    <IMG SRC="images/forum/icons/icon_razz.gif">



  5. #15
    Perdigao
    Existe o arquivo php.ini também, entretanto para levantar os modulos do php, ao invels de vc colocar o AddType etc etc no httpd.conf vc colocar no php.conf só pra ficar mais organizado eu acho...

    Quanto ao shortopentag = on já habilitei ele no php.ini, mas não mudou em nada...

    <IMG SRC="images/forum/icons/icon_biggrin.gif">

    Abraços

    Perdigao






Tópicos Similares

  1. Squirrel mail urgente!
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 23-08-2002, 13:23
  2. Me ajudem!! URGENTE!!!! Filtros de Impressão!!!!
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-08-2002, 16:41
  3. URGENTE!!! vnc através firewall
    Por doug no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-08-2002, 09:28
  4. Netsaint URGENTE
    Por SergioBZ no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-08-2002, 13:54
  5. Bloquear sites no squid - urgente
    Por bauer no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-05-2002, 22:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L