Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #6
    Futuremax
    O seu php foi compilado ou instalado via rpm??? Devem ser os módulos do MySql que não estão carregando....

    Ok??

  2. #7
    Perdigao
    Futuremax,

    Foi compilado... e o estranho é que recompilei ele novamente e nada mudou... continua do mesmo jeito... alterei o php.ini e nada... refiz a compilação do mysql, do php e até do apache, mas não resolve, é como se simplismente ele não quizesse ou nao conseguisse mais fazer com que o mysql interaja com o php. e o mysqld esta levantado, e tudo certinho, os bancos de dados criados e tudo mais...

    Tem alguma idéia??? se quizer e puder, entre em contato comigo no ICQ que habilito um usuario pra vc entrar via ssh e olhar o que tem lá... e me dize se é algo que estou esquecendo ou o que... <IMG SRC="images/forum/icons/icon_frown.gif">

    No Aguardo,

    Perdigao

    SIM-ICQ: 15889316



  3. #8
    Futuremax
    Infelismente não tenho ICQ, mas vamos tentar resolver por aki, acho que encontrei seu erro, olhe na linha cuja qual está o comando que foi compilado o php, há um pedaço dela que está assim &acute;without-mysql&acute; , não sei se esse parametro foi proposital, mas tire ele, ou digite with-mysql e acredito que seu problema está resolvido....

  4. #9
    Perdigao
    Futuremax,

    Esta parte é exatamente o que esta me preocupando, entretanto já recompilei o php, apache e mysql mas não tive sucesso coloquei o parametro --with-mysql=../diretoriomysql mas não resolveu <IMG SRC="images/forum/icons/icon_frown.gif">

    Como faço para alterar o without-mysql ???

    somente via compilação?? sendo que o mysql já esta instalado e tudo mais... ...??

    No aguardo,

    Perdigao <IMG SRC="images/forum/icons/icon27.gif">



  5. #10
    Olá perdigão!!

    Entre na pasta do Apache e compile ele (instruçoes abaixo)

    Entre na pasta do fonte do mysql e digite

    rm config.cache

    make clean

    ./configure --prefix=/usr/local/mysql
    make
    make install

    na pasta do php

    ./configure --with-mysql=/usr/local/mysql --with-apxs2=/usr/local/apache2/bin/apxs
    make
    make install

    (Para a versão do Apache 2.0.x)

    entre na pasta do apache

    ./configure --prefix=/usr/local/apache2 --enable-module=so
    make
    make install

    -----------------------------------
    Um bom conselho....Compila primeiro o apache e depois recompila
    após o mysql e php. Já tive problema de compilar o apache e faltar
    alguma biblioteca, por isso vc deve compilar 2 vezes.


    Se não funcionar, grita por nós.....

    Hasta....Junior


    Se não resolver,






Tópicos Similares

  1. Squirrel mail urgente!
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 23-08-2002, 13:23
  2. Me ajudem!! URGENTE!!!! Filtros de Impressão!!!!
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-08-2002, 16:41
  3. URGENTE!!! vnc através firewall
    Por doug no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-08-2002, 09:28
  4. Netsaint URGENTE
    Por SergioBZ no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-08-2002, 13:54
  5. Bloquear sites no squid - urgente
    Por bauer no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-05-2002, 22:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L