+ Responder ao Tópico



  1. #1

    Padrão PHP naum funfa!

    o PHP naum tá funfando....
    acabei de compilar ele....

    quando clico em algum link .php ele abre a página mostrando
    o código php do arquivo ...... quer dizer que ele naum tá rodando....


    q q eu faço???

  2. #2

    Padrão PHP naum funfa!

    como está o php.ini ????
    e q comando vc usou pra compilar ele??



  3. #3

    Padrão PHP naum funfa!

    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql --enable-sysvsem --enable-sysvshm --enable-sockets --with-interbase=/opt/interbase --enable-track-vars --enable-trans-sid --disable-debug

  4. #4
    Visitante

    Padrão PHP naum funfa!

    Olá PITsA !!

    Se vc estiver usando o RH 8.0, copie o arquivo httpd.conf na pasta /etc/httpd/conf e na pasta /etc/httpd/conf.d

    hasta...Junior



  5. #5

    Padrão PHP naum funfa!

    engine = On

    short_open_tag = On

    asp_tags = Off

    precision = 12

    y2k_compliance = On

    output_buffering = Off

    zlib.output_compression = Off

    implicit_flush = Off

    unserialize_callback_func=

    allow_call_time_pass_reference = On

    safe_mode = Off

    safe_mode_gid = Off

    safe_mode_include_dir =

    safe_mode_exec_dir =

    safe_mode_allowed_env_vars = PHP_

    safe_mode_protected_env_vars = LD_LIBRARY_PATH

    disable_functions =

    expose_php = On

    register_globals = On

  6. #6

    Padrão PHP naum funfa!

    estou usando o slackware.....

    tipo... eu compilei mas ele instalo por cima....
    pois já havia compilado ele antes.....



  7. #7
    neurobashing
    Visitante

    Padrão PHP naum funfa!

    1o - Compila o apache com suporte a DSO (--enable-module=so)

    2o - Compila o PHP com as opções q vc precisa (--disable-debug --enable-pic --enable-inline-optimization --with-apxs=/usr/local/apache/bin/apxs --enable-shared --disable-static --with-regex=system --with-gettext --with-db2 --enable-debugger --enable-magic-quotes --enable-safe-mode --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-yp --enable-snmp --enable-dbf --enable-ftp --enable-bcmath --with-mysql --with-xml --with-zlib --with-zip=/usr/local/include/ --with-sybase=/opt/sybase-11.9.2 --enable-track-vars)

    3o - No httpd.conf insira as seguintes linhas:

    LoadModule php4_module libexec/libphp4.so

    <IfModule mod_dir.c>
    DirectoryIndex index.php index.php3 index.html index.htm
    </IfModule>

    AddType application/x-httpd-php .php .php3


    Pra mim funcionou !

  8. #8
    Visitante

    Padrão PHP naum funfa!

    vlw mas ja fiz ele funfa!

    naum estava funcionando com a opção no php

    --with-apxs/usr/local/apache/bin/apxs

    daí usei o fonte do apache..

    --with-apache=../apacheXXX

    e depois compilei o apache e fico beleza!!