+ Responder ao Tópico



  1. #1

    Padrão Netlogon

    Bom dia!

    Porque script de netlogon não é carregado com o login (mesmo configurado e suas respctivas pastas e arquivos existem e estão com permissão 777, vide
    smb.conf) os scripts estão sendo carregados manualmente.

    [global]
    workgroup = MEDITEC
    server string = Meditec Server %v
    hosts allow = 192.168.0. 127.
    printcap name = /etc/printcap
    load printers = yes
    printing = lprng
    ;guest account = root
    log file = /var/log/samba/log-%U.%m
    max log size = 5000
    debug level = 3
    security = user
    ;password server = <NT-Server-Name>
    password level = 8
    username level = 8
    encrypt passwords = no
    smb passwd file = /etc/smbpasswd
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n
    *passwd:*all*authentication*tokens*updated*successfully*
    username map = /etc/smbusers
    ;include = /etc/smb.conf.%m
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    ;interfaces = 192.168.12.2/24 192.168.13.2/24
    ;remote browse sync = 192.168.3.25 192.168.5.255
    ;remote announce = 192.168.1.255 192.168.2.44
    local master = yes
    os level = 99
    domain master = yes
    preferred master = yes
    ;domain controller = <NT-Domain-Controller-SMBName>
    domain logons = yes
    logon script = %U.bat
    logon path =
    logon home = \\%L\homes
    name resolve order = wins lmhosts bcast
    wins support = yes
    ;wins server = w.x.y.z
    ;wins proxy = yes
    dns proxy = no
    ;unix password sync = yes
    netbios name = SERVER
    keepalive = 20
    ;preserve case = no
    ;short preserve case = no
    ;default case = lower
    ;case sensitive = no
    ;admin users = root, osni
    ;valid users = osni, teste, andrea, administrador, root
    logon drive = T:
    ;remote browse sync = 192.168.0.255
    ;remote announce = 192.168.0.255
    create mask = 0777
    ;time server = yes
    ;domain admin group = root
    oplock = false
    #============================ Share Definitions
    ==============================
    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes
    available = yes
    public = yes

    [netlogon]
    comment = Network Logon Service
    path = /home/netlogon
    guest ok = yes
    writable = yes
    browseable = no

    [meditec]
    comment = meditec
    path = /files/med
    public = yes
    writable = yes
    browseable = no

    [tox]
    comment = tox
    path = /files/tox
    copy = meditec

    [rs]
    comment = rs
    path = /files/rs
    public = yes
    writable = yes
    browseable = no

    [lukra]
    comment = lukra
    path = /files/lukra
    public = yes
    writable = yes
    browseable = no


    [publico]
    comment = publico
    path = /files/pub
    public = yes
    writable = yes
    browseable = no

    [catalog]
    comment = catalogos
    path = /files/cat
    public = yes
    writable = yes
    browseable = no

  2. #2

    Padrão Netlogon

    Onde vc criou os arquivo de lote do logon?

    Vc utilizou o EnablePlainTextPassword?


    Marcos Amorim




  3. #3
    Cyberfred
    Visitante

    Padrão Netlogon

    um problema comum acontece quando vc edita o arquivo de logon no vi ou semelhantes q o final da linha dele não eh reconhecido pelo DOS...
    faça o seguinte....
    # todos < SCRIPT_DE_LOGON > SCRIPT_DE_LOGON.dos

    este comando converte arquivos em formato UNIX para DOS...

    Outro detalhe...
    vc estah usando a flag logon script = %U.bat , assim sendo vc tem que ter um script.bat para cada usuario.

    Falows.

  4. #4

    Padrão Netlogon

    Sim eu desabilitei a criptografia nas estações e usei o notepad para criar e editar os arquivos de netlogon..
    o caso é que nem chega a carregar (pois eles foram testados manualmente e funcionam)

    Valeu...



  5. #5

    Padrão Netlogon

    Ainda não consegui fazer funcionar... Alguem tem alguma ideia?

  6. #6
    Visitante

    Padrão Netlogon

    Tente agrupar todas tags relacionadas a um tipo de finalidade

    domain logons = yes
    logon home = /home/%U
    logon script = \\LINUX_03\%U.bat
    logon path = \\N\profiles\%U

    aki funcionou assim, mas o netlogon não fecha hehe !!



  7. #7
    Blackcatdbflush
    Visitante

    Padrão Netlogon

    Acho que encontrei a solução !!

    o correto no compartilhamento é esse !!

    [netlogon]
    comment = Script logon
    path = diretório onde se encontra as batzinhas do login
    public = no
    browseable = yes
    writeable = no

    esse é o padrão para o net logon funfar ok !! <IMG SRC="images/forum/icons/icon_biggrin.gif">

  8. #8
    mirror
    Visitante

    Padrão Netlogon

    Repare q a propriedade &acute;logon path&acute; esta vazia, ao invez disso tente colocar o path dos seus bats. Como por exemple: logon path = \home\netlogon


    tenta ai!!!



    Lucas



  9. #9

    Padrão Netlogon

    Olha... pelo que eu sei, netlogon so vai funcionar se voce logar no servidor, e para que voce se logue no servidor(desta maneira) voce prescisa que o samba seja o PDC da rede, e com security = user nao vai funcionar <IMG SRC="images/forum/icons/icon_smile.gif">
    security = domain ou server que eh nivel d PDC, se eu nao me engano eh domain <IMG SRC="images/forum/icons/icon_smile.gif">

    tente isso, e faca suas estacoes win* logarem no dominio. eh isso <IMG SRC="images/forum/icons/icon_smile.gif">