+ Responder ao Tópico



  1. #1
    jackjamil
    Visitante

    Padrão freeswan trava as conexoes de rede local

    ola amigos,

    quando inicio a conexao do ipsec tudo conecta e funciona uma máquina pinga a outra e tudo, mas a rede local perde o acesso a internet ao servidor. Isto é um erro de configuração meu ou tem algo de errado?

    []´s


  2. #2
    devlinmaxx
    Visitante

    Padrão freeswan trava as conexoes de rede local

    Bro, nao entendi.. Tem como explicar melhor? <IMG SRC="images/forum/icons/icon_razz.gif">
    Se nao estiver afim de ficar explicando, poe seu ipsec.conf aqui pra gente dar uma olhada, Ok???



  3. #3
    jackjamil
    Visitante

    Padrão freeswan trava as conexoes de rede local

    Olá, obrigado por responder.

    Não tenho um problema de configuração, eu consigo conectar a duas redes e pingar de uma estação na outra. o problema é que esta maquina (que levanta o tunel) para de responder para as requisições locais, ou seja, o compartilhamento de arquivos e a conexão com a internet param de funcionar. fiz um teste, coloquei o tunel em outra maquina, que não compartilha arquivos apenas a conexão com a internet e quando levanto o tunel, a rede para de navegar na net, o ipsec funciona, mas a internet para de ser acessada.

  4. #4
    jackjamil
    Visitante

    Padrão freeswan trava as conexoes de rede local

    eu tenho que adicionar alguma rota especifica?



  5. #5

    Padrão freeswan trava as conexoes de rede local

    tente isso na sua regra de mascaramento:

    iptables -A POSTROUTING -t nat -s 192.168.10.0/24 -d ! 192.168.0.0/24 -j MASQUERADE

    onde 192.168.10.0/24 é a sua rede de origem e 192.168.0.0/24 sua rede de destino na VPN

    Marcos Amorim

  6. #6
    jackjamil
    Visitante

    Padrão freeswan trava as conexoes de rede local

    Aqui vai meu ipsec.conf:

    # basic configuration
    config setup
    # THIS SETTING MUST BE CORRECT or almost nothing will work;
    # %defaultroute is okay for most simple cases.
    interfaces=%defaultroute
    # Debug-logging controls: "none" for (almost) none, "all" for lots.
    klipsdebug=none
    plutodebug=none
    # Use auto= parameters in conn descriptions to control startup actions.
    plutoload=%search
    plutostart=%search
    # Close down old connection when new one using same ID shows up.
    uniqueids=yes

    # defaults for subsequent connection descriptions
    # (these defaults will soon go away)
    conn %default
    keyingtries=0
    disablearrivalcheck=no
    esp=3des-md5-96
    authby=rsasig

    conn sp_bauru
    # Left security gateway, subnet behind it, next hop toward right.
    left=200.xxx.xxx.xxx
    leftsubnet=10.0.0.0/8
    leftnexthop=200.171.229.1
    # Right security gateway, subnet behind it, next hop toward left.
    right=200.xxx.xxx.xxx
    rightsubnet=10.0.1.0/8
    rightnexthop=200.206.161.1
    # To authorize this connection, but not actually start it, at startup,
    # uncomment this.
    auto=add
    authby=rsasig
    leftrsasigkey=0sAQODVoRumGvP4fkGrKdS...
    rightrsasigkey=0sAQOCs6UBt1iAsB5Bz...




  7. #7
    devlinmaxx
    Visitante

    Padrão freeswan trava as conexoes de rede local

    Tenta o que o Amorim disse, bro. Se nao der, nao estou vendo nada de errado com seu ipsec.conf.
    Por favor, veja o sei /var/log/messages e /var/log/secure quando voce inicia a conexao e quando a conexao restante para, e mande-o pra ca.. Pode ser? Se algo estiver errado, vai estar registrado ai...

  8. #8
    jackjamil
    Visitante

    Padrão freeswan trava as conexoes de rede local

    Olá, obrigado pela ajuda, coloquei o que o Amorim sugeriu e funcionou.

    Muito Obrigado