+ Responder ao Tópico



  1. #1

    Padrão Squid

    Pessoal, o squid está dando o seguinte erro no log, qdo tento startar o serviço.
    Parece ser um erro de pemissão. Mas onde?
    O meu squid.conf está padrão da instalação, pois só irei fazer as alterações depois q conseguir colocar o squid rodando, o q ainda não aconteceu.
    A unica coisa q modifiquei no squid.conf foi:
    cache_effective_user proxy
    cache_effective_group proxy
    Já dei as permissões no /var/cache/squid p/ user e group (proxy 755). Tenho q dar esta permissão em mais algum lugar?


    2003/09/02 13:59:44| Using Least Load store dir selection
    2003/09/02 13:59:44| Set Current Directory to /var/cache/squid
    2003/09/02 13:59:44| Loaded Icons.
    2003/09/02 13:59:45| Accepting HTTP connections at 0.0.0.0, port 3128, FD 10.
    2003/09/02 13:59:45| Accepting ICP messages at 0.0.0.0, port 3130, FD 11.
    2003/09/02 13:59:45| Accepting HTCP messages on port 4827, FD 12.
    2003/09/02 13:59:45| Accepting SNMP messages on port 3401, FD 13.
    2003/09/02 13:59:45| WCCP Disabled.
    2003/09/02 13:59:45| sendto FD 14: (1) Operation not permitted
    2003/09/02 13:59:45| ipcCreate: CHILD: hello write test failed

    Alguém pode me dar a dica de como resolver isso?
    Valeu galera...

  2. #2
    devlinmaxx
    Visitante

    Padrão Squid

    Voce criou o dir do squid la no var, correto? Deu permissao 777 nele para isolar o problema? Criou a area de swap dele? # squid -z e talz???



  3. #3

    Padrão Squid


    Já criei o Swap no /var/cache/squid/ com o comando #squid -z e todos os diretórios estão como proxy e permissão 777. Só não entendi q dir é esse no var, não seria o swap?

  4. #4
    devlinmaxx
    Visitante

    Padrão Squid

    Isso mesmo, o /var/spool/squid... Se a instalaçao nao criar, voce tem que cria-lo na mao. Ele esta criado, ne? Seu squid.conf esta corretamente configurado com as portas, volume de cache, etc?
    E porque voce colocou esses 2 parametros, desculpe a ignorancia?



  5. #5

    Padrão Squid

    Pessoal ninguem tem idéia do q esta acontecendo.
    Já dei permissão 777 p/ o meu swap, o usuário e o grupo é o mesmos q está no squid.conf. Permissão 777 p/ o cache.log
    Já foi criado o swap com #squid -z.
    E qdo vou no log olhar pq não está funcionando, ele esta dando um erro de permissão.

    2003/09/02 13:59:44| Using Least Load store dir selection
    2003/09/02 13:59:44| Set Current Directory to /var/cache/squid
    2003/09/02 13:59:44| Loaded Icons.
    2003/09/02 13:59:45| Accepting HTTP connections at 0.0.0.0, port 3128, FD 10.
    2003/09/02 13:59:45| Accepting ICP messages at 0.0.0.0, port 3130, FD 11.
    2003/09/02 13:59:45| Accepting HTCP messages on port 4827, FD 12.
    2003/09/02 13:59:45| Accepting SNMP messages on port 3401, FD 13.
    2003/09/02 13:59:45| WCCP Disabled.
    2003/09/02 13:59:45| sendto FD 14: (1) Operation not permitted
    2003/09/02 13:59:45| ipcCreate: CHILD: hello write test failed

    [ Esta mensagem foi editada por: doliveira em 04-09-2003 21:11 ]

    [ Esta mensagem foi editada por: doliveira em 04-09-2003 21:25 ]

  6. #6

    Padrão Squid

    Onde mais tenho q modificar alguma permissão ou usúario?
    Valeu...



  7. #7
    Visitante

    Padrão Squid

    Altere as seguintes linhas:
    #################################

    hierarchy_stoplist cgi-bin ?
    cache_mem 16 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 1000 16 256
    cache_access_log /var/log/squid/access.log
    ftp_user [email protected]
    # ACLS
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow all
    icp_access allow all
    visible_hostname on
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on


    #IPTABLES
    #Estas linhas deverão ser acrescentadas em algum arquivo ex.: /etc/rc.local
    #. /etc/rc.d/init.d/functions
    #. /etc/sysconfig/network

    # echo 1 > /proc/sys/net/ipv4/ip_forward
    # /sbin/modprobe iptable_nat
    # iptables -F
    # iptables -t nat -F
    # iptables -t nat -A PREROUTING -s 0/0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    # iptables -t nat -A PREROUTING -s 0/0 -p udp --dport 80 -j REDIRECT --to-port 3128
    # iptables -t nat -A POSTROUTING -s 0/0 -o eth1 -j MASQUERADE

  8. #8

    Padrão Squid

    Valeu pela dica, mais isso não deu muito certo. Continuo na mesma. Alem do que estas modificações é p/ transformar em um proxy transparente, certo? E o problema q está acontecendo comigo é de permissão.





  9. #9

    Padrão Squid

    Pessoal, O problema q estou tendo, acho q é pq não foi criado o squid.pid.
    Criei ele na mão mesmo mas continua dando erro, alguém sabe o q tende ser feito?
    Valeu....