+ Responder ao Tópico



  1. #1
    kappalinux
    Visitante

    Padrão PHP + Apache

    tenho slackware 9.0, e instalei o php e o apache durante a instalacao. Nao instalei o mysql.
    tentei rodar um php no apache mas nao estah funcionando. quando eu tento abrir um link q contem o php a tela do browser fika branca, alguem pode me ajudar?
    PS: O php, apache estao com a configuracao padrao unica coisa q mudei foi o httpd.conf o DocumentRoot

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão PHP + Apache

    Você deve incluir ainda em httpd.conf:

    LoadModule php4_module libexec/libphp4.so

    AddModule mod_php4.c

    Ponha index.php tambem em <IfModule mod_dir.c>
    e:

    Include /etc/apache/mod_php.conf (presumindo que esteja ai seu conf)



  3. #3
    kappalinux
    Visitante

    Padrão PHP + Apache

    valeu psy
    vou tentar editar os conf&acute;s
    valeu cara pelas dias..
    falooow
    []&acute;s

  4. #4
    kappalinux
    Visitante

    Padrão PHP + Apache

    psy, ao descomentar essa linha no httpd.conf:
    Include /etc/apache/mod_php.conf

    e levantar o apache(httpd) eu tive recebi a seguinte msg:
    [Thu Sep 25 17:47:28 2003] [warn] module php4_module is already loaded, skipping[Thu Sep 25 17:47:28 2003] [warn] module mod_php4.c is already added, skipping

    é normal isso? ele simplesmente ja leu o php4_module e o mod_php4.c ao adicionar no httpd.conf
    []&acute;s
    faloow



  5. #5
    kappalinux
    Visitante

    Padrão PHP + Apache

    psy o php funcionou legalzinho
    valeu cara...valeu mesmo!!! <IMG SRC="images/forum/icons/icon_wink.gif">)))
    []&acute;s

  6. #6
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão PHP + Apache

    Opa, tranquilo entao amigo, disponha =)
    Quanto ao erro, eh que no mod_php.conf ja tem as linhas, mas ele nao interfere em nada, pode deixar assim mesmo heheh



  7. #7
    brmisan
    Visitante

    Padrão PHP + Apache

    Caros companheiros...cansei!
    tentei atualizar (compilando) para o:
    apache-1.3.28
    mod_ssl-2.8.15_1.3.28
    mysql-4.0.15a
    openssl-0.9.7c
    php-4.3.3

    entao devido a praticidade, baixei o binarios do slackware e instalei os pacotes, o problema e q qdo vou utilizar o php, ele enxerga apenas o fonte do index.php
    detalhe: o apache foi compilado (binario) com suporte a php so que num func.
    Qualquer ajuda, valeu demais!
    eu ia

  8. #8
    brmisan
    Visitante

    Padrão PHP + Apache

    Como ninguem se habilitou a me ajudar... fiz um upgradepkg para as versões originais do slackware 9.0 e tudo funcionou!