+ Responder ao Tópico



  1. #1

    Padrão Proxy Squid com problemas

    Caros colegas!

    Tenho um servidor CL8 rodando firewall/proxy e hoje de manha simplesmente o serviço de proxy parou de funcionar; já verifiquei que o link está funcionado; nenhuma alteração foi feita nas configurações do servidor;verifiquei o seguinte:

    1)O cache está ok; ainda tem bastante espaço para armazenamento;
    2)A partição de /var/log/squid também tem bastante espaço para armazenar os meus access.log;
    3)Quando dou o comando:
    #service squid status (ele me retorna a seguinte mensagem)
    squid inativo mas seus subdiretorios trancados

    4)verifiquei o conteúdo do arquivo /var/log/messages e achei as seguintes mensagens lá sobre o squid:

    Oct 31 13:45:29 colpmc70 rc: Iniciando webmin: succeeded
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process 1163 started
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process 1163 exited due to signal 25
    Oct 31 13:45:34 colpmc70 squid[1053]: Squid Parent: child process 1171 started
    Oct 31 13:45:35 colpmc70 squid[1053]: Squid Parent: child process 1171 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process 1179 started
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process 1179 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Exiting due to repeated, frequent failures


    Alguém pode já viu este erro?
    Por favor alguém tem uma dica do que eu posso fazer para achar o erro?

    Obrigado turma!

    Abraços.

  2. #2
    beastie
    Visitante

    Padrão Proxy Squid com problemas



    você tem certeza de que o user admin do squid (squid ou proxy no conectiva) tem os respectivos direitos nos diretórios que ele precisa? como o /var/log/squid e o /var/cache/squid ???



  3. #3

    Padrão Proxy Squid com problemas

    Sim!

    tenho certeza!

    vou continuar a fuçar aqui e se eu conseguir a solução posta aqui no forúm!

    Obrigado.

  4. #4

    Padrão Proxy Squid com problemas

    SOLUÇÃO PARA O PROBLEMA ABAIXO:
    ---------------->
    Caros colegas!

    Tenho um servidor CL8 rodando firewall/proxy e hoje de manha
    simplesmente o serviço de proxy parou de funcionar; já verifiquei que
    o link está funcionado; nenhuma alteração foi feita nas configurações
    do servidor;verifiquei o seguinte:

    1)O cache está ok; ainda tem bastante espaço para armazenamento;
    2)A partição de /var/log/squid também tem bastante espaço para
    armazenar os meus access.log;
    3)Quando dou o comando:
    #service squid status (ele me retorna a seguinte mensagem)
    squid inativo mas seus subdiretorios trancados

    4)verifiquei o conteúdo do arquivo /var/log/messages e achei as
    seguintes mensagens lá sobre o squid:

    Oct 31 13:45:29 colpmc70 rc: Iniciando webmin: succeeded
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process
    1163 started
    Oct 31 13:45:31 colpmc70 squid[1053]: Squid Parent: child process
    1163 exited due to signal 25
    Oct 31 13:45:34 colpmc70 squid[1053]: Squid Parent: child process
    1171 started
    Oct 31 13:45:35 colpmc70 squid[1053]: Squid Parent: child process
    1171 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process
    1179 started
    Oct 31 13:45:38 colpmc70 squid[1053]: Squid Parent: child process
    1179 exited due to signal 25
    Oct 31 13:45:38 colpmc70 squid[1053]: Exiting due to repeated,
    frequent failures


    Alguém pode já viu este erro?
    Por favor alguém tem uma dica do que eu posso fazer para achar o erro?

    Obrigado turma!

    Abraços.
    ---------------------------------------------------------->

    Solução:

    Verifique então o seguinte:
    abri outra tty e digitei:
    #top
    verifiquei que o comando vi estava utilizando 75% de processador e tb muita memória.

    finalizei o comando vi com #kill -9 <pid>

    Daí veriquei que o arquivo estava com mais de 2.0Gb.

    Exlui o mesmo, recriei um em branco, dei as permissões corretas e iniciei o serviço de proxy, daí tudo tá funcionando.

    VALEU COLEGAS!!

    É POR ISSO QUE ESTOU NESTA COMUNIDADE "LINUX"

    <IMG SRC="images/forum/icons/icon_smile.gif">



  5. #5
    replicante
    Visitante

    Padrão Proxy Squid com problemas

    Wal,

    aqui no meu servidor eu criei um script para ele limpar esse arquivo diariamente (logo apos fazer o relatorio com o sarg).. ae vc adiciona no crontab e já era... <IMG SRC="images/forum/icons/icon_smile.gif">

    falow,

  6. #6

    Padrão Proxy Squid com problemas

    Caro colega!

    posta aqui pra gente esse script!

    obrigado.



  7. #7
    replicante
    Visitante

    Padrão Proxy Squid com problemas

    é esse, ficou bem simples mas quebra um galhão! hehehe

    ae vc adiciona uma chamada diaria pra ele no crontab.

    #!/bin/bash
    ## Gera variavel do dia
    dia=`date +%Y"-"%b"-"%d`

    ## Cria a pasta do dia e copia os arquivos
    mkdir /usr/local/squid/var/logs/backup/"$dia"

    cp /usr/local/squid/var/logs/access.log /usr/local/squid/var/logs/backup/"$dia"/access.log

    cp /usr/local/squid/var/logs/cache.log /usr/local/squid/var/logs/backup/"$dia"/cache.log

    cp /usr/local/squid/var/logs/store.log /usr/local/squid/var/logs/backup/"$dia"/store.log

    ## Inicia o Sarg
    sarg

    ## Apaga os arquivos antigos
    >/usr/local/squid/var/logs/access.log
    >/usr/local/squid/var/logs/cache.log
    >/usr/local/squid/var/logs/store.log

    eu montei um tutorial bem loko de squid e talz mandei hj pra underlinux acho que ate segunda eles devem colocar ae vc dá uma olhada... tem todas essas coisinhas nele.. <IMG SRC="images/forum/icons/icon_smile.gif">

    falow,

  8. #8

    Padrão Proxy Squid com problemas

    ok!

    obrigado...vou implementar este recurso aqui no meu server.

    Depois vou verificar o seu tutorial no site aqui, pois utilizo muito os recursos do proxy squid.
    Aproveitando vc tem algum tutorial ou pode me indicar um local onde eu posso pesquisar sobre como implementar autenticação no proxy squid puxando os users do meu samba (bind)

    Obrigado pelas dicas.
    Abraços
    <IMG SRC="images/forum/icons/icon_smile.gif">



  9. #9

    Padrão Proxy Squid com problemas

    Replicante!
    Estava analisando o seu script e verifiquei o seguinte....após vc deletar os arquivos abaixo, não é necessário criá-los (#touch access.log - cria-los em branco mesmo)novamente?

    >/usr/local/squid/var/logs/access.log
    >/usr/local/squid/var/logs/cache.log
    >/usr/local/squid/var/logs/store.log

    Obrigado pelas dicas.

  10. #10
    replicante
    Visitante

    Padrão Proxy Squid com problemas

    naum, pq esse comando naverdade naum deleta o arquivo mas sim zera o conteudo dele...

    é como se vc desse o comando:

    echo "teste" > teste

    ele vai colocar a palavra "teste" no arquivo teste

    colocando apenas:

    >teste

    ele copia "nada" p/ dentro do arquivo, ou seja, apaga seu conteudo... <IMG SRC="images/forum/icons/icon_smile.gif">

    é isso,



  11. #11
    4ndr3
    Visitante

    Padrão Proxy Squid com problemas

    Alguém ai já pesquisou o logrotate ?

    Basta colocar no squid.conf :

    logfile_rotate 4

    e executar :

    /usr/sbin/logrotate /etc/logrotate.conf

    Verifique o logrotate.conf se quiser aprender mais ...

    PS : verifique se no /etc/cron.daily ja existe um shell "logrotate" se não houver é só criar.

    <IMG SRC="images/forum/icons/icon_wink.gif">


  12. #12

    Padrão Proxy Squid com problemas

    ok!

    entendido!!!

    obrigado.