+ Responder ao Tópico



  1. #1

    Padrão Erro ao iniciar squid

    Ola,

    Quando dou o comando service squid status surge o seguinte erro:

    squid dead but subsys locked
    2003/12/19 10:12:00| aclParseAclLine: ACL ´our_networks´ already exists with different type, skipping.
    squid: ERROR: No running copy

    Alguma dica acerca de uma solução? Alguém se deparou com este tipo de problema?

    []s
    Alan



  2. #2
    Visitante

    Padrão Erro ao iniciar squid

    Veja se para inicializar ele está buscando de algum script.
    Tente limpar os logs em /var/log/squid e depois startar o serviço direto em
    /etc/rc.d/init.d/squid start.

    ( )´s

    Beto



  3. #3

    Padrão Erro ao iniciar squid

    Ola,

    Acabei de fazer isto. Porém continua do mesmo jeito. O squid tem dois processos no segundo processo observo que o pid altera constantemente, ou seja ele tenta reiniciar e para após um monte de tentativas.

    []s
    Alan
    <IMG SRC="images/forum/icons/icon27.gif">

  4. #4

    Padrão Erro ao iniciar squid

    Alan....


    olha so ele esta falando que tem uma duplicata dessa acl! , da uma olhada no squid.conf...
    ve se tu nao colocou 2 vezes essa acl...

    se nao for isso irmao , faz aassim
    tail -F / var/log/messages , abre outro terminal e tenta levantar o squid.
    e claro veja a messagen que ele gerou no log.
    ai posta ai..
    abracos!



  5. #5
    Visitante

    Padrão Erro ao iniciar squid

    fera, seguinte, ele ta dizendo q existe um erro nesta linha de comando, ou vc criou 2 vezes o acl como diz o nosso companheiro acima ou vc crio o acl mais nao criou o http_access.
    da uma olhada

  6. #6

    Padrão Erro ao iniciar squid

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2003-12-19 13:04, MAJOR wrote:
    Alan....


    olha so ele esta falando que tem uma duplicata dessa acl! , da uma olhada no squid.conf...
    ve se tu nao colocou 2 vezes essa acl...

    se nao for isso irmao , faz aassim
    tail -F / var/log/messages , abre outro terminal e tenta levantar o squid.
    e claro veja a messagen que ele gerou no log.
    ai posta ai..
    abracos!

    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Ola,

    Retirei isto a mensagem fica assim,

    service squid status
    squid dead but pid file exists
    squid: ERROR: Could not send signal 0 to process 9312: (3) No such process

    Quando face /etc/rc.d/init.d/squid start eis os logs

    squid[10257]: Squid Parent: child process 10260 started

    Aqui vai o status:

    squid (pid 10260 10257) is running...

    E veja o que acontece:

    Squid Parent: child process 10260 exited due to signal 25
    Dec 19 14:21:18 pts squid[10257]: Squid Parent: child process 10287 started

    Até que o squid para de rodar!!

    []s
    Alan




  7. #7

    Padrão Erro ao iniciar squid

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2003-12-19 13:30, Anonymous wrote:
    fera, seguinte, ele ta dizendo q existe um erro nesta linha de comando, ou vc criou 2 vezes o acl como diz o nosso companheiro acima ou vc crio o acl mais nao criou o http_access.
    da uma olhada
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Este erro é que eu tenho uma acl para minha rede interna, our_network, e editei o tag para autenticação nesta acl,

    acl our_networks proxy_auth REQUIRED (quero que mesu usuários autentiquem) ele dá o erro porém fez. Mas tirei para tentar resolver o outro problema.

    []s
    Alan

  8. #8
    Visitante

    Padrão Erro ao iniciar squid

    Cara se eu não me engano esse "child process 10260 exited due to signal 25
    " é pq seu arquivos de log em "/var/log/squid/" estão no tamanho maximo, pare o squid e exclua eles e volte a iniciar o squid

    posta o resultao



  9. #9

    Padrão Erro no squid



    É exatamente isso; o seu arquivo de log do squid chegou no seu tamanho limite. Quando o arquivo de log chega em 2mb o squid para de funfar..isto já aconteceu comigo!

    A melhor solução é vc jogar um valor vazio no seu arquivo de log (é claro fazer um backup antes dos seus arquivos de log , se vc for precisar para relatório) e reiniciar o squid novamente...com certeza vai funfar.

    Falow.