+ Responder ao Tópico

CPU



  1. #1
    guardian_metal
    Visitante

    Padrão CPU

    Uso RH9 como servidor samba, apache, banco de dados mysql, postfix e squid. Depois de dois ou três dias ligados o processamento chega a 100% e fica por aí e o servidor ficar muito lento e só consigo resolver isto reiniciando-o. Mesmo quando se tem apenas uma máquina conectada a ele acontece o mesmo. Como resolvo isso?

  2. #2
    Pombalonga
    Visitante

    Padrão Primeiro vc tem q identificar o processo!!!

    Monitora os processos, vê o q tah consumindo progressivamente a memohria e o processamento.
    Qd vc o identificar atualiza o daemon ou faz um downgrade, enfim, pega uma versaum que naum teja bugada!!!



  3. #3

    Padrão CPU

    verifique a utilização de sua CPU com o comando TOP
    #top

    tenta tb olhar os log, se é de uma hora para outra ele deve acusar algo.

    fallow

  4. #4

    Padrão CPU

    outra opção e colocar no cron um .sh para mudar os arquivos de log do samba para outro diretório, assim ajuda na hora dos usuários acessarem...



  5. #5
    lss
    Visitante

    Padrão CPU

    qual a config. da sua maquina?
    pode ser que ela nao esteje aguentando o tranco.

  6. #6

    Padrão CPU

    Maquina guerreira.... servidor de arquivos, banco de dados , servidor de web e de email, ainda eh proxy... deve ser firewall tambem ??

    Voce por acaso nunca viu em dividir os servicos ou que 1 nao faz tudo?



  7. #7
    guardian_metal
    Visitante

    Padrão CPU

    É firewall tb.. por mim eu colocava tudo em duas máquinas mas eu não sou o dono da empresa e tenho que me virar com o que me dão. É um P4 2.0GHz com 512MB e 80 de disco.

  8. #8

    Padrão CPU

    Citação Postado originalmente por guardian_metal
    É firewall tb.. por mim eu colocava tudo em duas máquinas mas eu não sou o dono da empresa e tenho que me virar com o que me dão. É um P4 2.0GHz com 512MB e 80 de disco.
    só falta ainda dizer que você deixa rodando o X rodando, deixa?

    pra tanto serviço assim, o hardware influencia bastante, tipo, qualidade de motherboard, velocidade da memória, de I/O.

    Verifique serviço a serviço qual está gastando mais processo, roda comando top como nosso amigo acima disse.
    Poste aqui quantos processos tão rodando na sua máquina só pra gente ver (ps aux | wc -l)



  9. #9
    guardian_metal
    Visitante

    Padrão CPU

    O X fica rodando pq não consigo fazer o mysql rodar na inicialização colocando um comando no rc.local e preciso rodar um aquivo php que só roda no mozzila. Segundo o top tem aproximadamente 120 processos.

  10. #10

    Padrão CPU

    meu! suma com o X do pc, fica comendo a maior parte do processo a toa(ainda mais se for KDE e GNOME), deixe nada gráfico rodando, rode tudo via linha de comando, pra rodar o arquivo.php vá em outra máquina na rede e pronto. Quanto ao mysql, descreva melhor pq vc não consegue inicilizar ele, tá colocando o comando certo no rc.local?



  11. #11

    Padrão problema de inicialização do mysql

    inicializo ele assim:

    /bin/sh -c 'cd /usr/local/mysql; ./bin/mysqld_safe --user=mysql &'

    tente ae..ajuste para o seu path do mysql acima....

    vlws...

  12. #12
    guardian_metal
    Visitante

    Padrão CPU

    E como eu faço para adicionar este user mysql?



  13. #13

    Padrão CPU

    este é o usuário adm do mysql, que você setou a senha quando instalou e configurou o mysql, caso tenha feito isso... deixa eu pergunta... esta instalação do mysql que você tem, é a que veio no RH?

    mysqladmin -u mysql password digite-a-senha-aqui
    ou
    mysqladmin -u root password digite-a-senha-aqui

    para se conectar:

    mysql -h nome_ou_IP_da_maquina -u mysql -p
    ou
    mysql -h localost -u mysql -p

  14. #14

    Padrão CPU

    ah, e completando... para desabilitar seu X,

    Edite o arquivo /etc/inittab

    Deixe a seguinte linha assim:

    id:3:initdefault:

    assim vc estará setando o nível de execução 3 ao invés do padrão 5..
    neste arquivo tem explicando cada RunLevel, ele deve té em 5.. mude pra 3...

    caso a instalação do seu mysql seja default do RH, execute o "ntsysv" e marque a opção de iniciar o mysql, e desmarque o que vc não tive usando... dae naum precisa colocar aquele comando no rc.local....



  15. #15
    guardian_metal
    Visitante

    Padrão CPU

    Não é a que veio com o RH9 não, esta eu peguei no site, é uma versão que nem foi preciso instalar nem nada, foi só descompactar no /usr/local/msql e ja funcionou..

  16. #16
    guardian_metal
    Visitante

    Padrão CPU

    Tipo: eu precisaria criar um usuário sem login? e se for como eu faço isso?



  17. #17

    Padrão CPU

    acho q naum... qual usuário administrador do MYSQL vc usa para criar banco de dados e outras coisas.. é esse q vc tem q por lá...
    coloque ele lá e veja se funciona... blz...

  18. #18
    guardian_metal
    Visitante

    Padrão CPU

    Eu uso o root mas com ele não funciona pois ja tentei