Estranho cara, procurei no apt-get.org
e não achei nenhum pacote que seja gcc-devel,
tem certeza que é realmente este o nome do pacote que vc instalou?