Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Velho, a principio, mas não funcionou.
    Depois tentei criar na mão.

    Continuou não funcionando.

    Vou tentar gerar novamente usando o cfgmaker.

    Mais alguma dica?

    Obrigado por enquando!!!

  2. #7
    gustavofd
    presta atenção, não é complcado não...
    primeiro vc tem q ter certeza q o snmp tá rodando no outro servidor...
    depois vc cria o arquivo .cfg com o cfgmaker...
    lembre de não usar a chave public, altere para qq outra coisa, para evitar invasões ou desvio de informções...
    depois vc tem q editar o cfgmaker e setar o workdir, nele ficam os arquivos da página, as informações e as imagens...
    depois é só colocar o apache para rodar e ver pelo navegador...



  3. #8
    gustavofd
    e qq dúvida, vá no site:

    http://people.ee.ethz.ch/~oetiker/webtools/mrtg/

    sei q é chato ler em inglês, mas é o jeito...

    eu tenho mrtg/snmp rodando aqui em vários servidores...

    outro produto q recomendo para monitoração é o nagios (antigo netsaint)...

    faz vários testes shows...

  4. Instalei o snmp no server.
    Tentei rodar o ./cfgmaker pelo comando a seguir:

    ./cfgmaker --global 'Workdir: /var/www/html/mrtg' \
    --global 'Options[_]: bits,growright' \
    --output /usr/local/mrtg-2/bin/mrtg.cfg\ gateway@200.140.203.2



    O seguinte erro ocorreu:

    --base: Get Device Info on public@ :
    Error:
    can't resolve " " to IP address
    at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 424
    SNMPWALK Problem for public@ ::::::v4only
    at ./cfgmaker line 821
    WARNING: Skipping public@ : as no info could be retreived

    --base: Get Device Info on gateway@200.140.203.2:
    SNMP Error:
    no response received
    SNMPv1_Session (remote host: "200.140.203.2" [200.140.203.2].161)
    community: "gateway"
    request ID: -770772361
    PDU bufsize: 8000 bytes
    timeout: 2s
    retries: 5
    backoff: 1)
    at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 622
    SNMPWALK Problem for 1.3.6.1.2.1.1 on gateway@200.140.203.2::::::v4only
    at ./cfgmaker line 821
    WARNING: Skipping gateway@200.140.203.2: as no info could be retreived

    --base: Writing /usr/local/mrtg-2/bin/mrtg.cfg

    Estou lendo o manual da página do MRTG, vamos ver!!!



  5. #10
    gustavofd
    seguinte, vc alterou a community para gateway na /etc/snmp.conf no 200.140.203.2

    roda só ./cfgmaker community@ip

    depois quando vc conseguir isso, vc coloca o Workdir, fica menor a linha ok???

    lembre-se d liberar a conexão no firewall das duas máquinas, isso é importante...

    na máquina q está com o snmp (onde queremos as informações) no caso 200.140.203.2 tb é importante liberar no /etc/hosts.allow

    ou seja, insira a seguinte linha no arquivo:

    snmpd: ip/mask

    ip e mask claro no servidor q está com o mrtg






Tópicos Similares

  1. zabbix não gera gráfico do mikrotik
    Por felipeolivares no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-03-2014, 13:37
  2. MRTG no Debian Target ERROR. Não gera gráficos.
    Por vipnet no fórum Servidores de Rede
    Respostas: 10
    Último Post: 13-03-2008, 14:20
  3. Sasacct não gera graficos
    Por kalz no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-06-2007, 17:41
  4. Cacti não gera gráficos...Quem sabe???
    Por regisnr no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 05-04-2007, 12:58
  5. Cacti não gera gráficos
    Por Davi Junio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-01-2006, 00:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L