Notei um erro ae, Vc não deve instalar o libxml2-2.6.10-2.src.rpm e sim o libxml2-2.6.10-2.i386.rpm. O pacote que você instalou são os fontes (src) e não o pacote ja pronto.

Pega aqui estes dois:

ftp://ftp.conectiva.com.br/pub/conec...0_1cl.i386.rpm

ftp://ftp.conectiva.com.br/pub/conec...0_1cl.i386.rpm

ou dá um apt-get install libxml2

e depois compila seu php.