Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #6
    aduraess
    Me perdoe se a pergunta for muiiito básica, mas SOCORRO!!

    Onde/como faço isso??

  2. #7
    mariborghi
    no arquivo /etc/postfix/access
    vc coloca os numeros ips que possam ter acesso ao relay do seu smtp.

    exemplo:

    200.210.5.78 RELAY

    este numero pode ser sua placa válida do firewall ou seu servidor direto na net.
    Não sei como está sua configuração.



  3. #8
    aduraess

    Obrigado pela sua atenção e ajuda, mas ainda não consigo receber e-mail oriundo do "hotmail".....

    E-mail do "ig", "terra", são aceitos, mas do hotmail e yahoo são negados!

    Definitivamente não sei mais o que fazer.....

  4. #9
    mariborghi
    vc habilitou o log do postfix?
    Se sim dá um tail -f /etc/log/mailog e fica olhando passo a passo de cada mensagem que chega e que sai.
    Foi assim que eu consegui entender onde estava o meu problema.
    Mas é o lance de liberar os relays.
    São nestes 3 pontos.

    no main.cf

    mydestination = $myhostname, localhost.$mydomain, $mydomain

    relay_domains = $mydestination

    e no arquivo /etc/postfix/access

    200.211.5.78 RELAY

    Ou então, cria um arquivo network_table, por exemplo, e coloca dentro dele todos os numeros ips que possam usar o RELAY.
    e no main.cd vc coloca esta linha no mynetworks

    mynetworks=hash:/etc/postfix/network_table

    ou se for um numero ip só, vc habilita direto no main.cf

    mynetworks= nº IP/máscara



  5. #10
    aduraess
    :?:

    Antes de mais nada muiito obrigado pela "paciência" disponibilizada!

    O problema ainda persiste!

    Segue cópia do meu main.cf:

    main.cf
    #
    queue_directory=/var/spool/postfix
    command_directory=/usr/sbin
    daemon_directory=/usr/lib/postfix
    mail_owner=postfix
    default_privs=nobody
    myhostname=<meu hostname>
    #myhostname = virtual.domain.tld
    mydomain=<Meu domain>
    myorigin = $mydomain
    inet_interfaces=all
    mydestination= $myhostname, localhost.$mydomain, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain, <meu hostname>
    default_transport=smtp
    unknown_local_recipient_reject_code = 450
    #mynetworks = 168.100.189.0/28, 127.0.0.0/8
    #mynetworks = $config_directory/mynetworks
    #mynetworks = hash:/etc/postfix/network_table
    relay_domains= $mydestination
    alias_maps=hash:/etc/postfix/aliases
    alias_database=hash:/etc/postfix/aliases
    mailbox_command=/usr/bin/procmail
    debug_peer_level=2
    debugger_command=PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail
    newaliases_path = /usr/bin/newaliases
    mailq_path = /usr/bin/mailq
    setgid_group = postdrop
    manpage_directory = /usr/share/man
    sample_directory = /etc/postfix/sample
    readme_directory = no
    mydestination =
    relay_domains =
    # smtpd_recipient_restrictions=permit_mynetworks
    mynetworks= <minha rede>
    home_mailbox=Mailbox
    smtp_connect_timeout0
    smtp_helo_timeout00
    smtp_mail_timeout00
    smtp_rcpt_timeout00
    smtp_data_init_timeout0
    smtp_data_xfer_timeout0
    smtp_data_done_timeout`0
    smtp_quit_timeout00
    daemon_timeout000
    ipc_idle0
    ipc_timeout600
    max_idle0
    trigger_timeout
    delay_warning_time=0
    smtpd_timeout00
    smtpd_error_sleep_time=1
    append_at_myorigin=no
    best_mx_transport=local
    #

    master.cf
    #
    # =========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # =========================================================================
    smtp inet n - n - - smtpd
    #628 inet n - n - - qmqpd
    pickup fifo n - n 60 1 pickup
    cleanup unix n - n - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - n 300 1 nqmgr
    rewrite unix - - n - - trivial-rewrite
    bounce unix - - n - 0 bounce
    defer unix - - n - 0 bounce
    flush unix n - n 1000? 0 flush
    proxymap unix - - n - - proxymap
    smtp unix - - n - - smtp
    relay unix - - n - - smtp
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - n - - showq
    error unix - - n - - error
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - n - - lmtp
    #
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
    #
    # The Cyrus deliver program has changed incompatibly, multiple times.
    #
    old-cyrus unix - n n - - pipe
    flags=R user=cyrus argv=/usr/lib/cyrus/deliver -e -m ${extension} ${user}
    # Cyrus 2.1.5 (Amos Gouaux)
    cyrus unix - n n - - pipe
    user=cyrus argv=/usr/lib/cyrus/deliver -e -r ${sender} -m ${extension} ${user}
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    #

    Log de um e-mail vindo do HotMail
    #
    Jul 22 07:43:41 <host> postfix/smtpd[5276]: connect from bay17-f35.bay17.hotmail.com[64.4.43.85]
    Jul 22 07:43:42 <host> postfix/smtpd[5276]: 12B263FE01F: client=bay17-f35.bay17.hotmail.com[64.4.43.85]
    Jul 22 07:43:42 <host> postfix/smtpd[5276]: 12B263FE01F: reject: RCPT from bay17-f35.bay17.hotmail.com[64.4.43.85]: 554 <meu e-mail>: Relay access denied; from=<(e-mail)@hotmail.com> to=<meu e-mail> proto=ESMTP helo=<hotmail.com>
    Jul 22 07:43:43 <host> postfix/smtpd[5276]: 12B263FE01F: reject: RCPT from bay17-f35.bay17.hotmail.com[64.4.43.85]: 554 <meu e-mail>: Relay access denied; from=<(e-mail)@hotmail.com> to=<meu e-mail> proto=ESMTP helo=<hotmail.com>
    Jul 22 07:43:44 <host> postfix/smtpd[5276]: disconnect from bay17-f35.bay17.hotmail.com[64.4.43.85]
    #

    Continuo sem saber que fazer! Onde estou errando?! :?






Tópicos Similares

  1. Postfix + Courier nao recebe emails.
    Por ivonei no fórum Servidores de Rede
    Respostas: 4
    Último Post: 20-11-2008, 14:21
  2. postfix + dovecot não recebe email
    Por Dedao no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-01-2008, 16:24
  3. POSTFIX não envia emails nem recebe
    Por LinuxKids no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-10-2006, 14:39
  4. Postfix - não recebe emails
    Por caticiane no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-03-2005, 14:01
  5. Meu servidor nao recebe email de alguns dominios externos !
    Por raphaelcm no fórum Servidores de Rede
    Respostas: 20
    Último Post: 07-07-2004, 12:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L