+ Responder ao Tópico



  1. #1
    luccosta
    Visitante

    Padrão Uma pequena dúvida no FSTAB

    Hello All.

    Estou dando uma configurada aqui na minha máquina de teste e estou com algumas dúvidas quanto ao FSTAB. Será que alguém poderia por uma luz nesta(?).

    Meu FSTAB esta configurado assim:

    /dev/hda5 swap swap defaults 0 0
    /dev/hda6 / ext3 defaults 1 1
    /dev/hda1 /windows vfat auto,users,defaults,exec 0 0
    /dev/hda2 /programas vfat auto,users,defaults,exec 0 0
    /dev/cdrom /mnt/cdrom iso9660 user,noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto users,noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

    Só que logado como usuário normal do sistema eu não consigo montar o Cdrom ou o Floppy. Será que alguém pode dar uma analisada neste file e me apontar uma saida?
    Outra coisa, o que significam os valores 0 0, 1 1 que aparecem no final de cada linha...

    Valeu ai.

  2. #2

    Padrão Uma pequena dúvida no FSTAB

    tire o owner da configuração deles



  3. #3

    Padrão Uma pequena dúvida no FSTAB

    A primeira coluna de 0 serve para decidir se o sistema de arquivos vai ser checado na inicialização, já a segunda eu não lembro, sorry.


    Abraços!

  4. #4

    Padrão Uma pequena dúvida no FSTAB

    Coloca isso aqui ó:

    /dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
    /dev/cdrom /mnt/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0

    E tudo vai ficar Azul....



  5. #5
    Visitante

    Padrão Re: Uma pequena dúvida no FSTAB

    Obrigado pelas respostas, mas ainda tenho uma dúvida...
    No meu FSTAB as linhas avabaixo dizem respeito a duas partições que tenho:
    Citação Postado originalmente por luccosta
    /dev/hda1 /windows vfat auto,users,defaults,exec 0 0
    /dev/hda2 /programas vfat auto,users,defaults,exec 0 0
    Na forma que esta, logado com meu usuário padrão eu não tenho acesso às informações existentes na mesma. Será que existe alguma informação errada?

    Outra coisa, na 3 coluna do FSTAB o correto é user ou users, eu já vi as duas formas e estou achando estranho. Dentro do Slack10 o grupo é chamado users, não é?

    Valeu pela ajuda!

  6. #6
    Mav3r1ck
    Visitante

    Padrão Uma pequena dúvida no FSTAB

    olha só:
    o 0 0 ou 1 1 q vc mencionou, podem ser:

    o primeiro zero pode ser tb 1, significado:
    0 --> Não executa o Dump nesta partição
    1 --> Executa o Dump...

    o segundo 0 pode ser tb 1 ou 2:
    0 --> Não roda o fsck
    1 --> Roda o fsck mas com MAIOR prioridade
    2 --> Roda o fsck..

    No meu arquivo fstab mounto o cdrom e floppy assim:
    /dev/fd0 /mnt/floppy ext2 noauto 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,ro 0 0

    falow



  7. #7
    luccosta
    Visitante

    Padrão Uma pequena dúvida no FSTAB

    Ainda não consigo acessar as partições como usuário padrão:
    /windows
    e /programas

    No FSTAB tenho:
    /dev/hda1 /windows vfat auto,users,defaults,exec 0 0
    /dev/hda2 /programas vfat auto,users,defaults,exec 0 0

    Mas se logo como root tenho acesso completo.

    Será que alguem tem mais sugestões?
    meu usuários faz parte dos grupos user, audio, cdrom, floppy, ftp, games, wheel e video.

  8. #8
    dctalk
    Visitante

    Padrão Uma pequena dúvida no FSTAB

    Outra coisa, na 3 coluna do FSTAB o correto é user ou users, eu já vi as duas formas e estou achando estranho. Dentro do Slack10 o grupo é chamado users, não é?
    não confunda as coisas....
    no /etc/fstab user significa que usuários não-root podem montar no caso o CD e o Floppy.

    obs: se vc estiver usando o vim como editor vc verá que colocando "user" a palavra ficará verde , ou seja, correta. Então coloque a palavra "users" e vê se ficará verde...

    "users" no slack é o grupo para usuários, é default no sistema.

    se eu estiver errado me corrija....

    Ainda não consigo acessar as partições como usuário padrão:
    /windows
    e /programas

    No FSTAB tenho:
    /dev/hda1 /windows vfat auto,users,defaults,exec 0 0
    /dev/hda2 /programas vfat auto,users,defaults,exec 0 0

    Mas se logo como root tenho acesso completo.

    Será que alguem tem mais sugestões?
    meu usuários faz parte dos grupos user, audio, cdrom, floppy, ftp, games, wheel e video.

    well, na partição onde está o windows ou seja , qualquer coisas do tipo "vfat"

    coloque assim

    /dev/hda1 /windows vfat auto,gid=100,umask=002,user,exec 0 0
    /dev/hda2 /programas vfat auto,gid=100,umask=002,user,exec 0 0

    o importante é ter gid=100,umask=002,user

    falouz!