Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. coloque:

    nameserver 200.xxx.xxx.xxx (o dns do teu provedor de acesso por exemplo)

  2. 1º, tenha certeza d q vc jah estah conectado a internet, e outra coisa, gw tem q ter ip fixo na sua LAN

    se vc faz uma discagem, quando sua conexao eh estabelecida, uma nova interface eh levantada, acredito q deve levantar a ppp0

    se vc quer soh fazer um gw, faca o seguinte:

    digite no seu /etc/rc.local

    modprobe iptable_nat
    echo "1" /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    isso deve resolver seu prob, e para configurar seu squid, no google, procure por "squid ninja" e vc vai ter um tutorial excelente

    []'s



  3. Quer ver um bom material sobre Squid e Proxy Transparente? Pega o meu guia...
    http://www.facic.fuom.br/~guilherme/stefano

    No servidor está a versão 1.0, mas logo estará saindo a 1.1. Qualquer coisa você pode pedir que eu te mando por e-mail...


    Um abraço!

  4. Galera, muito obrigado pela ajuda de todos......
    Mas acho que meu problema e mais sério.
    Pelo que verifiquei a interface ppp0 esta UP.
    Mas o que acontece, fui no meu resolv.conf e coloquei o seguinte:
    nameserver 200.227.128.20
    nameserver 200.227.128.21
    BLZ, ate ai tudo bem, mas mesmo no prompt com a interface ppp0 UP, tento dar um ping para qualquer endereço na web, e não vai, mesmo colocando ping -I ppp0 www.uol.com.br, ele não responde.
    A unica maneira que consegui fazer ele responder seria tentando pingar para o DNS, que seria assim ping -I ppp0 200.227.128.20, porque também se tirar o -I ppp0, ele não funciona.
    Alguem teria ideia do que poderia fazer depois disso tudo??

    Valeu pessoal.....



  5. Citação Postado originalmente por jricardo
    Galera, muito obrigado pela ajuda de todos......
    Mas acho que meu problema e mais sério.
    Pelo que verifiquei a interface ppp0 esta UP.
    Mas o que acontece, fui no meu resolv.conf e coloquei o seguinte:
    nameserver 200.227.128.20
    nameserver 200.227.128.21
    BLZ, ate ai tudo bem, mas mesmo no prompt com a interface ppp0 UP, tento dar um ping para qualquer endereço na web, e não vai, mesmo colocando ping -I ppp0 www.uol.com.br, ele não responde.
    A unica maneira que consegui fazer ele responder seria tentando pingar para o DNS, que seria assim ping -I ppp0 200.227.128.20, porque também se tirar o -I ppp0, ele não funciona.
    Alguem teria ideia do que poderia fazer depois disso tudo??

    Valeu pessoal.....
    Amigo arruma um 486 instala o RedHat de preferência o 9 e vai por partes faz o NAT:
    1º edita o rc.local

    modprobe iptable_nat
    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

    #(OBS: Note que no meu caso, a placa de rede que se conecta a internet é eth1, isso pode mudar de acordo com sua configuração, podendo variar para eth0, ppp0, etc. )

    Feito isso vc ja vai estar com sua maquina fazendo GW da internet para a rede interna confira se já está navegando coloque um pc WIN na segunda placa de rede e tente navegar provavelmente vai dar certo até pq o GW é só isso mesmo de pois é só vc criar as regras para direcionar os pacotes para o Squid e para o Apache.

    Valeu resolve 1º este problema da navegação q é o mas simples depois vc pensa no mas complicado......vamos por partes,,,,
    Espero ter ajudado.






Tópicos Similares

  1. kernel e suporte iptables
    Por estanisgeyer no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-12-2003, 14:02
  2. Compilar kernel para habilitar iptables !
    Por Hsantos no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-05-2003, 13:24
  3. Compilar kernel para habilitar iptables !
    Por Hsantos no fórum Servidores de Rede
    Respostas: 4
    Último Post: 15-05-2003, 09:48
  4. Compilar kernel para habilitar iptables !
    Por Hsantos no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-05-2003, 15:13
  5. Compilar kernel para habilitar iptables !
    Por Hsantos no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-05-2003, 14:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L