Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. bo, interbase + firebird é show..eu uso aqui.... vc terá que compilar seu php com suporte ao firebird..... ao configurar ele na compilação use a opção "--with-interbase=//path/to/interbase/" .....pega o PHP 5 e compila ele, irá funcionar legal....arruma seu httpd.conf para ler o módulo do php compilado e estará funcionando redondinho....

    po não sei pq ele já não vem habilitado por padrão no linux....se ao menos viesse o módulo dele separado para carrega-lo...

  2. obrigado pela dica já estou fazendo



  3. Eu compilei com a opção --with-interbase=//path/to/interbase/ que nosso amigo passou beleza depois na hora de procurar a biblioteca do modulo php5 para colocar no http.conf eu só encontro no diretorio que eu descompactei o php5 vcs sabem me dizer se eu fiz alguma coisa errada ?? ou tem algum outro problema???

  4. quais as opções vc usou na compilação? como compilou? os binários do php estão em que pasta?

    ./configure --with-apxs2=/pathtoapache/apache2/bin/apxs --with-interbase=/ibase_path --with-mysql

    # make
    # make install


    dae vc coloca o path do libphp5.so no seu httpd.conf, se não me engano deverá estar em libexec/libpp5.so dentro da pasta do apache....os paths do apache mudam nos pacotes padrões de cada distro, por isso adapte corretamente...



  5. Oi o apache eu compilei assim
    # ./configure --prefix=/usr/local/apache --enable-shared=max
    make && make install

    O php5 eu compilei assim

    ./configure --with-apxs=/usr/local/apache/bin/apxs - -with-interbase=/opt/firebird/

    Compilou tudo certinho o propio instalador do php reconstruiu o http.conf mais mesmo assim qdo eu inicio o apache não levanta os modulos do php
    no http.conf tem as linhas que deveriam levantar o php
    LoadModule php5_module libexec/libphp5.so
    (e a biblioteca esta no diretorio)
    mais qdo eu testo com o mesmo arquivo php que esta logo acima ele aparece o texto não os comando do php e no log do apache ele dá a seguinte linha
    error.log
    [Thu Aug 5 14:30:56 2004] [notice] Apache/1.3.31 (Unix) PHP/5.0.0 configured -- resuming normal operations
    [Thu Aug 5 14:30:56 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)

    access.log
    192.168.20.6 - - [05/Aug/2004:14:34:54 -0300] "GET /teste.php HTTP/1.0" 200 368

    alguem tem ideia do que pode ter acontecido?






Tópicos Similares

  1. Dúvida sobre PHP + Firebird
    Por aprendiz_ce no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 11-12-2006, 20:50
  2. PHP+FIREBIRD
    Por MAKS01 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-08-2005, 19:03
  3. PHP+Firebird
    Por Raphael_branco no fórum Servidores de Rede
    Respostas: 3
    Último Post: 05-08-2005, 12:07
  4. Linux - Firebird + PHP + Apache
    Por jricardo no fórum Servidores de Rede
    Respostas: 15
    Último Post: 09-03-2005, 16:38
  5. PHP 5.0.1 com suprte a Firebird no Conectiva 10
    Por omaximo no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-09-2004, 10:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L