Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. calma...nao se desespere.....qual foi o prefix q vc usou na instalacao do postgresql, e qual o diretorio q vc coloco pra compilar o php???

  2. #12
    Eu estou achando é o seguinte :
    Teve um cara da Empresa que tinha instalado o PostgreSQL , não sei como , e o maldito entrou de férias . Por isso o que eu fiz..:
    Baixei os Códigos-fonte do PostgreSQL , e passei o seguinte parâmetro no configure


    ./configure --prefix=/usr/local/pgsql

    Isso eu fiz somente para que eu tivesse um lugar para pegar os arquivos do PostgreSQL que eu precisava ( não sei se eu fiz certo).

    E deve ser isso que deve tá dando pau..!! não sei..!

    Aí na compilação do PHP eu indiquei o seguinte caminho

    /usr/local/pgsql


    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/pgsql


    Olha pra ver se você me dá uma idéia..!!!
    Como eu tive que colocar o banco em produção eu fiz as configurações com uma outra máquina , com todos os pacotes instalados com os RPM's do Redhat 9.0 . Más a máquina que eu não consegui instalar tá lá ainda..!


    Goiaba-linux



  3. nao sei se pode ser isso....mas toda vez q eu instalei o php com suporte ao postgresql eu usei junto a opcao --enable-dbase ve se isso resolve

  4. #14
    jamba
    Ae maninho se liga na minha compilacao

    PGSQL
    Código :
    ./configure --prefix=/usr/local/postgres --libdir=/usr/lib/postgresql/lib/ --with-perl --with-odbc --with-openssl  --datadir=/etc/postgresql/ --with-pgport=5432 --sysconfdir=/etc/postgresql --bindir=/usr/lib/postgresql/bin/ --mandir=/usr/share/man/ --docdir=/usr/share/postgresql/

    PHP-4.3.4
    Código :
    ./configure --with-pgsql=/usr/local/pgsql/ --with-mysql=/usr/local/mysql/ --with-mysql-sock=/tmp/mysql.sock --with-apxs2=/usr/local/apache2/bin/apxs --with-config-file-path=/etc/ --with-pear=/usr/share/pear/ --with-gettext --with-xml --with-openssl  --with-gd --with-jpeg-dir=/usr/lib/ --with-zlib-dir=/usr/include/ --with-freetype-dir=/usr/include/freetype2/ --with-png-dir=/usr/lib/ --with-xpm-dir=/usr/X11R6/lib/






Tópicos Similares

  1. Problemas com o Apache e PHP
    Por GhOsTLip no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-09-2004, 07:37
  2. Fiz merda #$% no apache ou php
    Por Neckratal no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-02-2004, 11:04
  3. instalar configuração mínima do apache com PHP
    Por redoctober no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-01-2004, 07:17
  4. Apache x PHP
    Por ghenri no fórum Servidores de Rede
    Respostas: 7
    Último Post: 02-12-2003, 15:19
  5. Instalando um apache com php e suporte a Oci8 num conectiva
    Por Futuremax no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-12-2002, 15:23

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L