+ Responder ao Tópico



  1. #1
    guardian_metal
    Visitante

    Padrão Atualização

    Quando instalei meu apache (2.0.40) pelo tar.gz, instalei da seguinte forma:

    ./configure –enable-so –enable-mods-shared=all
    make
    make install

    Agora gostaria de atualizar para o 2.0.51. Como faço para fazer isso?
    Basta descompactar o apache e rodar os mesmo comando de instalação que rodei para o anterior? Meu httpd.conf será sobrescrito e terei de editar novamente?

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão Atualização

    a principio sim são os mesmo comando porem faça uma copia de segurança do httpd.conf



  3. #3
    guardian_metal
    Visitante

    Padrão Atualização

    Valeu pela dica Benatto. Como tinha guardado os fontes, encontrei um arquivo chamado config.nice na pasta. Quando abri, vi que ele guardou todos os meus configures. Bastei rodar o ./config.nice e depois make e make install e ae foi blz. Ja ta até atualizado.

    Valeu.

    PS: Esse procedimento funciona para tudo que foi instalado por tar.gz?

  4. #4
    gmlinux
    Visitante

    Padrão Atualização

    não, depende dos scripts de configuração... quando existem...



  5. #5
    guardian_metal
    Visitante

    Padrão Atualização

    Pretendo atualizar o php mas não tenho mais os fontes. Ainda tenho guardado num arquivo de texto os configures que usei para instalá-lo. Se eu usar os mesmo configures ele vai atualizar ou devo seguir outro procedimento?

  6. #6
    gmlinux
    Visitante

    Padrão Atualização

    o ideal é executar o comando configure novamente, usando os mesmos parametros que uso da outra vez, se possível....