+ Responder ao Tópico



  1. #1
    RMaceira
    Visitante

    Padrão Perda de pacotes

    Boa tarde,

    Tenho um provedor que estou começando agora, estou com um grande problema, tenho um servidor redhat 9.0, que depois de 5 dias ligado esta perdendo pacotes, quando reinicio o linux, a máquina volta preparada para funcionar por mais 5 dias, perdendo pacotes novamanete depois de cinco dias.
    No momento que ocorre o problema tendo dar um ping mas aparece uma mensagem de "operação não permitida", para uns cinco pacotes aparece a mensagem e um ping correto.
    O que pode ser? se puderem me ajude com uma idéia.

    Obrigado!

    Também gostaria de saber por alguns usuários tem um número de linuxuser, o que significa isso?
    Ate mais ...

  2. #2
    b1n4r1
    Visitante

    Padrão Perda de pacotes

    blz??

    eu trabalho num provedor e sei como é, bom em relaçao ao ping q vc
    da e aparece operaçao nao permitida é pq no firewall esta bloqueado o ping e depois de um tempo da um ping correto realmente nao sei pq acontece isso.
    e perda de pacotes, pode ser por causa de muito fluxo de dados, sei pq aki ja aconteceu tb estava com muita perda de pacotes e quando vi tinha
    um cliente detonando!! mesmo com controle de banda ativado.
    se derrepende vc dizer oq ta rodando nele, se a maquina é boa e tal, derrepente fica mais facil a gente ajudar.
    espero ter dado um pequena ajuda

    t+ valeu



  3. #3
    RMaceira
    Visitante

    Padrão Perda de pacotes

    blz!!

    No firewall não tem nada bloqueado, quanto a maquina é um pentium 3 com 1 giga de processamento, 512 Mb de memoria, 10 Gb de HD e tem 90 usuários pendurado nela.

    Valeu !!

  4. #4
    b1n4r1
    Visitante

    Padrão Perda de pacotes

    é estranho, se firewall nao é, maquina tb nao, nao deve nem fazer cosquinha :-), em relaçao a perda de pacote ve se nao tem muito fluxo de dados passando, formando um funil na saida isso causa perda de pacotes, agora pq a cada 5 dias tem q rebootar a maquina por causa disso é meio estranho, vc ja atualizo o RH9 ? segurança/correçoes, mas assim vc esta perdendo pacotes na sua saida ? ou na sua entrada?



  5. #5
    RMaceira
    Visitante

    Padrão Perda de pacotes

    Citação Postado originalmente por b1n4r1
    é estranho, se firewall nao é, maquina tb nao, nao deve nem fazer cosquinha :-), em relaçao a perda de pacote ve se nao tem muito fluxo de dados passando, formando um funil na saida isso causa perda de pacotes, agora pq a cada 5 dias tem q rebootar a maquina por causa disso é meio estranho, vc ja atualizo o RH9 ? segurança/correçoes, mas assim vc esta perdendo pacotes na sua saida ? ou na sua entrada?
    Parece meio estranho, mas não sei fazer atualização

    Se puder ajudar, agradeço.

    Valeu!!

  6. #6
    felco
    Visitante

    Padrão Perda de pacotes

    acho q o problema eh broadcast

    iptables -F
    iptables -F -t nat
    iptables -X
    iptables -X -t nat

    iptables -t nat -P PREROUTING ACCEPT
    iptables -t nat -P POSTROUTING ACCEPT
    iptables -t nat -P OUTPUT ACCEPT
    iptables -P INPUT DROP
    iptables -P FORWARD DROP
    iptables -P OUTPUT ACCEPT

    iptables -t nat -A PREROUTING -m state --state INVALID -j DROP
    iptables -t nat -A PREROUTING -m unclean -j DROP

    #caso vc use squid na rede
    iptables -t nat -A PREROUTING -i eth1 -s 192.168.0.0/16 -p tcp --dport 80 -j REDIRECT --to-port 3128

    iptables -A INPUT -m state --state INVALID -j DROP
    iptables -A INPUT -m unclean -j DROP
    iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    iptables -A INPUT -i eth0 -s 0/0 -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -i eth1 -s 0/0 -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -i eth1 -s 192.168.0.0/16 -p tcp --dport 3128 -j ACCEPT
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A INPUT -p tcp --syn -m limit --limit 1/s --limit-burst 1 -j RETURN
    iptables -A INPUT -p icmp -m limit --limit 1/s --limit-burst 2 -j ACCEPT
    iptables -A INPUT -j DROP

    iptables -A FORWARD -m state --state INVALID -j DROP
    iptables -A FORWARD -m unclean -j DROP
    iptables -A FORWARD -p tcp --dport 135 -j DROP
    iptables -A FORWARD -p udp -m multiport --dports 137,138 -j DROP
    iptables -A FORWARD -p tcp --dport 139 -j DROP
    iptables -A FORWARD -p tcp --dport 445 -j DROP
    iptables -A FORWARD -p udp --dport 445 -j DROP
    iptables -A FORWARD -p udp --dport 500 -j DROP
    iptables -A FORWARD -p tcp --dport 1039 -j DROP
    iptables -A FORWARD -p udp --dport 1050 -j DROP
    iptables -A FORWARD -p udp --dport 1065 -j DROP
    iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT
    iptables -A FORWARD -i eth0 -o eth1 -j ACCEPT

    iptables -t nat -A POSTROUTING -m state --state INVALID -j DROP
    iptables -t nat -A POSTROUTING -m unclean -j DROP
    iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/16 -j MASQUERADE



  7. #7
    Visitante

    Padrão Perda de pacotes

    Citação Postado originalmente por felco
    acho q o problema eh broadcast

    iptables -F
    iptables -F -t nat
    iptables -X
    iptables -X -t nat

    iptables -t nat -P PREROUTING ACCEPT
    iptables -t nat -P POSTROUTING ACCEPT
    iptables -t nat -P OUTPUT ACCEPT
    iptables -P INPUT DROP
    iptables -P FORWARD DROP
    iptables -P OUTPUT ACCEPT

    iptables -t nat -A PREROUTING -m state --state INVALID -j DROP
    iptables -t nat -A PREROUTING -m unclean -j DROP

    #caso vc use squid na rede
    iptables -t nat -A PREROUTING -i eth1 -s 192.168.0.0/16 -p tcp --dport 80 -j REDIRECT --to-port 3128

    iptables -A INPUT -m state --state INVALID -j DROP
    iptables -A INPUT -m unclean -j DROP
    iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    iptables -A INPUT -i eth0 -s 0/0 -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -i eth1 -s 0/0 -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -i eth1 -s 192.168.0.0/16 -p tcp --dport 3128 -j ACCEPT
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A INPUT -p tcp --syn -m limit --limit 1/s --limit-burst 1 -j RETURN
    iptables -A INPUT -p icmp -m limit --limit 1/s --limit-burst 2 -j ACCEPT
    iptables -A INPUT -j DROP

    iptables -A FORWARD -m state --state INVALID -j DROP
    iptables -A FORWARD -m unclean -j DROP
    iptables -A FORWARD -p tcp --dport 135 -j DROP
    iptables -A FORWARD -p udp -m multiport --dports 137,138 -j DROP
    iptables -A FORWARD -p tcp --dport 139 -j DROP
    iptables -A FORWARD -p tcp --dport 445 -j DROP
    iptables -A FORWARD -p udp --dport 445 -j DROP
    iptables -A FORWARD -p udp --dport 500 -j DROP
    iptables -A FORWARD -p tcp --dport 1039 -j DROP
    iptables -A FORWARD -p udp --dport 1050 -j DROP
    iptables -A FORWARD -p udp --dport 1065 -j DROP
    iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT
    iptables -A FORWARD -i eth0 -o eth1 -j ACCEPT

    iptables -t nat -A POSTROUTING -m state --state INVALID -j DROP
    iptables -t nat -A POSTROUTING -m unclean -j DROP
    iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/16 -j MASQUERADE

    Eu tenho que aplicar essas regras no meu firewall ??

    Valeu!!

  8. #8
    felco
    Visitante

    Padrão Perda de pacotes

    faz um teste



  9. #9
    pflamellas
    Visitante

    Padrão Perda de pacotes

    Kra,
    naum sei se vai ajudar...mas vc já experiomentou verificar se não é erro de eth...as placas são confiaveis???