+ Responder ao Tópico



  1. #1

    Padrão Pontos de montadem...

    Olá pessoal...
    Como eu faço para definir pontos de montagem samba na inicialização do sistema?
    Uso Fedora2...

  2. #2

    Padrão Pontos de montadem...

    Acho que isso fica no arquivo de configuracao do samba
    /etc/samba/smb.conf



  3. #3

    Padrão Pontos de montadem...

    Citação Postado originalmente por vonlinkerstain
    Acho que isso fica no arquivo de configuracao do samba
    /etc/samba/smb.conf
    Ajudou muito...
    Acho que não fui claro. O que eu quero é definir pontos de montagem na minha máquina Fedora2 para que sejam montados compartilhamentos windows automaticamente na inicialização....

  4. #4

    Padrão Pontos de montadem...

    vc pode colocar no fstab...

    mas eu acho mais facil inserir o "mount -smbfs coisa e talz"... no /etc/rc.local

    []`s



  5. #5

    Padrão Pontos de montadem...

    Citação Postado originalmente por demiurgo
    .
    ...mount -smbfs ...
    Desculpe, mas se possível dá pra concluir com um exemplo?

  6. #6

    Padrão Pontos de montadem...

    blz...
    vamos imaginar o cenario?

    ip do pc com share: 192.168.0.1
    nome do share: docs
    username: zezinhu
    senha: vaca
    ponto d montagem loca: /mnt/rede

    mount -t smbfs -o username=zezinhu,password=vaca //192.168.0.1/docs /mnt/rede

    coloca issu no seu /etc/rc.local

    []`s



  7. #7

    Padrão Pontos de montadem...

    Olha o que retornou....

    [email protected]:~$ su
    Password:
    [email protected]:/home/kurumin# cd
    [email protected]:~# mount -t smbfs -o username=administrador,password=guaraply //192.168.3.1/inst$ /mnt/rede
    cli_negprot: SMB signing is mandatory and we have disabled it.
    16418: protocol negotiation failed
    SMB connection failed
    [email protected]:~#

  8. #8

    Padrão Pontos de montadem...

    O samba ta ativo nesta maquina?



  9. #9

    Padrão Pontos de montadem...

    Eu coloquei no rc.local o seguinte comando:

    smbmount //maqwin/pastacompartilhada //dir_nolinux/pastanomnt -o password=

    No caso o compartilhamento da maquina ruindows nao tem senha.
    a opcao (-o password= ) serve para nao pedir enter de senha vazia quando monta o compartilhamento..

    Obs.: para o smbmount funcionar blz tem que ter o samba mais ou menos configurado.. e ativo.

  10. #10
    fibrox
    Visitante

    Padrão Samba: Linux acessando Samba

    Tenho um CL8 com samba, o qual serve a alguns micros Windows, funciona muito bem (cria o drive R: e o drive P: ), mas eu queria que um micro Linux tivesse acesso ao compartilhamento homes e um pasta publica (servida pelo samba).

    Uso o seguinte comando para ter acesso ao homes:

    smbmount //servidor/homes /pastalocal -o username=usuario,password=senha rw

    Mas como que pode montar é o root sendo assim o real usuario nao pode criar/apagar arquivos/pastas neste local.

    Gostaria de saber como permitir ao usuario ter acesso completo a sua pasta neste samba? Seria possivel incluir isso no fstab?

    Muito obrigado.



  11. #11

    Padrão Pontos de montadem...

    O usuario nao tem permissao de escrita na pasta de montagem da maquina linux, ou o usuario nao tem a permissao de montagem do "drive" samba?

  12. #12

    Padrão Pontos de montadem...

    interessante,,,só pra acompanhar...



  13. #13

    Padrão Pontos de montadem...

    pois ele n tem permissão de acesso pq ao montar o compartimento pelo rc.local ele é montado pelo sistema uid=0
    logo apenas o root tem acesso

  14. #14
    fibrox
    Visitante

    Padrão Samba : ponto de montagem

    Como que tem permissao para montar é o root, o usuario nao terá como escrever neste ponto de montagem criado pela conexao com o samba, Ou seja, na linha abaixo /pastalocal pertence ao root, e o usuario só pode ler e nada mais.

    smbmount //servidor/homes /pastalocal -o username=usuario,password=senha rw

    Como seria um entrada no fstab para isso? Talvez?

    //servidor/homes ~/homes smbfs rw,user,auto 0 0
    //servidor/publico ~/publico smbfs rw,user,auto 0 0

    E a senha?