+ Responder ao Tópico



  1. #1
    serhumano
    Visitante

    Padrão lsmod

    eu.. atualizei meu kernel... de 2.4.22 para o 2.6.9...
    e quando eu entro no 2.6.9 quando eu entro com o comando "lsmod"
    nao mostra nada.... pq serah?? quando eu volto pro kernel antigo tudo aparece....
    alguem pode me ajudar?

  2. #2

    Padrão lsmod

    ué... os modulos naum foram carregados no seu novo kernel...



  3. #3

    Padrão lsmod

    creio eu que os módulos podem estar compilados como builtin no kernel.... e por isso não são exibidos...

    ouuuuu por algum motivo eles não estão sendo carregados.... (mas com isso muita coisa não funionaria direito)

  4. #4

    Padrão lsmod

    Intaum no caso nos diga ae se o som, a rede e derivados estão funcionando ou nao...!?



  5. #5
    serhumano
    Visitante

    Padrão ae

    nem rede nem som ta prestando... e no kernel antigo sim...
    e como eu faço pra prestar?

  6. #6

    Padrão lsmod

    Como vc instalou o kernel? compilou ele e adicionou na configuração dele para criar os modulos de rede e som referente a seu hardware?



  7. #7

    Padrão lsmod

    para carregar o modulo da placa de som por exemplo, tente:

    modprobe NOME-DO-MODULO-DA-PLACA-DE-SOM

    e faça o mesmo para os demais dispositivos do seu sistema!

  8. #8
    serhumano
    Visitante

    Padrão ae

    sim..eu sei....
    mas o problema e q não carrega.. da erro..diz q não encontrou o módulo...



  9. #9
    serhumano
    Visitante

    Padrão lsmod

    Olha eu instalei do jeito q ta nesse tópico...

    https://under-linux.org/modules.php?...wtopic&t=19707

    tar jxvf kernel-2.6.8.1.tar.bz2 - C /usr/src/
    cd /usr/src/
    rm linux
    ln -s linux-2.6.8.1/ linux
    cd linux/
    make mrproper
    make menuconfig
    make
    make modules
    make modules_install
    cp System.map /boot/System.map-2.6.x
    cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.x


    oq falta?

  10. #10
    gmlinux
    Visitante

    Padrão lsmod

    experimenta executar
    depmod -a
    algumas distros rodam isto na inicialização.

    PS.: Você esta certo que o modutils correspode a versão mínima requerida pelo mesmo kernel? Leia os Readmes do diretório dos fontes do kernel, la existe esta informação.



  11. #11
    serhumano
    Visitante

    Padrão ae

    kara.. eu testei o "depmod -a"
    ele aceitou.. no entanto.. não mudou em nada.... nada ta prestando.. eu tentei carregar os módulos, mas num deu certo...
    e oq é modutils?

  12. #12
    hawk23
    Visitante

    Padrão lsmod

    Amigo vc tem que instalar o module-init-tools , no caso do debian vc baixa o module-init-tools.deb e instala com o comando dpkg -i --force-all modules-init-tools

    Espero ter ajudado .



  13. #13
    serhumano
    Visitante

    Padrão lsmod

    e no slack.. como faz?

  14. #14
    gmlinux
    Visitante

    Padrão lsmod

    ftp://ftp.kernel.org/pub/linux/utils/kernel/modutils
    ftp://ftp.kernel.org/pub/linux/utils...le-init-tools/

    estes pacotes (um xor outro) possuem sa ferramentas depmod, modprobe, lsmod, rmmod, etc. mais atualizadas, sempre que se compila o kernel, deve-se ler no README de qual versão ele depende.



  15. #15
    parrala
    Visitante

    Padrão lsmod

    olha amigo naum tenho certeza mais acho que tinha que dar um make dep antes de make modules...