Seguinte...

meu esquema ta da seguinte forma:

Internet (200.1.2.2) --> eth1 (200.1.2.3) -- lbox -- eth0 (192.168.0.1)

Tenho um cliente no radius configurado como:

teste Auth-Type = Local, Password = "teste"
Service-Type = Framed-User,
Framed-Protocol = PPP,
Framed-IP-Address = 192.168.0.10,
Framed-IP-Netmask = 255.255.255.255,
Framed-Routing = Broadcast-Listen,
Framed-Filter-Id = "bo",
Framed-MTU = 1500,
Framed-Compression = Van-Jacobson-TCP-IP,
Idle-Timeout = 600,
Download = 256,
Upload = 64

O arquivo /etc/ppp/ips tem o seguinte conteudo:

192.168.0.0-255

Eu inicializo o pppoe-server da seguinte forma:

pppoe-server -C Teste -L 192.168.0.1 -p /etc/ppp/ips -I eth0

Em um cliente com windows 98, utilizando o RASPPPoE eu consigo efetuar a conexão, o usuario 'teste' eh autenticado, o IP 192.168.0.10 eh atribuido a ele, os servidores de DNS são configurados com os que eu previamente defini no arquivo /etc/ppp/pppoe-server-options.

No entanto, ñ consigo sair da rede... como se ñ houvesse NAT.

No lbox eu configuro o NAT da seguinte forma:

iptables -A FORWARD -d 0/0 -s 192.168.0.10 -j ACCEPT
iptables -A FORWARD -d 192.168.0.10 -s 0/0 -j ACCEPT
iptables -t nat -A POSTROUTING -s 192.168.0.10 -d 0/0 -j MASQUERADE
iptables -A INPUT -s 192.168.0.10 -d 0/0 -j ACCEPT
iptables -A OUTPUT -s 192.168.0.10 -d 0/0 -j ACCEPT

ativo o repasse de pacotes no kernel da seguinte forma:

echo 1 > /proc/sys/net/ipv4/ip_forward

Vale ressaltar tb que eu consigo pingar do cliente windows os seguinte ip's:

192.168.0.1
200.1.2.3 (ip da outra IF)

No entanto, não consigo sair dessa rede... nem mesmo alcanço o ip 200.1.2.2

Gostaria de saber o q pode estar acontecendo.

Se alguém puder me ajudar... estou antecipadamente grato.

[]s