Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. #16
    visitante
    colega, ative os modulos do ftp.

    /sbin/modprobe ip_conntrack_ftp
    /sbin/modprobe ip_nat_ftp

    deve funcionar.

    se ok coloque para na inicialização no pc (rc.local ou coisa parecida)

    sds

  2. Citação Postado originalmente por mbtec
    # This option, if enabled, will make the users unable to access anything
    # outside their home directory tree. READ THE DOCS!
    #DefaultRoot ~ !root

    # User and Group the server will run as
    User proftpd
    Group proftpd

    <Directory /*>
    AllowOverwrite no
    </Directory>

    # Default configuration for anonymous ftp, without an incoming directory.

    <Anonymous /srv/ftp>
    User ftp
    Group ftp
    DirFakeUser on
    DirFakeGroup on
    RequireValidShell off
    UserAlias anonymous ftp
    MaxClients 10 "Sorry, max %m users -- try again later"
    MaxClientsPerHost 2 "Too many simultaneous connections"
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    AccessGrantMsg "Anonymous access granted for %u."

    # # Write disabled in anonymous chroot
    <Limit WRITE>
    DenyAll
    </Limit>

    </Anonymous>
    **********************************
    Seguinte tem o diretorio /srv/ftp para o usuario anonimo?? e para ftp de usuarios eu descomento a linha #DefaultRoot ~ !root

    falows



  3. bom por default a para srv/ftp ja vem criada mas se não vir crie ela e de um chwon como nobody. a segunda opção e a melhor que funcionou com migo, pois tinha o mesmo problema que o seu. coloque na porta 2222, veio.
    OBs: Talvez esta porta te ajude, pois também passei por este problema e com esta porta consegui resolver. flw.

  4. Citação Postado originalmente por LinuxKids
    bom por default a para srv/ftp ja vem criada mas se não vir crie ela e de um chwon como nobody. a segunda opção e a melhor que funcionou com migo, pois tinha o mesmo problema que o seu. coloque na porta 2222, veio.
    OBs: Talvez esta porta te ajude, pois também passei por este problema e com esta porta consegui resolver. flw.
    Caros amigos,
    Estou na seguinte situação:

    /etc/proftpd.conf
    port 2121

    /etc/services
    ftp-data 2120\udp
    ftp-data 2120\tcp

    ftp 2121\tcp
    ftp 2121\tcp

    Pastas para FTP
    chown ftp.ftp /srv/ftp/anonymous
    chown nobody.nobody /srv/ftp/incoming

    Squid
    acl SafePorts port 21 20 2121 2120
    http_access allow SafePorts

    Estou testando fazendo estas configurações com
    ADSL IP dinâmico, informando a cada conexão
    ao usuário qual o ip que ele deve conectar.
    Logo será fixo (com ip fixo ou no-ip)

    Estou desconfiado do roteamento das placas
    eth0 e eth1. Acho que não estou liberando a
    passagem entre as duas.

    Podem me auxiliar por favor?

    Segue novo /etc/proftpd.conf

    ****************************
    ServerName "ProFTPD - Default Instalation"
    ServerType standalone
    DefaultServer on
    ScoreboardFile /var/run/proftpd/scoreboard
    DeferWelcome on
    ServerAdmin root@localhost
    SyslogFacility AUTH

    # Port 21 (ftp standard) is used in case of standalone more
    Port 2121

    # Umask 022 is a good default value to prevent new directories and
    # files from being writable by the group or by other users
    Umask 022

    # To prevent DoS attacks, the max number of instances is limited to 30.
    # If one wants to allow more then 30 simultaneous connectionva, just
    # increment this value. This directive only applies if running in standalone
    # mode
    MaxInstances 30

    # This option, if enabled, will make the users unable to access anything
    # outside their home directory tree. READ THE DOCS!
    DefaultRoot ~

    # User and Group the server will run as
    User nobody
    Group nobody

    <Directory /*>
    AllowOverwrite no
    </Directory>

    # Default configuration for anonymous ftp, without an incoming directory.

    <Anonymous /srv/ftp/anonymous>
    User ftp
    Group ftp
    DirFakeUser on ftp
    DirFakeGroup on ftp
    RequireValidShell off
    UserAlias anonymous ftp
    MaxClients 10 "Sorry, max %m users -- try again later"
    MaxClientsPerHost 2 "Muitas conexões simultâneas - Tente mais tarde"
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    AccessGrantMsg "Anonymous access granted for %u."

    # # Write disabled in anonymous chroot
    <Directory *>
    <Limit WRITE>
    DenyAll
    </Limit>
    </Directory>

    <Directory incoming>
    Umask 022 022
    <Limit READ WRITE>
    DenyAll
    </Limit>
    <Limit STOR>
    AllowAll
    </Limit>
    </Directory>

    </Anonymous>
    ****************************






Tópicos Similares

  1. .: Velox conecta mas não navega :.
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 24
    Último Post: 10-05-2005, 14:29
  2. Respostas: 8
    Último Post: 17-12-2003, 00:20
  3. conecta mas nao navega conectiva8???
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-09-2003, 23:42
  4. conecta ma nao navega??
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-09-2003, 09:47
  5. Respostas: 4
    Último Post: 11-12-2002, 14:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L