Visite: BR-Linux ·  VivaOLinux ·  Dicas-L


+ Responder ao Tópico

  1. #11
    Quando tento instalar o pacote do ndiswrapper da o seguinte erro

    baixei o arquivo ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm porem quando tento instala-lo da o seguinte erro:

    [root@crs clecio]# rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    [root@crs clecio]#


    tentei tambem pelo aptget-install e tambem deu erro

    [root@crs clecio]# apt-get install ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando ndiswrapper-utils para 'ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.

    Já que você solicitou uma única operação é extremamente provável que
    o pacote esteja simplesmente não instalável e um relato de erro sobre
    esse pacote deve ser enviado.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:

    Como posso resolver essas pendêcias de pacotes.

    Grato

    Clecio Rodrigo
    Iniciante em Linux
    ndiswrapper-utils: Depende: perl(Fcntl) mas este não é instalável
    Depende: perl(strict) mas este não é instalável
    E: Pacotes quebrados
    [root@crs clecio]#


  2.    Publicidade


  3. #12
    Me desculpem pelo erro acima

    Quando tento instalar o pacote do ndiswrapper da o seguinte erro

    baixei o arquivo ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm porem quando tento instala-lo da o seguinte erro:

    [root@crs clecio]# rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    [root@crs clecio]#


    tentei tambem pelo aptget-install e tambem deu erro

    [root@crs clecio]# apt-get install ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando ndiswrapper-utils para 'ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.

    Já que você solicitou uma única operação é extremamente provável que
    o pacote esteja simplesmente não instalável e um relato de erro sobre
    esse pacote deve ser enviado.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:
    ndiswrapper-utils: Depende: perl(Fcntl) mas este não é instalável
    Depende: perl(strict) mas este não é instalável
    E: Pacotes quebrados
    [root@crs clecio]#

    Como posso resolver essas pendêcias de pacotes.

    Grato

    Clecio Rodrigo
    Iniciante em Linux

  4. Instalação do Ndiswrapper no CL10:

    baixe a ultima versão do Ndiswrapper do site oficial no momento é esse aqui:
    http://easynews.dl.sourceforge.net/s...per-1.1.tar.gz,
    pegue a ultima versão do driver ndis do windows no site da realtek, no momento esse aqui:
    http://152.104.125.9/cn/wlan/rtl8180...-8180(173).zip,
    de posse dos dois, instale o kernel-headers e o kernel-source no seu CL10(se já não estiverem instalados) e para completar entre em /usr/src/linux e dê um make menuconfig e quando abrir a tela de configuração do kernel, desmarque e marque novamente a opção loadable module support(atenção faça apenas isso), dai é só sair do menu de configuração e quando ele pedir para salvar o arquivo de configuração salve!(motivo desse ultimo passo é q esse arquivo de configuração não vem instalado por padrão no CL10 e ele é necessario para a instalção do ndiswrapper), feito esse passos é só descompactar o ndiswrapper que vc baixou e digitar dentro da pasta dele make install(atenção não precisa o make antes, é só make install direto) e por ultimo(ufa).... descompacte o driver ndis do windows em uma pasta qualquer e adicione ele no ndiswrapper com o comando ndiswrapper -i(Ex: ndiswrapper -i /root/ndis/NET8180.INF), com isso é só dar um modprobe ndiswrapper e configurar sua placa wireless normalmente com o iwconfig.....(ufa de novo), só isso.

    Flw.

    PS: Virou um tutorial, hehe.

  5. tentei fazer da forma que falou e não deu muito certo, poderia em ajudar com este erro

    [root@crs root]# cd /usr/src/linux
    [root@crs linux]# make menuconfig
    HOSTCC scripts/basic/fixdep
    /bin/sh: line 1: gcc: command not found
    make[1]: ** [scripts/basic/fixdep] Erro 127
    make: ** [scripts_basic] Erro 2
    [root@crs linux]#

    Grato

    Clecio Rodrigo
    Inciante em Linux

  6. Citação Postado originalmente por cleciorodrigo
    tentei fazer da forma que falou e não deu muito certo, poderia em ajudar com este erro

    [root@crs root]# cd /usr/src/linux
    [root@crs linux]# make menuconfig
    HOSTCC scripts/basic/fixdep
    /bin/sh: line 1: gcc: command not found
    make[1]: ** [scripts/basic/fixdep] Erro 127
    make: ** [scripts_basic] Erro 2
    [root@crs linux]#

    Grato

    Clecio Rodrigo
    Inciante em Linux
    Well...... faz esses 2 passos:
    - apt-get install gcc
    - apt-get install task-c++-devel

    isso ai vai instalar os compiladores, não estão instalados no seu sistema.

    Flw.


  7.    Publicidade




Usuários que leram este tópico: 0

Nenhum usuário nesta lista