Página 9 de 10 PrimeiroPrimeiro ... 45678910 ÚltimoÚltimo
+ Responder ao Tópico



  1. #41
    fpmazzi
    e aki esta a config. do meu sarg.conf

    #
    language Portuguese
    #access_log /usr/local/squid/var/logs/access.log
    access_log /var/log/squid/access.log
    title "RELATORIO DE ACESSO A INTERNET PELO PROXY SQUID"
    temporary_dir /tmp
    output_dir /var/www/sarg
    resolve_ip yes
    user_ip no
    topuser_sort_field BYTES reverse
    user_sort_field BYTES reverse
    date_format u
    remove_temp_files yes
    index yes
    overwrite_report yes
    topsites_num 100
    topsites_sort_order CONNECT D
    index_sort_order D
    # 8 Hours
    max_elapsed 28800000
    report_type topsites sites_users users_sites date_time denied auth_failures site_user_time_date
    long_url yes
    date_time_by bytes
    show_successful_message yes
    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
    user_report_fields CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

  2. Eai blz
    Teu Sarg ta legal.
    AGora post seu conf do squid para ver pq ele ta gerando u ip rede!!
    Qual sua distro?


    Citação Postado originalmente por fpmazzi
    como vc pediu aqui esta o inicio do meu access.log:


    1107781579.535 68 192.168.100.0 TCP_MISS/200 434
    GET
    http://de.uol.com.br/js.ng/site=uolb...=0&ord=160958?
    - DIRECT/200.221.6.52 application/x-javascript
    1107781579.818 73 192.168.100.0 TCP_MISS/200 1842
    GET
    http://de.uol.com.br/js.ng/site=uolb...=0&ord=160958?
    - DIRECT/200.221.6.48 application/x-javascript
    1107781579.884 97 192.168.100.0 TCP_MISS/200 1811
    GET
    http://de.uol.com.br/js.ng/site=uolb...=0&ord=160958?
    - DIRECT/200.221.6.47 application/x-javascript
    1107781585.368 154 192.168.100.0 TCP_MISS/200 15350
    GET
    http://de.i.uol.com.br/americanas/uo...vdtocatudo.gif
    - DIRECT/200.221.7.38 image/gif
    1107781585.466 60 192.168.100.0 TCP_HIT/200 4386
    GET
    http://de.i.uol.com.br/folha/uol/041...ater_folha.gif
    - NONE/- image/gif
    1107781592.413 66 192.168.100.0 TCP_MISS/302 306
    GET
    http://de.uol.com.br/event.ng/Type=c...l%3Forig%3Duo3
    - DIRECT/200.221.6.54 text/html
    1107781593.809 1122 192.168.100.0 TCP_MISS/200 10511
    GET http://www.pontofrio.com.br/cgi-bin/loja.pl? -



  3. #43
    fpmazzi
    eis aki o meu squid.conf

    http_port 192.168.100.1:3128
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin
    no_cache deny QUERY
    cache_mem 300 MB
    cache_swap_low 900
    cache_swap_high 950
    cache_replacement_policy lru
    memory_replacement_policy lru
    ipcache_size 1024
    ipcache_low 90
    ipcache_high 93
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    cache_dir diskd /var/spool/squid 350 16 256
    cache_access_log /var/log/squid/access.log
    mime_table /etc/squid/mime.conf
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    cache_effective_user squid
    cache_effective_group squid

    # ============================================================================
    # ACLS
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl localnet src 192.168.100.0/255.255.255.0
    acl cache_user src 192.168.100.0/255.255.255.0
    client_netmask 255.255.255.0

    # =============================================================================

    # Configuracao do Hotmail para funcionar #

    acl hotmail_domains dstdomain .hotmail.msn.com
    header_access Accept-Encoding deny hotmail_domains

    # Adicione essas linhas no Iptables

    # iptables -t nat -A PREROUTING -s 0/0 -d 65.4.0.0/16 -p tcp --dport 80 -j ACCEPT
    # iptables -t nat -A PREROUTING -s 0/0 -d 64.4.0.0/16 -p tcp --dport 80 -j ACCEPT

    # Configuracao para Yahoo #

    acl yahoo_domains dstdomain .yahoo.com .yahoo.com.br
    header_access Accept-Encoding deny hotmail_domains

    #= ============================================================================
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl purge method PURGE
    acl CONNECT method CONNECT
    acl proibidas url_regex -i "/etc/squid/regras/proibidas"
    acl liberadas url_regex -i "/etc/squid/regras/liberadas"
    acl ipsliberados src "/etc/squid/regras/ipsliberados"
    #acl ipsbloqueados src "etc/squid/regras/ipsbloqueados"
    # ===========================================================================

    # ===========================================================================

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny SSL_ports
    http_access allow ipsliberados
    #http_access deny ipsbloqueados
    http_access allow liberadas
    http_access deny proibidas
    http_access allow localnet
    http_access deny all
    icp_access allow all
    visible_hostname on
    visible_hostname Servidor
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    error_directory /usr/share/squid/errors/Portuguese
    # ===========================================================================

  4. Bom dia!
    Você tem dua regras de cache para o access.log! tire uma apague seus log rode o squid e tente novamente olhar os logs! veja ce ainda continua gerando o ip da rede!



  5. #45
    fpmazzi
    Cara limpei os arquivos cache.log, store.log e o access.log, e comentei a primeira linha das duas que indica o access.log, mas sem sucesso, depois fui la no squid, reabilitei a primeira linhda onde continha o access.log e desabilitei a segunda e nada tbm...

    oq sera ke ta acontecendo .... ops:






Tópicos Similares

  1. Problemas na configuração do monitor no CL9
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 12
    Último Post: 07-11-2004, 07:51
  2. Problema de configuração do postfix
    Por anmendes no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-07-2004, 10:23
  3. problema na configuração do vsftpd
    Por roggy no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-05-2004, 12:54
  4. Respostas: 0
    Último Post: 12-11-2003, 09:05
  5. problemas de configuração do cups
    Por Wronieri no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-02-2003, 11:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L