+ Responder ao Tópico



  1. #1
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    :? Ja fiz um monte de alterações mas nada funciona... estou usando 2 placas de rede e a saida de internet é eth1 a da rede local é eth0... condigurei nos clientes o seguinte:
    gateway: ip da placa de rede com saída pra internet
    dns: os dois passados pelo provedor

    se eu naum startar o squid naum funciona a internet e nem o outlook se eu startar funciona só a internet....

    olha só o meu firewall como esta:

    # Firewall
    # Carrega os módulos
    modprobe ip_tables
    modprobe iptable_nat

    #Compartilha a conexão
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #Liberar respostas de servidores www para o meu squid
    iptables -A INPUT -p TCP -i ppp0 --sport 80 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 443 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 20 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 21 -j ACCEPT
    iptables -A INPUT -p UDP -i ppp0 --sport 21 -j ACCEPT

    #Bloquear tudo
    iptables -A INPUT -p tcp --dport 3128 -j REJECT --reject-with tcp-reset
    iptables -A INPUT -j LOG --log-prefix "Pacote input descartado: "
    iptables -A INPUT -j DROP

    #Descartar pacotes inválidos
    iptables -A FORWARD -m state --state INVALID -j DROP
    #Aceitar conexões estabilizadas
    iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT

    #Liberar respostas aos servidores de nome
    iptables -A FORWARD -p udp -s 192.168.143.0/255.255.255.0 -d 200.204.0.10 --dport 53 -j ACCEPT
    iptables -A FORWARD -p udp -s 192.168.143.0/255.255.255.0 -d 200.204.0.138 --dport 53 -j ACCEPT
    iptables -A FORWARD -p udp -s 200.204.0.10 --sport 53 -d 192.168.143.0/255.255.255.0 -j ACCEPT
    iptables -A FORWARD -p udp -s 200.204.0.138 --sport 53 -d 192.168.143.0/255.255.255.0 -j ACCEPT

    #Outlook
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 25 -j ACCEPT
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 25 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 21 -j ACCEPT

    #Bloqueando e gerando log
    iptables -A FORWARD -j LOG --log-prefix "Pacote forward descartado: "
    iptables -A FORWARD -j DROP

    #Abre algumas portas
    iptables -A INPUT -p tcp --destination-port 25 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 110 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 143 -j ACCEPT

    #Abre para rede local
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT

    #Fecha o resto
    iptables -A INPUT -p tcp --syn -j DROP

  2. #2

    Padrão Re: Meu outlook continua naum funcionando... por favor me aj

    Cara o gateway das estaçoes e o ip da placa de rede interna!!!

    Tente usar assim o seu script


    # Carrega os módulos
    modprobe iptables
    modprobe iptable_nat

    #Abre algumas portas
    iptables -A INPUT -p tcp --destination-port 25 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 110 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 143 -j ACCEPT

    #Compartilha a conexão
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #Abre para rede local
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT

    #Fecha o resto
    iptables -A INPUT -p tcp --syn -j DROP


    Qualquer coisa posta ai !!!



  3. #3
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    e ai blz? eu fiz exatamente como vc falou... mas naum consigo acessar a internet nos clientes sem startar o squid.... no servidor após conectar a inernet (adsl-start) eu uso o seguinte comando:

    route del -net 0.0.0.0
    route add -net 0.0.0.0/0 dev ppp0
    route del default
    route add default ppp0

    se eu naum usar isso naum consigo acessar site algum... mesmo com o squid startado... isso pode influenciar em algo?

    e outra coisa, no servidor eu consigo pingar pop.jnd.terra.com.br p é o pop do terra, mas nos clientes o outlook naum funfa.....

  4. #4
    dispatcher
    Visitante

    Padrão Meu outlook continua naum funcionando

    mrpicolo , só uma perguntinha:
    pra que vc esta usando a faixa de enderecos 90.0.0.0 nestas regras?

    #Outlook
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 25 -j ACCEPT
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 25 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 21 -j ACCEPT



  5. #5
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    eu num tinha visto... mas corrigi e mesmo assim naum funcionou...

  6. #6

    Padrão iptables

    Bom, se vc usa ip dinamico, na linha do nat tem que substituir o eth1 por ppp0, senão não funciona:

    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    Se for ip fixo (speedy business), deixa do jeito que está.



  7. #7
    felco
    Visitante

    Padrão Re: Meu outlook continua naum funcionando... por favor me aj

    Citação Postado originalmente por gatoseco
    iptables -A INPUT -p tcp --destination-port 25 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 110 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 143 -j ACCEPT
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT
    O INPUT eh expecificamente para conexoes destinadas a maquina firewall nao há necessidade de abrir essas portas ao menos que:
    Se tenha um servidor smtp (porta 25)
    Se tenha um servidor pop (porta 110)

    Agora essa porta 143 eu desconheco...
    Detalhe a porta 22 (ssh) acredito ter utilidade...
    iptables -A INPUT -p tcp --destination-port 22 -j ACCEPT

  8. #8

    Padrão Meu outlook continua naum funcionando

    vc tá usando proxy transparente ou tá setando o proxy no navegador?



  9. #9
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    eu alterei meu meu firewall para:

    #carrega modulos
    modprobe ip_tables
    modprobe iptable_nat

    #mascaramento
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    #roteamento
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #abre rede local
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT

    #outlook
    iptables -A FORWARD -p tcp -i eth0 --dport 25 -j ACCEPT
    iptables -A FORWARD -p tcp -i eth0 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp -i eth1 --sport 25 -j ACCEPT
    iptables -A FORWARD -p tcp -i eth1 --sport 110 -j ACCEPT


    mas naum consigo conectar a internet nos clientes sem startar o squid... e meu outlook num funfa.... no firewall na parte #outlook onde está eth0 não seria eth1 e onde esta eth1 não seria eth0, pois a placa q conecta com o speedy é a eth1....

  10. #10

    Padrão Tente simplificar...

    Cara, tente rodar só com o masquerade, depois vá acrescentando as outras regras. Comigo sempre dá certo.

    Boa sorte !



  11. #11
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    deixar só o carregamento dos modulos, o masquerade e o echo 1 > /proc.... ? só esse e tentar fazer conectar a ineternet nos clientes?

  12. #12

    Padrão Menos é mais

    Isso ai. Tem que funcionar tudo, depois voce vai acrescentando as regras e testando uma por uma.

    Menos é mais, já dizia alguém aí.



  13. #13

    Padrão Meu outlook continua naum funcionando

    Citação Postado originalmente por mrpicolo
    deixar só o carregamento dos modulos, o masquerade e o echo 1 > /proc.... ? só esse e tentar fazer conectar a ineternet nos clientes?
    Amigo, vc nao está fazendo nem proxy transparente, nem mascaramento... onde tá lá:

    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    mude para:

    iptables -t nat -A POSTROUTING -o ethX -j MASQUERADE

    onde ethx é a interface que se conecta à internet.

  14. #14
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    eu dexei apenas isso no meu arquivo de inicialização:

    #carrega modulos
    modprobe ip_tables
    modprobe iptable_nat

    #mascaramento
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    #roteamento
    echo 1 > /proc/sys/net/ipv4/ip_forward

    e naum consigo conectar a internet nos clientes... olha as configurações
    a eth0 tem ip 192.168.143.110 e a eth1 tem ip 192.168.143.210 e é com a eth1 que eu conecto a internet....

    no cliente q é windows xp eu coloquei gateway 192.168.143.210 e os dns do terra... 200.204.0.10 e 200.204.0.138



  15. #15
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    eu alterei para
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

    e tb naum funfou... e agora?

  16. #16

    Padrão Esse numero tá certo...

    Vc disse q sua eth0 e final 110 e q o gateway é final 210 ?

    isso tá certo ?

    O gateway tem q ser o IP da placa q esta na rede. E se sua internet for IP dinamico com autenticação tem q ser ppp0, não eth1 na linha do nat.

    Eu sempre monto assim, e sempre dá certo. Agora, se vc não precisa logar na internet usando adsl, então é eth1 mesmo.

    Confira tudo de novo e boa sorte.



  17. #17

    Padrão Meu outlook continua naum funcionando

    Citação Postado originalmente por mrpicolo
    eu alterei para
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

    e tb naum funfou... e agora?
    Verifique se no browser vc nao setou o proxy...

    Se vc startar o squid e quiser navegar através dele, coloque o proxy no browser, senão, basta manter seu firewall rodando e tirar o proxy do browser

  18. #18
    mrpicolo
    Visitante

    Padrão Meu outlook continua naum funcionando

    quando starto o squid eu seto no browser o proxy... mas pra testar sem squid eu tiro....



  19. #19

    Padrão Meu outlook continua naum funcionando

    Citação Postado originalmente por mrpicolo
    quando starto o squid eu seto no browser o proxy... mas pra testar sem squid eu tiro....
    Neste caso verifique o Gateway, se com squid funfa, sem squid nao funfa, e as regras estão corretas, verifique se gateway e DNS estão corretos, se não adiantar ranca todas as regras do firewall e deixa só:

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE