+ Responder ao Tópico



  1. #1
    honae
    Visitante

    Padrão Auntenticação de estações Windows 2000 no samba

    Galera,

    tenho uma rede com um servidor linux Debian - Kernel 2.4.x e várias estações Windows 2000. No servidor existe uma pasta pública que é acessada por todos os usuários da rede( segue o smb.conf ).
    Quero fazer com que as estações façam autenticação no samba e que essa pasta pública continue sendo compartilhada.
    O que devo fazer?

    Grato!

    Hélio

    # Global parameters
    [global]
    workgroup = ILHEUS
    netbios name = TLINKSERVER
    server string = Servidor-tlinkserver
    security = SHARE
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    invalid users = root
    read only = No


    [homes]
    comment = Home Directories
    read only = Yes
    create mask = 0700
    directory mask = 0700
    browseable = No

    [pastacompartilhada]
    comment = Pasta Publica
    path = /etc/samba/pastacompartilhada
    create mask = 0777
    force create mode = 0777
    force security mode = 0777
    directory mask = 02777
    force directory mode = 02777
    directory security mask = 02777
    force directory security mode = 02777
    guest ok = yes
    sync always = Yes
    oplocks = No
    posix locking = No
    strict locking = Yes

  2. #2
    jamba
    Visitante

    Padrão Auntenticação de estações Windows 2000 no samba

    Se ja tiver os usuarios criados no samba crie=os tb nas estacoes com a mesma senha do samba.

    Agora achei meio estranho vc colocar sua pasta_comprtilhada no /etc/samba.....seria mais conveniente colocar em /home.

    E nao esquece de criar os arquivos .bat dos usuarios tb



  3. #3
    charadaa
    Visitante

    Padrão Auntenticação de estações Windows 2000 no samba

    voce tambem pode criar um mapeamento de rede do windows 2000 apontando para este diretorio publico basta inserir o nome de usuario e senha na opção "outro usuario" do windows 2000 na hora de criar o mapeamento.

  4. #4
    honae
    Visitante

    Padrão Auntenticação de estações Windows 2000 no samba

    Citação Postado originalmente por jamba
    Se ja tiver os usuarios criados no samba crie=os tb nas estacoes com a mesma senha do samba.

    Agora achei meio estranho vc colocar sua pasta_comprtilhada no /etc/samba.....seria mais conveniente colocar em /home.

    E nao esquece de criar os arquivos .bat dos usuarios tb
    veja o que eu fiz:

    configurei o arquivo smb.conf:


    # Global parameters
    [global]
    workgroup = ILHEUS
    netbios name = TLINKSERVER
    server string = Servidor-tlinkserver
    security = user
    unix password sync = Yes
    smb passwd file = /etc/samba/smbpasswd
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    domain logons = Yes
    preferred master = Yes
    domain master = Yes
    dns proxy = No
    invalid users = root
    read only = No


    [homes]
    comment = Home Directories
    valid users = %S
    read only = no
    create mask = 0664
    directory mask = 0775
    browseable = No

    [pastacompartilhada]
    comment = Pasta Publica
    path = /etc/samba/pastacompartilhada
    create mask = 0777
    force create mode = 0777
    force security mode = 0777
    directory mask = 02777
    force directory mode = 02777
    directory security mask = 02777
    force directory security mode = 02777
    guest ok = yes
    sync always = Yes
    oplocks = No
    posix locking = No
    strict locking = Yes


    adicionei root no smbpasswd:

    # smbpasswd -a root

    depois criei um usário referente à máquina:

    # useradd -d /dev/null -c techlink02 -m -s /bin/false techlink02$(detalhe ->não me pediu senha)

    depois adicionei o usuário techlink02 no smbpasswd:
    # smbpassword -m -a techlink02

    depois restart no samba

    fui no pc techlink02 e mudei tentei mudar sua identificação de rede para:
    nome da máquina - techlink02

    membro de:

    Domínio: ILHEUS

    ele me pede um usário e uma senha:

    usuário: root
    senha: senha do root

    dá uma mensagem de erro: Falha no logon - nome do usuário ou senha inválidos

    Que é que eu posso fazer?



  5. #5
    edinh0
    Visitante

    Padrão Auntenticação de estações Windows 2000 no samba

    Opa !!!

    veja q na secao [global] vc negou o usuario root

    invalid users = root

    verifique se a sua estacao estah encontrando o servidor tlinkserver, caso estiver crie no linux(adduser/passwd) o mesmo usuario q vc estah usando no samba, com as devidas permissoes. Faça esse teste e veja se resolve !!

    []'s

  6. #6

    Padrão Auntenticação de estações Windows 2000 no samba

    Outra coisa amigo. Além do que já mencionaram.
    Também temos estações win2000 e xp autenticando no nosso servidor Samba .
    Nessas estações windows, ainda tive que fazer o seguinte :
    Vá em iniciar, configurações, ferramentas administrativas , diretivas locais, opções de segurança. Acho que é esse o caminho.
    Tenho que olhar direitinho lá na empresa. Mas acho que é isso.
    Bom quando chegar no último item, vai aparecer uma tela com n opções que podem estar ativadas ou desativadas.
    Procure uma que fala para não enviar senha criptografada em servidor SMB e coloque como ativada.
    Pelo menos fazemos isso aqui e sempre deu certo.
    Um abraço .........