+ Responder ao Tópico



  1. #1

    Padrão cron não funfa!!!

    eu coloco funções no cron, mas ele não funfa, por exemplo...

    * 19 * * * /bin/mozilla <-- crontab do usarios
    * 19 * * * root /bin/mozilla <-- /etc/crontab

    ele não executa o mozilla, mas a cada minuto que passa, ele consome processador, mas nada d mozilla!!!

    ja coloquei no /etc/crontab e no e com o comando crontab -u root -e

    nenhum funfo!!

    alguém sabe o que pode ser?

    valeu!!!

  2. #2

    Padrão cron não funfa!!!

    Vc quer rodar o mozilla que horas??

    se for 19 horas faz assim 0 19 * * * /bin/mozilla

    ps veja se esse eh o path do mozilla mesmo



  3. #3

    Padrão cron não funfa!!!

    eu acho q o cron ta executando sim, mas como o mozilla requer ambiente grafico, e o cron eh executado em shell e em background nao tem nada aparecendo.....

  4. #4

    Padrão cron não funfa!!!

    Eh deve ser isso mesmo Ice.

    falows



  5. #5

    Padrão cron não funfa!!!

    naum funfava exatamente pq eu tava tentano roda aplicativo grafico!!!

    valeu!!!

  6. #6
    gmlinux
    Visitante

    Padrão cron não funfa!!!

    Com o X executado, no cron do user que o executou (por causa do .Xauthority), se a variável DISPLAY estiver setada no cron, deve funcionar.



  7. #7
    whinston
    Visitante

    Padrão 2 motivos

    a galera ja disse, mas vc agendou pra rodar a cada minuto da hora 19, ou seja, 60 vezes!!! minuto 0, 1, 2, 3....

    se o mozilla aparece no top e no ps, ele ta em execução, mas a saída não está aparecendo, por falta de interface gráfica. se vc tiver no console, axo que não aparece mesmo, já no X, é pra aparecer.

  8. #8
    gmlinux
    Visitante

    Padrão cron não funfa!!!

    No X não é para aparecer, apenas se o cron estiver configurando a variável DISPLAY e o server X estiver autorizando (via xhost ou Xauth, ,por exemplo)