+ Responder ao Tópico



  1. #1
    danilo__
    Visitante

    Padrão impossivel instalar driver da nvidia

    Ola pessoal, eu estou usando o slackware 10.1 com kernel 2.6.11 e tenho uma GeForce FX 5200 de 128MB eu baixei o ultimo driver da nVidia
    Acontece q apos a instalaçao recompilar o kernel (depois do building kernel) ele me retorna o seguinte erro:

    ERROR: Unable to build the NVIDIA kernel module.
    ERROR: Installation has failed. Please see the file
    '/var/log/nvidia-installer.log' for details. You may find suggestions
    on fixing installation problems in the README available on the Linux
    driver download page at www.nvidia.com.

    e no log (apenas onde tinha os warnings e errors) tava o seguinte:

    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:642: warning
    : implicit declaration of function `pci_find_class'
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:642: warning
    : assignment makes pointer from integer without a cast
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:653: warning
    : assignment makes pointer from integer without a cast
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:1161: warnin
    g: `pm_register' is deprecated (declared at include/linux/pm.h:106)
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:1279: warnin
    g: `pm_unregister' is deprecated (declared at include/linux/pm.h:111)
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:1764: warnin
    g: implicit declaration of function `remap_page_range'
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:2732: warnin
    g: passing arg 1 of `pmd_offset' from incompatible pointer type
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3324: warnin
    g: `inter_module_put' is deprecated (declared at include/linux/module.h:578)
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3474: warnin
    g: assignment makes pointer from integer without a cast
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3479: warnin
    g: assignment makes pointer from integer without a cast
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3677: error:
    `PM_SAVE_STATE' undeclared (first use in this function)
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3677: error:
    (Each undeclared identifier is reported only once
    /tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.c:3677: error:
    for each function it appears in.)
    make[3]: *** [/tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv/nv.
    o] Error 1
    make[2]: *** [_module_/tmp/selfgz23348/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/sr
    c/nv] Error 2
    NVIDIA: left KBUILD.
    nvidia.ko failed to build!
    make[1]: *** [module] Error 1
    make: *** [module] Error 2

    foi isso o q aconteceu no log

    ja procurei pela net e nao encontrei nada a respeito, se alguem puder me ajudar ficaria muito grato

    obrigado

  2. #2

    Padrão impossivel instalar driver da nvidia

    Tá faltando alguma biblioteca aí pra ti...


    Abraços!



  3. #3
    danilo__
    Visitante

    Padrão impossivel instalar driver da nvidia

    poxa qual biblioteca seria? levando em consideraçao q eu fiz a instalaçao full

  4. #4

    Padrão impossivel instalar driver da nvidia

    so pra te avisar vc nao ta com o ultimo driver, pega ele aqui: http://www.nvidia.com/object/linux_d..._1.0-6629.html

    e tenta de nvo

    falows



  5. #5
    danilo__
    Visitante

    Padrão impossivel instalar driver da nvidia

    Citação Postado originalmente por ruyneto
    so pra te avisar vc nao ta com o ultimo driver, pega ele aqui: http://www.nvidia.com/object/linux_d..._1.0-6629.html

    e tenta de nvo

    falows
    entao, eu tentei instalar com os tres ultimos drivers, este q vc falou e os dois antes desse e nenhum deles funcionou, todos deram o mesmo erro


    ta dificil de achar uma soluçao aqui...

  6. #6

    Padrão impossivel instalar driver da nvidia

    Se vc compilou o kernel com a opção para driver NVIDIA habilitado como Built-in vai dar problemas quando tentar instalar um driver da NVIDIA como módulo. Reconfigure o kernel habiltando o driver Nvidia como modulo (m) e recompile o kernel, depois reinstale o driver.




    Valeu...



  7. #7
    danilo__
    Visitante

    Padrão impossivel instalar driver da nvidia

    manser foi justamente isso q eu fiz
    eu compilei o novo kernel com suporte pra nvidia como built-in, eu vou recompila-lo e tentar instalar o driver novamente, e depois posto aqui os resultados

    vlw pela atençao de vcs!!!!

  8. #8
    danilo__
    Visitante

    Padrão impossivel instalar driver da nvidia

    eu recompilei o kernel colocando aquelas configuraçoes da nvidia como modulo, mas mesmo assism nao deu certo, continua dando o mesmo erro

    ta dificil viu...



  9. #9

    Padrão impossivel instalar driver da nvidia

    pelo que andei lendo
    o driver da nvidia tem problemas com o kernel 2.6.11
    teste o 2.6.10 e verá que não ocorrerão esses problemas

    tentei uns patchs que achei, mas nenhum dá certo, continua dando aquele Unable To Build....

    agora é esperar uma solução da nVidia

    []'s
    Robson

  10. #10
    drginfo
    Visitante

    Padrão impossivel instalar driver da nvidia

    tenta seguir os passos de instalação Carlos Morimoto do Kurumin, segue abaixo os links:

    http://www.guiadohardware.net/artigos/235/
    http://www.guiadohardware.net/linux/dicas/67.htm

    ve se estes links te ajudam!!



  11. #11

    Padrão Solução NV

    Ei amigo, oque acontece é o seguinte, o proplema não esta no kernel mas sim com a versão do gcc que foi usada na compilação do mesmo,
    mas deixando isso de lado existe uma forma de instalar o driver da NVIDIA sem precisar recompilar o kernel, segue a sintaxe abaixo:

    --pare a execusção do kdm

    # /etc/ini.d/kdm stop (para distro baseada no Debian) ou
    # service kdm stop

    antes de instalar o driver NV digite estes comandos:

    IGNORE_CC_MISMATCH=1
    IGNORE_CC_MISMATCH=yes

    export IGNORE_CC_MISMATCH=1
    export IGNORE_CC_MISMATCH=yes

    isso fará com que o instalador do driver NV não verifique e ignore a versão do gcc.

    depois instale o driver NV digitando estes comandos:

    ./Arquivo NV --force-tls=classic

    e pronto!!! :-)

    depois deste processo altere o arquivo XF86config.

    e execute novamente o kdm se aparecer o logo da NV antes da tela de loguin, ocorreu tudo bem.

    Demais configurações e problemas poste aqui!!!!!!!


    Robson Franklin


    VIVA o LINUX!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!