+ Responder ao Tópico



  1. #1

    Padrão Alguem ja viu esse erro?

    Ola pessoal!

    Estou com seguinte problema, todo programa que tento instalar usando o installpkg, ele retorna este erro:
    Installing package glibc-2.3.2-i486-6.tgz (Priority: [unknown])...
    PACKAGE DESCRIPTION:
    Unable to install glibc-2.3.2-i486-6.tgz: tar archive is corrupt (tar returned error code 1)

    Pensei que pudesse ser o pacote corrompido mais ja usei diversas versoes e outros pacotes e o resultado e sempre o mesmo.

    Quem souber ajuda ai...

    Obrigadao!

  2. #2

    Padrão Alguem ja viu esse erro?

    glibc 2.3?
    num ta meio desatualizado isso ae nao?? 8O

    pega os pacotes que vc precisa aqui: www.linuxpackages.net
    ou entaum utilize o swaret



  3. #3

    Padrão Alguem ja viu esse erro?

    Citação Postado originalmente por 1c3_m4n
    glibc 2.3?
    num ta meio desatualizado isso ae nao?? 8O

    pega os pacotes que vc precisa aqui: www.linuxpackages.net
    ou entaum utilize o swaret

    Fico muito grato pela dica, mais no meu caso eu preciso que a ferramenta pkg esteja funcionando, o pacote do glibc foi como demonstracao pra retornar o erro, porem todos os pacotes que tento instalar retorna este erro mencionado no topico..

    Ajuda ai galera!

    Valeu!

    Standart

  4. #4

    Padrão Alguem ja viu esse erro?

    todos os pacotes???????
    xiiii
    bom agora to sem meu slack aki pra olhar mas se nao me engano tem uma opcao do installpkg pra ele nao verificar o arquivo
    ve se vc acha

    installpkg --help



  5. #5
    LenTu
    Visitante

    Padrão Alguem ja viu esse erro?

    fikei curioso e dei uma fuçada aki... .

    #man installpkg

    num achei nada do genero.. 8O

    :wink:

  6. #6

    Padrão Alguem ja viu esse erro?

    Citação Postado originalmente por 1c3_m4n
    todos os pacotes???????
    xiiii
    bom agora to sem meu slack aki pra olhar mas se nao me engano tem uma opcao do installpkg pra ele nao verificar o arquivo
    ve se vc acha

    installpkg --help
    Legal!

    Se tiver mesmo esta opcao da ferramenta pkg naum checar o arquivo tentarei descobri aqui....
    Brigadao, pela forca aos manos que estaumm postando ai...
    Quem tiver algo de mais concreto ajuda ai..


    Standart



  7. #7

    Padrão Alguem ja viu esse erro?

    perai tive uma ideia..... ele ta dando em todos os arquivos neh? faz um teste ae, pega um .tar.gz qq e tenta descompactar e ve se vai dar erro.... se der o pau ta no teu tar e nao no installpkg

  8. #8

    Padrão Alguem ja viu esse erro?

    Citação Postado originalmente por 1c3_m4n
    perai tive uma ideia..... ele ta dando em todos os arquivos neh? faz um teste ae, pega um .tar.gz qq e tenta descompactar e ve se vai dar erro.... se der o pau ta no teu tar e nao no installpkg
    Opa!

    Ola o que retornou do teste que vc idealizou!

    tar: /lib/libc.so.6: version `GLIBC_2.3' not found (required by tar)

    E ai ?
    O que devo fazer agora?

    Valeu!



  9. #9

    Padrão Alguem ja viu esse erro?

    xiiiiiiiiii me parece q vc removeu coisa q nao devia do sistema... primeiro ve se vc acha o arquivo libc.so.6 se nao achar vc vai ter que reinstalar o glibc...

  10. #10

    Padrão Alguem ja viu esse erro?

    Citação Postado originalmente por 1c3_m4n
    xiiiiiiiiii me parece q vc removeu coisa q nao devia do sistema... primeiro ve se vc acha o arquivo libc.so.6 se nao achar vc vai ter que reinstalar o glibc...

    Como vou fazer isso na mao grande?

    Da uma dica ai...!

    VAleu Bro!

    Standart



  11. #11

    Padrão Alguem ja viu esse erro?

    bom... pra procurar o arquivo find / -name libc.so.6

    agora pra reinstalar vai ser complicado, vai precisar de sorte
    jah q o tar nao funfa, nem nada q dependa do gcc... vc vai ter que bootar por um cd, montar a particao do hd q tem o linux ai vc faz:

    cd /mnt/particao
    tar -zxvf path_do_glibc.tar.gz

    ai ele vai copiar os arquivos pro teu hd, teoricamente pro lugar certo....
    mas nao da pra garantir neh

  12. #12

    Padrão Alguem ja viu esse erro?

    Muito Obrigado mano 1c3_m4n!

    Vou pensar no que fazer, mais desde ja gostaria de pedir que se alguem tiver mais sugestoes, para a solucao do mesmo, posta ai.

    Há!

    Do comando find / -name libc.so.6 retornou o seguinte:

    /lib/libc.so.6

    Valeu galera!

    Citação Postado originalmente por 1c3_m4n
    bom... pra procurar o arquivo find / -name libc.so.6

    agora pra reinstalar vai ser complicado, vai precisar de sorte
    jah q o tar nao funfa, nem nada q dependa do gcc... vc vai ter que bootar por um cd, montar a particao do hd q tem o linux ai vc faz:

    cd /mnt/particao
    tar -zxvf path_do_glibc.tar.gz

    ai ele vai copiar os arquivos pro teu hd, teoricamente pro lugar certo....
    mas nao da pra garantir neh



  13. #13

    Padrão Alguem ja viu esse erro?

    E ai camarada?! BLZ?

    Ai, parece que tem estrago na sua Glibc.E sem ela nada de instalar pkgs...
    Então tenta uma coisa ai, sei-la talvez funcione...

    Dê boot pelo cd do slack e monte a sua partição onde esta instalado o seu slack, tipo /dev/hda2 em /raiz ( crie antes este dir com mkdir /raiz).Depois de um chroot /raiz, entre no dir do cdrom em slackware/l e tente instalar a glibc com installpkg.


    Valeu, espero que de certo...

  14. #14

    Padrão Alguem ja viu esse erro?

    tb pensei nisso, mas com chroot num vai dar... pq dentro do chroot soh vai ter os binarios que estao ferrados =/



  15. #15
    nod3vic3
    Visitante

    Padrão Alguem ja viu esse erro?

    Aí cara, blz

    Sei lá se vale a dica, mas pega aí o cd do seu slack e tenta reinstalar ele.

    É só não formatar que voce não perde nada. Porém não tenho certeza se ele vai sobrescrever ou vai manter os pacotes que já estão instalados.

    Mas tenta aí.

  16. #16

    Padrão Alguem ja viu esse erro?

    Alguem ja fez esta acao e deu certo?
    Grato,

    standart
    Citação Postado originalmente por nod3vic3
    Aí cara, blz

    Sei lá se vale a dica, mas pega aí o cd do seu slack e tenta reinstalar ele.

    É só não formatar que voce não perde nada. Porém não tenho certeza se ele vai sobrescrever ou vai manter os pacotes que já estão instalados.

    Mas tenta aí.



  17. #17
    felco
    Visitante

    Padrão Alguem ja viu esse erro?

    pega o arquivo do livecd eh copia pro seu hd eh a mesma compilacao nao da segfault